[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / xv

File: [cvs.NetBSD.org] / pkgsrc / graphics / xv / Makefile (download)

Revision 1.62, Sat Mar 4 21:29:52 2006 UTC (17 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.61: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.62 2006/03/04 21:29:52 jlam Exp $

DISTNAME=	xv-3.10a
PKGREVISION=	11
CATEGORIES=     graphics x11
MASTER_SITES=	ftp://ftp.cis.upenn.edu/pub/xv/
#DISTFILES=	${DISTNAME}${EXTRACT_SUFX}

PATCHFILES=	xv-3.10a-jumbo-patches-20050501.tar.bz2
PATCH_SITES=	${MASTER_SITE_SOURCEFORGE:=png-mng/}
PATCH_DIST_CAT=		${BZCAT} $$patchfile | ${TAR} -Oxf - "*-patch-*"
PATCH_DIST_STRIP=	-p1

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.trilon.com/xv/
# and...	http://www.sonic.net/~roelofs/greg_xv.html
COMMENT=	X11 program that displays images of various formats

USE_IMAKE=	YES

# See the end of README in work/xv-3.10a for details.
RESTRICTED=	"Distribution of modified copies and commercial distribution is not permitted."
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_FTP=		${RESTRICTED}

LICENSE=	xv-license

.include "../../mk/bsd.prefs.mk"

pre-configure:
	${MV} ${WRKSRC}/config.h ${WRKSRC}/config.h.orig &&		\
		${SED} -e 's|@LOCALBASE@|${LOCALBASE}|g'		\
		${WRKSRC}/config.h.orig > ${WRKSRC}/config.h

.if ${OPSYS} == "SunOS"
post-configure:
	${MV} ${WRKSRC}/${MAKEFILE} ${WRKSRC}/${MAKEFILE}.orig &&	\
		${SED} -e 's| CC = .*| CC = ${CC}|'			\
		-e 's| CCOPTIONS = .*| CCOPTIONS = ${CFLAGS}|'		\
		-e 's| CDEBUGFLAGS = .*| CDEBUGFLAGS =|'		\
		${WRKSRC}/${MAKEFILE}.orig > ${WRKSRC}/${MAKEFILE}
.endif

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/xv
	${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xv
	${INSTALL_DATA} ${WRKSRC}/docs/xvdocs.ps ${PREFIX}/share/doc/xv

.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"