[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / xfig

File: [cvs.NetBSD.org] / pkgsrc / graphics / xfig / Makefile (download)

Revision 1.77, Wed May 20 06:09:09 2020 UTC (3 years ago) by rillig
Branch: MAIN
Changes since 1.76: +7 -1 lines

mark packages that fail with -Werror=char-subscripts

These packages are susceptible to bugs when confronted with non-ASCII
characters.

See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=94182.

It takes some time to analyze and fix these individually, therefore they
are only marked as "needs work".

# $NetBSD: Makefile,v 1.77 2020/05/20 06:09:09 rillig Exp $

DISTNAME=	xfig-3.2.6a
PKGNAME=	${DISTNAME:S/-full//}
PKGREVISION=	1
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=mcj/}
EXTRACT_SUFX=	.tar.xz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://mcj.sourceforge.net/
COMMENT=	CAD-like 2D drawing tool, good for colorful scale drawings & ISOs

DEPENDS+=	fig2dev-[0-9]*:../../print/fig2dev

XAW_TYPE?=		3d

GNU_CONFIGURE=		yes

CONFIGURE_ARGS+=	--with-appdefaultdir=${PREFIX}/lib/X11/app-defaults

# w_cmdpanel.c: In function 'change_orient':
# w_cmdpanel.c:893:36: error: array subscript has type 'char' [-Werror=char-subscripts]
#      FirstArg(XtNlabel, orient_items[appres.landscape]);
# Maybe fix this later.
BUILDLINK_TRANSFORM+=	rm:-Werror=char-subscripts

.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../x11/libXi/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
# if we're using Xaw3d, then we need 1.5E or newer since using that
# version means we need a patch, which is currently used unconditionally
BUILDLINK_API_DEPENDS.Xaw3d+=	Xaw3d>=1.5E
.include "../../mk/xaw.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"