File:  [cvs.NetBSD.org] / pkgsrc / graphics / veusz / Makefile
Revision 1.67: download - view: text, annotated - select for diffs
Mon Oct 12 21:52:01 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile,v 1.67 2020/10/12 21:52:01 bacon Exp $

DISTNAME=		veusz-3.1
PKGREVISION=		7
CATEGORIES=		graphics
MASTER_SITES=		${MASTER_SITE_GITHUB:=veusz/}
GITHUB_RELEASE=		${DISTNAME}

MAINTAINER=		pkgsrc-users@NetBSD.org
#HOMEPAGE=		https://veusz.github.io/
COMMENT=		Scientific plotting package
LICENSE=		gnu-gpl-v2

USE_LANGUAGES=		c c++

REPLACE_PYTHON+=	examples/embedexample.py
REPLACE_PYTHON+=	veusz/veusz_listen.py
REPLACE_PYTHON+=	veusz/veusz_main.py

INSTALLATION_DIRS+=	share/applications
INSTALLATION_DIRS+=	share/icons/hicolor/128x128/apps
INSTALLATION_DIRS+=	share/icons/hicolor/16x16/apps
INSTALLATION_DIRS+=	share/icons/hicolor/32x32/apps
INSTALLATION_DIRS+=	share/icons/hicolor/48x48/apps
INSTALLATION_DIRS+=	share/icons/hicolor/64x64/apps
INSTALLATION_DIRS+=	share/icons/hicolor/scalable/apps
INSTALLATION_DIRS+=	share/mime/packages

ALL_ENV+=		QMAKE_EXE=${QTDIR}/bin/qmake
ALL_ENV+=		SIP_DIR=${PREFIX}/share/sip${PYVERSSUFFIX}

post-install:
	${INSTALL_DATA} ${WRKSRC}/support/veusz.desktop \
		${DESTDIR}${PREFIX}/share/applications
	for s in 16 32 48 64 128;do \
		${INSTALL_DATA} ${WRKSRC}/icons/veusz_$${s}.png \
			${DESTDIR}${PREFIX}/share/icons/hicolor/$${s}x$${s}/apps/veusz.png; \
	done
	${INSTALL_DATA} ${WRKSRC}/icons/veusz.svg \
		${DESTDIR}${PREFIX}/share/icons/hicolor/scalable/apps
	${INSTALL_DATA} ${WRKSRC}/support/veusz.xml \
		${DESTDIR}${PREFIX}/share/mime/packages

.include "../../databases/shared-mime-info/mimedb.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../lang/python/distutils.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../x11/py-qt5/buildlink3.mk"
.include "../../x11/py-sip/buildlink3.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>