[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / tiff

File: [cvs.NetBSD.org] / pkgsrc / graphics / tiff / Makefile (download)

Revision 1.42, Sun Oct 20 09:15:23 2002 UTC (21 years, 6 months ago) by jlam
Branch: MAIN
Changes since 1.41: +11 -20 lines

Use bsd.pkg.install.mk and change INSTALL.OpenWindows into a model for how
to replace the complexity of the default INSTALL/DEINSTALL scripts with
something simpler when simple is all that's needed.  Also replace the
check for OpenWindows with one that's more sensible.

# $NetBSD: Makefile,v 1.42 2002/10/20 09:15:23 jlam Exp $

DISTNAME=	tiff-v3.5.7
PKGNAME=	tiff-3.5.7
CATEGORIES=	graphics
MASTER_SITES=	ftp://ftp.remotesensing.org/pub/libtiff/
DISTFILES=	${DISTNAME}${EXTRACT_SUFX}
# need DISTFILES above for adding lzw-files to it if USE_GIF is defined
# in mk.conf

MAINTAINER=	packages@netbsd.org
HOMEPAGE=	http://www.libtiff.org/
COMMENT=	Library and tools for reading and writing TIFF data files

USE_BUILDLINK2=	# defined
USE_LIBTOOL=	# defined
HAS_CONFIGURE=	# defined
CONFIGURE_ARGS=	--noninteractive --site=${FILESDIR} --prefix=${PREFIX}

.include "../../mk/bsd.prefs.mk"

.if defined(USE_GIF)
LZW_VERSION=	1.3
DISTFILES+=	libtiff-lzw-compression-kit-${LZW_VERSION}.tar.gz
LZWWRKDIR=	${WRKDIR}/libtiff-lzw-compression-kit-${LZW_VERSION}

post-patch:
	${CP} ${LZWWRKDIR}/tif_lzw.c ${WRKSRC}/libtiff
.endif

CPPFLAGS+=	-Dunix
CONFIGURE_ENV+=	PREFIX="${PREFIX}"
CONFIGURE_ENV+=	ENVOPTS="${CFLAGS} ${CPPFLAGS}"

pre-patch:
	# reference correct relative man page when using .so
	#
	${MV} ${WRKSRC}/man/Makefile.in ${WRKSRC}/man/Makefile.in.in
	${SED}	-e "s,\$${MANDIR}\(.*\)\.\([0-9]\).,\1.\2,g" \
		-e "s,\$${MANDIR}\(.*\)\.\([0-9]\),\1.\2,g" \
		${WRKSRC}/man/Makefile.in.in  > ${WRKSRC}/man/Makefile.in

	# libtoolize build of TIFF tools
	#
	${MV} ${WRKSRC}/tools/Makefile.in ${WRKSRC}/tools/Makefile.in.in
	${SED}	-e "s,\(\$${CC} -o\),\$${LIBTOOL} \1,g" \
		${WRKSRC}/tools/Makefile.in.in  > ${WRKSRC}/tools/Makefile.in

.include "../../devel/zlib/buildlink2.mk"
.include "../../graphics/jpeg/buildlink2.mk"

.if !empty(X11BASE:M*openwin)
INSTALL_TMPL=	${.CURDIR}/INSTALL.OpenWindows
DEINSTALL_TMPL=	${INSTALL_TMPL}

.  include "../../mk/bsd.pkg.install.mk"
.endif

.include "../../mk/bsd.pkg.mk"