The NetBSD Project

CVS log for pkgsrc/graphics/ruby-gnome2-clutter-gdk/Attic/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / graphics / ruby-gnome2-clutter-gdk

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.16
Sat Sep 14 18:11:35 2019 UTC (5 years, 2 months ago) by tsutsui
Branches: MAIN
CVS tags: HEAD
FILE REMOVED
Changes since revision 1.15: +1 -1 lines
ruby-gnome: Update to 3.3.8, and rename package names to match gems.

Also reorganize several dependencies in Makefile and buildlink3.mk.
See the following post for details:
 https://mail-index.netbsd.org/pkgsrc-users/2019/09/07/msg029327.html
 https://mail-index.netbsd.org/pkgsrc-users/2019/09/13/msg029356.html

Upstream changes (from NEWS):

== Ruby-GNOME 3.3.8: 2019-09-10

This is a partially GLib 2.62.0 support release.

=== Changes

==== All

  * Improvements

    * Changed our project name to Ruby-GNOME from Ruby-GNOME2.
      [GitHub#1277][Suggested by kojix2]
      [GitHub#1291][Patch by kojix2]

    * Stopped to release (({.tar.gz})) because they are no longer
      used.

==== Ruby/GLib2

  * Improvements

    * (({GLib.convert})): Changed to set correct encoding.

    * (({GLib::FILENAME_ENCODING})): Added.

    * Changed to use the same enum object for the same enum value.

    * (({GLib::Enum.find})): Added.

    * (({GLib::Bytes#initialize})): Changed to reuse (({String})) data
      even if the given (({String})) isn't frozen.

    * (({GLib::Bytes.try_convert})): Added.

    * (({GLib::Enum.try_convert})): Added.

    * (({GLib::Flags.try_convert})): Added.

    * (({GLib::Type.try_convert})): Added.

    * (({GLib::MkEnums.create})): Added support for flags to enum
      definition.
      [GitHub#1295][Patch by Mamoru TASAKA]

==== Ruby/GIO2

  * Fixes

    * Renamed to (({Gio::Icon#hash})) from (({Gio::Icon.hash})).
      [GitHub#1293][Reported by Erik Czumadewski]

==== Ruby/GObjectIntrospection

  * Improvements

    * Introduced (({try_convert})) protocol.

==== Ruby/CairoGObject

  * Improvements

    * (({Cairo::Context.try_convert})): Added.

    * (({Cairo::Device.try_convert})): Added.

    * (({Cairo::Pattern.try_convert})): Added.

    * (({Cairo::Surface.try_convert})): Added.

    * (({Cairo::ScaledFont.try_convert})): Added.

    * (({Cairo::FontFace.try_convert})): Added.

    * (({Cairo::FontOptions.try_convert})): Added.

    * (({Cairo::Region.try_convert})): Added.

=== Thanks

  * kojix2

  * Erik Czumadewski

  * Mamoru TASAKA

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun Aug 18 03:13:21 2019 UTC (5 years, 3 months ago) by tsutsui
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +1 -2 lines
ruby-gnome2: update to 3.3.7.

Upstream changes (from NEWS):

== Ruby-GNOME2 3.3.7: 2019-08-17

This is the bug fix release of 3.3.6.

=== Changes

==== Ruby/Pango

  * Improvements

    * (({Pango::AttrList#each})): Added.

    * (({Pango::AttrType})): Added support for (({PANGO_ATTR_FONT_DESC})).

==== Ruby/GObjectIntrospection

  * Improvements

    * Added support for (({GHashTable<utf8, enum>})).

    * Added support for GObject Introspection 1.60.0.

==== Ruby/Pango

  * Improvements

    * Added support for Pango 1.44.
      [GitHub#1288][Reported by Toshiaki Asai]

==== Ruby/GTK3

  * Fixes

    * Fixed document markup.
      [GitHub#1280][GitHub#1281][GitHub#1282][Patch by İsmail Arılık]

==== Ruby/WNCK3

  * Added.
    [GitHub#1284][Reported by Christopher L. Ramsey]

==== Ruby/libsecret

  * Added.

=== Thanks

  * İsmail Arılık

  * Christopher L. Ramsey

  * Toshiaki Asai

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun Jul 21 22:25:05 2019 UTC (5 years, 4 months ago) by wiz
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -1 lines
*: recursive bump for gdk-pixbuf2-2.38.1

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sun Jan 27 02:23:39 2019 UTC (5 years, 10 months ago) by tsutsui
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +1 -2 lines
ruby-gnome2: update to 3.3.1.

Upstream changes (from NEWS):

== Ruby-GNOME2 3.3.1: 2019-01-09

This is a release that improves GObject Introspection support.

=== Changes

==== Ruby/GLib2

  * Improvements

    * (({rbgobj_remove_relative()})): Added support for removing a
      relative added by (({rbgobj_add_relative()})).

    * Stopped to use raw (({Hash})) to guard objects from GC.

    * (({GLib::Idle.remove})): Deprecated. Use
      (({GLib::Source.remove})) instead.

  * Fixes

    * Fixed typos in samples.
      [GitHub#1267][Patch by kojix2]

==== Ruby/CairoGObject

  * Improvements

    * Started to require cairo gem 1.16.2 or later.

==== Ruby/GObjectIntrospection

  * Improvements

    * Added support for input object validation.

    * Added support for callback with module function such as
      (({Gdk.threads_add_idle})).
      [GitHub#1256][Reported by xetum]

    * Added support for converting (({GHash<utf8, GObject>})).

    * Added support for transfer full (({GHash})).

    * Added support for freeing array of primitive types.
      [GitHub#1266][Patch by Yosuke Shiro]

    * Improved suitable method detection for array and list.

    * Added support for converting an array of (({GObject})).

    * Added support for renaming compare operations:

      * (({not_equal})): (({!=}))

      * (({less_than})): (({<}))

      * (({less_than_or_equal})): (({<=}))

      * (({greater_than})): (({>}))

      * (({greater_than_or_equal})): (({>=}))

==== Ruby/GdkPixbuf2

  * Fixes

    * Fixed markup.
      [GitHub#1250][Patch by kojix2]

    * Fixed a bug that data passed to (({GdkPixbuf::Pixbuf.new(data:
      array)})) is corrupt by GC.

==== Ruby/Pango

  * Improvements

    * (({Pango::Layout#get_pixel_extents})): Added for backward
      compatibility.

    * (({Pango::Rectangle#ascent})): Added for backward
      compatibility.

    * (({Pango::Rectangle#descent})): Added for backward
      compatibility.

    * (({Pango::Rectangle#lbearing})): Added for backward
      compatibility.

    * (({Pango::Rectangle#rbearing})): Added for backward
      compatibility.

    * (({Pango::Rectangle#left_bearing})): Added.

    * (({Pango::Rectangle#right_bearing})): Added.

==== Ruby/GTK2

  * Fixes

    * Fixed typos in samples.
      [GitHub#1268][Patch by kojix2]

==== Ruby/GTK3

  * Improvements

    * Updated sample to work on HiDPI environment.
      [GitHub#1246][Patch by noanoa07]

    * Updated samples.
      [GitHub#1258][GitHub#1259][GitHub#1260][Patch by kojix2]

==== Ruby/RSVG2

  * Fixes

    * Fixed typos.
      [GitHub#1253][Patch by kojix2]

    * Removed needless rsvg2 gem dependency for Windows.
      [GitHub#1261][Reported by noanoa07]

==== Ruby/GEGL

  * Fixes

    * Fixed a typo in README.
      [GitHub#1263][Patch by kojix2]

=== Thanks

  * noanoa07

  * kojix2

  * xetum

  * Yosuke Shiro

Revision 1.12: download - view: text, markup, annotated - select for diffs
Wed Nov 14 22:21:46 2018 UTC (6 years ago) by kleink
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
Revbump after cairo 1.16.0 update.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Mon Nov 12 03:52:17 2018 UTC (6 years ago) by ryoon
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -1 lines
Recursive revbump from hardbuzz-2.1.1

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu May 3 12:04:03 2018 UTC (6 years, 7 months ago) by tsutsui
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +1 -2 lines
ruby-gnome2: update to 3.2.5.

Upstream changes (from NEWS):

== Ruby-GNOME2 3.2.5: 2018-05-02

This is a bug fix release of 3.2.4.

=== Changes

==== Document

  * Fixes

    * Fixed typos.
      [GitHub#1158][Patch by kojix2]
      [GitHub#1160][Patch by kojix2]

==== Ruby/GLib2

  * Fixes

    * Fixed a GC related crash bug.
      [GitHub#1162][Reported by Izumi Tsutsui]

==== Ruby/GObjectIntrospection

  * Improvements

    * Disabled NULL check for GObject Introspection < 1.42. Because
      GObject Introspection < 1.42 doesn't support "(nullable)"
      annotation yet.

==== Ruby/GdkPixbuf2

  * Improvements

    * (({GdkPixbuf::Pixbuf#composite})): Suppressed wrong warning.
      [GitHub#1156][Reported by Chaistrin]
      [GitHub#1157][Patch by cedlemo]

  * Fixes

    * Added a missing white space into message.
      [GitHub#1155][Reported by Robert A. Heiler]

    * (({GdkPixbuf::Pixbuf#composite})): Fixed a bug that width and
      height are ignored.
      [Patch by cedlemo]

==== Ruby/GTK3

  * Improvements

    * (({Gtk::TextBuffer#initialize})): Accepted "property-name" form.
      [GitHub#1161][Reported by kojix2]

==== Ruby/Poppler

  * Improvements

    * Added a workaround for poppler-glib 0.63 bug.
      [GitHub#1159][Reported by HIGUCHI Daisuke]

=== Thanks

  * Robert A. Heiler

  * Chaistrin

  * cedlemo

  * kojix2

  * Izumi Tsutsui

  * HIGUCHI Daisuke

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Apr 16 14:34:40 2018 UTC (6 years, 7 months ago) by wiz
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -1 lines
Recursive bump for new fribidi dependency in pango.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Fri Apr 13 16:31:10 2018 UTC (6 years, 7 months ago) by tsutsui
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +1 -2 lines
ruby-gnome2: update to 3.2.4.

Upstream changes (from NEWS):

== Ruby-GNOME2 3.2.4: 2018-04-09

This is a bug fix release of 3.2.3.

=== Changes

==== Ruby/GLib2

  * Fixes

    * Fixed a bug that some constants aren't defined. If a content
      name is the same constant name at the top level such as
      (({Gtk::Object})), the constant isn't defined.

      [GitHub#1154][Debian#894816][mikutter#1199]
      [Reported by Akira Ouchi][Forwarded by HIGUCHI Daisuke]

==== RubyRsvg2

  * Improvements

    * Windows: Upgraded bundled librsvg to 2.42.3.

=== Thanks

  * Akira Ouchi

  * HIGUCHI Daisuke

== Ruby-GNOME2 3.2.3: 2018-04-03

This is a bug fix release of 3.2.2.

=== Changes

==== Ruby/GObjectIntrospection

  * Fixes

    * Fixed a crash bug when (({GLib::Bytes})) is passed as an argument.

== Ruby-GNOME2 3.2.2: 2018-04-02

This is a release to support Ruby 2.5 on Windows.

=== Changes

==== All

  * Windows: Added Ruby 2.5 support.
    [GitHub#1148][Reported by Andy Meneely]

  * Red Hat: Use (({pkgconfig(name)})) style.
    [GitHub#1117][Patch by Mamoru TASAKA]

==== Ruby/GLib2

  * Improvements

    * (({GLib::Bytes#to_s})): Changed to return a frozen string to
      reduce data copy.

    * Migrated to (({TypedData})) from (({Data})).

==== Ruby/GObjectIntrospection

  * Improvements

    * Added (({nil})) argument check.

    * (({GObjectIntrospection::Loader#rubyish_method_name})):
      Added (({:n_in_args_offset})) option.

    * Suppressed a needless copy of (({GLib::Bytes})).

    * Added filename array support.
      [GitHub#1151][Patch by cedlemo]

  * Fixes

    * Fixed a overflow bug on 32bit.
      [Debian#766020][Reported by Mario Lang]
      [GitHub#1137][Forwarded by HIGUCHI Daisuke]

==== Ruby/GTK2

  * Fixes

    * Fix the wrong number of arguments.
      [GitHub#1133][Reported by Mamoru TASAKA]

==== Ruby/GDK3

  * Improvements

    * Ensured loading GDK 3.
      [GitHub#1126][Patch by cedlemo]

  * Fixes

    * (({Gdk::Screen.default})): Fixed a GC related crash.

    * (({Gtk::Widget#style_context})): Fixed a GC related crash.
      [GitHub#1149][Reported by Valentin Pelloin]

==== Ruby/GTK3

  * Improvements

    * Added a tool palette demo.
      [GitHub#1116][Patch by cedlemo]

    * Added a shortcut demo.
      [GitHub#1120][Patch by cedlemo]

    * Updated demo.
      [Reported by Titouan Teyssier]
      [GitHub#1139][Patch by Titouan Teyssier]

    * Updated README.
      [GitHub#1127][Patch by cedlemo]

  * Fixes

    * (({Gtk::Container#add_child(child)})): Made workable again.

==== Ruby/Poppler

  * Fixes

    * (({Poppler::Page#thumbnail_size})): Fixed return value.
      [GitHub:rcairo/rcairo#51][Reported by Mamoru TASAKA]

==== Ruby/Gnumeric

  * Improvements

    * Improved .typelib for Gnumeric detection.
      [GitHub#1118][Reported by cedlemo]

=== Thanks

  * cedlemo

  * Mamoru TASAKA

  * Titouan Teyssier

  * Mario Lang

  * HIGUCHI Daisuke

  * Andy Meneely

  * Valentin Pelloin

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Mar 12 11:16:50 2018 UTC (6 years, 8 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Recursive bumps for fontconfig and libzip dependency changes.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu Nov 23 17:19:58 2017 UTC (7 years ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
recursive bump for libxkbcommon removal from at-spi2-core

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Jun 11 05:51:40 2017 UTC (7 years, 5 months ago) by tsutsui
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +3 -1 lines
Move MAINTAINER line to each gem package.

Also retire from maintainership of packages that I don't need and
have less motivation.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat Jun 10 08:27:20 2017 UTC (7 years, 5 months ago) by tsutsui
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
Update ruby-gnome2 packages to 3.1.6.

pkgsrc changes:
 - remove a pkgsrc patch for ruby-gnome2-gtk that seems fixed in upstream
 - ignore native-package-installer dependency checks
   in ruby-gnome2-clutter-gstreamer and ruby-gnome2-webkit-gtk

Upstream changes:
(from https://github.com/ruby-gnome2/ruby-gnome2/blob/3.1.6/NEWS)

== Ruby-GNOME2 3.1.6: 2017-06-03

=== Changes

This is a bug fix release for Windows packages.

==== All

  * Fixes
    * Added a missing path existence check on Windows.

== Ruby-GNOME2 3.1.5: 2017-06-03

=== Changes

This is a bug fix release for Windows packages.

==== All

  * Improvements
    * Supported RubyInstaller2.

==== Ruby/Pango

  * Improvements
    * Add backward compatibility APIs:
      * (({Pango::FontDescription::WEIGHT_*}))
      * (({Pango::FontDescription::STYLE_*}))

== Ruby-GNOME2 3.1.4: 2017-05-30

=== Changes

This is a release that supports Ruby 2.4 on Windows.

==== All

  * Improvements
    * Supported MSYS2.

==== Ruby/GLib2

  * Improvements
    * Added (({GLib::Object#floating?})) for debugging.

==== Ruby/GIO2

  * Improvements
    * Added (({Gio::File.open})). The followings are deprecated.
      * (({Gio::File.commandline_arg}))
      * (({Gio::File.path}))
      * (({Gio::File.uri}))

==== Ruby/GObjectIntrospection

  * Improvements
    * Relaxed expected test result for 32bit environment.
      [GitHub#1026][Reported by Mamoru TASAKA]
    * Added tests for (({GObjectIntrospection::ConstantInfo})).
      [GitHub#1027][Patch by cedlemo]
    * Supported floating "transfer full" GObject.

==== Ruby/GDK3

  * Improvements
    * Supported (({Cairo::Surface#to_pixbuf(options={})})).
      (({Cairo::Surface#to_pixbuf(src_x, src_y, width, height)})) is
      deprecated.

==== Ruby/Rsvg2

  * Improvements
    * Migrated to GObject Introspection bindings.
    * Renamed to (({Rsvg})) from (({RSVG})). (({RSVG})) is still
      usable but it's deprecated.
      [GitHub#1030][Patch by cedlemo]
    * Supported (({Cairo::Context#render_rsvg_handle(handle, :id =>
      ...)})).

==== Ruby/WebKit2GTK

  * Improvements
    * (({WebKit3Gtk::WebView#initialize})): Supported (({Hash}))
      options.
      [GitHub#1028][Patch by Matijs van Zuijlen]

=== Thanks

  * Mamoru TASAKA
  * cedlemo
  * Matijs van Zuijlen

== Ruby-GNOME2 3.1.3: 2017-04-27

=== Changes

This is a release that improve backward compatibility for Ruby/Pango.

==== Ruby/Pango

  * Improvements
    * Defined constants under (({Pango})) again for backward compatibility.
      [GitHub#1022][Reported by Andy Meneely]
    * Defined constants under (({Pango::Layout})) again for backward
      compatibility.
      [GitHub#1022][Reported by Andy Meneely]
    * (({Pango.pixels})): Added again.
    * (({Pango::AttrShape#data})): Supported again.
  * Fixes
    * (({Pango::Layout#text=})): Fixed a bug that wrong bytesize is
      used for multibyte string.
    * (({Pango::Layout#markup=})): Fixed a bug that wrong bytesize
      is used for multibyte string.

=== Thanks

  * Andy Meneely

== Ruby-GNOME2 3.1.2: 2017-04-26

There is an incompatible change. (({GBytes})) to (({String}))
conversion is changed to (({GBytes})) to (({GLib::Bytes}))
conversion. You can get (({String})) by (({GLib::Bytes#to_s})).

Other incompatible changes are bugs. Please report them to us.

=== Changes

==== All

  * Improvements
    * Supported auto depended package install for GObject
      Introspection based bindings.

==== Ruby/GLib2

  * Improvements
    * Supported overriding (({alloc_func})) in super class.
    * Extracted native package installer code as
      native-package-installer gem.
    * (({GLib::Bytes})): Added.
    * Supported pkg-config 1.1.9 or later.
  * Fixes
    * Fixed a build error on CentOS 6 and Ubuntu 12.04. They use
      GLib < 2.34.
      [GitHub#1012][Reported by Scot]
    * Fixed a bug that (({GLib::TypePlugin})) can't be included.
      [GitHub#1019][Patch by Matijs van Zuijlen]

==== Ruby/GIO2

  * Fixes
    * Fixed a path in test. [GitHub#990][Reported by Mamoru TASAKA]

==== Ruby/GObjectIntrospection

  * Improvements
    * Supported getting interface, union and boxed type as a field value.
    * Supported setting an interface as a field.
    * Supported more struct types.
    * Supported cairo-gobject types.
    * Supported outputting an array of interfaces.
      [GitHub#1006][Reported by cedlemo]
    * Supported Rubyish method name conversion for (({list_XXX}))
      methods that return an array.
    * Supported customizing field reader method name.
    * Supported auto (({int})) to boolean conversion for field value.
    * (({GObjectIntrospection::Repository.default})): Added a GC guard.
    * Supported inputting (({unichar})).
    * Supported inputting (({gint64})) C array.
    * Supported inputting (({gint8})) C array.
    * Added tests for (({GObjectIntrospection::UnionInfo})).
      [GitHub#1016][Patch by cedlemo]
    * Stopped auto (({GBytes})) to (({String}))
      conversion. (({GBytes})) is converted to (({GLib::Bytes})). It's
      for efficient byte sequence handling in Ruby. It's
      an incompatible change. You can use (({GLib::Bytes#to_s})) to
      get (({String})).
  * Fixes
    * (({GObjectIntrospection::RepositoryError})): Fixed parent class.
    * Fixed a typo. [GitHub#1002][Reported by cedlemo]

==== Ruby/ATK

  * Improvements
    * Migrated to GObject Introspection bindings.
      [GitHub#998][Patch by cedlemo]

==== Ruby/CairoGObject

  * Fixes
    * Fixed a double free bug.

==== Ruby/Pango

  * Improvements
    * Migrated to GObject Introspection bindings.
      [GitHub#1007][GitHub#1008][GitHub#1009][GitHub#1010]
      [GitHub#1011][Patch by cedlemo]
      [GitHub#1013][GitHub#1014][Patch by Detlef Wagner]

==== Ruby/GdkPixbuf2

  * Improvements
    * Supported GdkPixbuf 2.31.6 on CentOS 7 again.

==== Ruby/GDK3

  * Improvements
    * (({Gdk::Event})) and subclasses: Supported again.
    * Supported old GDK 3 again.
    * Supported X11 related features.
      [GitHub#999][Reported by johnlane]

==== Ruby/GTK3

  * Improvements
    * (({Gtk::Widget#click})): Added.
    * (({Gtk::Widget#send_key})): Added.
    * (({Gtk::Widget#wait_for_draw})): Added.
    * (({Gtk::WiAccelGroup.activate})): Added.
    * Updated samples.
      [GitHub#1002][GitHub#1003]
      [Patch by cedlemo]
    * (({Gtk::IconTheme#choose_icon})): Changed the default flags to
      (({0})) from (({:generic_fallback})).
    * (({Gtk::IconTheme#lookup_icon})): Changed the default flags to
      (({0})) from (({:generic_fallback})).
    * Supported GTK+ < 3.20 again.
  * Fixes
    * Updated signal name in document.
      [GitHub#995][Patch by Arnaud Meuret]

==== Ruby/ClutterGdk

  * Fixes
    * Ensured initializing GDK.
      [GitHub#1000][Reported by cedlemo]

==== Ruby/GOffice

  * Improvements
    * (({GOffice::Version})): Added.

=== Thanks

  * Mamoru TASAKA
  * Arnaud Meuret
  * cedlemo
  * johnlane
  * Scot
  * Detlef Wagner
  * Matijs van Zuijlen

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Feb 12 06:25:31 2017 UTC (7 years, 9 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Recursive revbump from fonts/harfbuzz

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Feb 6 13:55:30 2017 UTC (7 years, 9 months ago) by wiz
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Recursive bump for harfbuzz's new graphite2 dependency.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sun Jan 29 07:41:10 2017 UTC (7 years, 10 months ago) by tsutsui
Branches: MAIN
Import ruby-gnome2-clutter-gdk-3.1.1 as graphics/ruby-gnome2-clutter-gdk.

Ruby-GNOME 2 is a set of Ruby language bindings for the various
application development libraries included with the GNOME/GTK+
environment.

Ruby/ClutterGDK is a Ruby binding of GDK specific API of Clutter.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>