[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / ruby-gnome2-cairo-gobject

File: [cvs.NetBSD.org] / pkgsrc / graphics / ruby-gnome2-cairo-gobject / Attic / Makefile (download)

Revision 1.18, Sun Jan 27 02:23:39 2019 UTC (5 years, 2 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.17: +2 -3 lines

ruby-gnome2: update to 3.3.1.

Upstream changes (from NEWS):

== Ruby-GNOME2 3.3.1: 2019-01-09

This is a release that improves GObject Introspection support.

=== Changes

==== Ruby/GLib2

  * Improvements

    * (({rbgobj_remove_relative()})): Added support for removing a
      relative added by (({rbgobj_add_relative()})).

    * Stopped to use raw (({Hash})) to guard objects from GC.

    * (({GLib::Idle.remove})): Deprecated. Use
      (({GLib::Source.remove})) instead.

  * Fixes

    * Fixed typos in samples.
      [GitHub#1267][Patch by kojix2]

==== Ruby/CairoGObject

  * Improvements

    * Started to require cairo gem 1.16.2 or later.

==== Ruby/GObjectIntrospection

  * Improvements

    * Added support for input object validation.

    * Added support for callback with module function such as
      (({Gdk.threads_add_idle})).
      [GitHub#1256][Reported by xetum]

    * Added support for converting (({GHash<utf8, GObject>})).

    * Added support for transfer full (({GHash})).

    * Added support for freeing array of primitive types.
      [GitHub#1266][Patch by Yosuke Shiro]

    * Improved suitable method detection for array and list.

    * Added support for converting an array of (({GObject})).

    * Added support for renaming compare operations:

      * (({not_equal})): (({!=}))

      * (({less_than})): (({<}))

      * (({less_than_or_equal})): (({<=}))

      * (({greater_than})): (({>}))

      * (({greater_than_or_equal})): (({>=}))

==== Ruby/GdkPixbuf2

  * Fixes

    * Fixed markup.
      [GitHub#1250][Patch by kojix2]

    * Fixed a bug that data passed to (({GdkPixbuf::Pixbuf.new(data:
      array)})) is corrupt by GC.

==== Ruby/Pango

  * Improvements

    * (({Pango::Layout#get_pixel_extents})): Added for backward
      compatibility.

    * (({Pango::Rectangle#ascent})): Added for backward
      compatibility.

    * (({Pango::Rectangle#descent})): Added for backward
      compatibility.

    * (({Pango::Rectangle#lbearing})): Added for backward
      compatibility.

    * (({Pango::Rectangle#rbearing})): Added for backward
      compatibility.

    * (({Pango::Rectangle#left_bearing})): Added.

    * (({Pango::Rectangle#right_bearing})): Added.

==== Ruby/GTK2

  * Fixes

    * Fixed typos in samples.
      [GitHub#1268][Patch by kojix2]

==== Ruby/GTK3

  * Improvements

    * Updated sample to work on HiDPI environment.
      [GitHub#1246][Patch by noanoa07]

    * Updated samples.
      [GitHub#1258][GitHub#1259][GitHub#1260][Patch by kojix2]

==== Ruby/RSVG2

  * Fixes

    * Fixed typos.
      [GitHub#1253][Patch by kojix2]

    * Removed needless rsvg2 gem dependency for Windows.
      [GitHub#1261][Reported by noanoa07]

==== Ruby/GEGL

  * Fixes

    * Fixed a typo in README.
      [GitHub#1263][Patch by kojix2]

=== Thanks

  * noanoa07

  * kojix2

  * xetum

  * Yosuke Shiro

# $NetBSD: Makefile,v 1.18 2019/01/27 02:23:39 tsutsui Exp $
#

DISTNAME=		cairo-gobject-${VERSION}
PKGNAME=		${RUBY_PKGPREFIX}-gnome2-${DISTNAME}
COMMENT=		Ruby binding of cairo-gobject
CATEGORIES=		graphics gnome

MAINTAINER=		tsutsui@NetBSD.org

DEPENDS+=		${RUBY_PKGPREFIX}-gnome2-glib>=${VERSION}:../../devel/ruby-gnome2-glib
DEPENDS+=		${RUBY_PKGPREFIX}-cairo>=1.16.2:../../graphics/ruby-cairo

.include "../../devel/ruby-gnome2-glib/buildlink3.mk"
.include "../../graphics/ruby-cairo/buildlink3.mk"
.include "../../graphics/cairo-gobject/buildlink3.mk"
.include "../../meta-pkgs/ruby-gnome2/Makefile.common"
.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"