[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / ruby-RMagick

File: [cvs.NetBSD.org] / pkgsrc / graphics / ruby-RMagick / PLIST (download)

Revision 1.32, Mon Mar 23 17:12:10 2020 UTC (4 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.31: +5 -366 lines

graphics/ruby-RMagick: update to 4.1.0

Update ruby-RMagick to 4.1.0.
pkgsrc change: depends on ImageMagick istead of ImageMagick6.


RMagick 4.1.0 (2020-03-22)

Improvements:

* reduce package size by more than 1.5mb (#849)
* improve memory usage (#836)
* add support for Ruby 2.7 (#853)
* many documentation fixes and cleanups
* many testing fixes and cleanups
* Support CMYK color in Image#get_pixels (#871)
* Support to get CMYK color in Image#pixel_color (#875)
* Support to set CMYK color in Image#pixel_color (#908)
* Add ImageList#map (#1154)

Bug Fixes:

* fixed memory leaks (#809, #815, #816, #960, #1024)
* eliminate compiler warnings (#855, #864, #878, #917, #969, #981, #996,
  #1000, #1044)
* Recognize invert option in Image#opaque_channel with ImageMagick 7 (#882)
* Fix heap-buffer-overflow in Image#wet_floor with ImageMagick 7 (#883)
* Handle channel value with new image in Image#opaque_channel with
  ImageMagick 7 (#886)
* Pass caption value into ImageMagick 7 API in Image#polaroid (#898)
* Example: Fix "uninitialized constant Magick::TransparentOpacity" error (#899)
* Example: Fix error of constant usage (#900)
* Example: Fix error in doc/ex/composite.rb (#901)
* Example: Fix error in doc/ex/crop_with_gravity.rb (#902)
* Revert removed RemapImages() calling in ImageList#remap for ImageMagick 6
  (#904)
* Example: Fix alpha channel in examples/vignette.rb (#918)
* Example: Fix alpha channel in doc/ex/coalesce.rb (#920)
* Handle alpha value in Pixel#to_color (#922)
* Detect the proper ARCHFLAGS on macOS (#923)
* Handle boolean value as dither option in ImageList#quantize (#926)
* Use strlcpy instead of strncpy to ensure null terminating. (#933)
* Remove memalign() (#939)
* Add safe strlen() to ensure avoiding buffer overrun (#940)
* Use strlcpy() instead of strcpy() to ensure avoiding buffer overflow
  (#941)
* Use snprintf() instead of sprintf() to ensure avoiding buffer overflow
  (#945)
* Example: Remove unnecessary alpha setting (#950)
* Replace to correct format specifiers for size_t/ssize_t value (#978)
* Use proper format specifiers within MinGW (#997)
* Fix snprintf() format specifiers for unsigned value (#1006)
* Fix warning of "Variable is reassigned a value before the old one has
  been use" (#1008)
* Fix warning of "warning: explicitly assigning value of variable of type
  'int' to itself" (#1013)
* Fix Image#resample to use blur option properly with ImageMagick 7 (#1023)
* Fix Image#resize to use blur option properly with ImageMagick 7 (#1032)
* Fix that Color#compliance returns nil with undefined bit (#1049)
* Check memory API properly on Windows (#1050)
* Example: Fix "undefined method `opacity'" (#1051)
* Add workaround to pdf problem (#1072)
* Fix exception message because #export_pixels accept 0 argument (#1121)
* Fix default value of fill argument in Image#initialize (#1122)
* Call rm_ensure_result() in creating Image object (#1144)
* Use StringValueCStr() instead of StringValuePtr() (#1156)
* Use RSTRING_PTR() to retrieve a pointer of String object for buffer
  (#1157)
* Use StringValueCStr() to get null-terminated C-lang string (#1158)
* Fix SEGV in Magick::Draw#marshal_load (#1162)
* Fix SEGV in rm_check_ary_len() with unexpected argument value (#1168)
* Fix SEGV in Image#marshal_load (#1169)

Breaking Changes:

* remove tainted? logic (#854)

RMagick 4.1.0.rc2 (2019-09-17)

* fix a couple of compilation bugs (#796, #797)

RMagick 4.1.0.rc1 (2019-09-12)

  The ImageMagick 7 release is here! This adds beta support for
  ImageMagick 7.  Much thanks to @Watson1978 for getting the ball rolling
  on this and to @dlemstra for the extraordinary amount of work and
  patience that went into seeing it through.  RMagick should currently
  behave the same way under IM7 as it did under IM6, so please open an
  issue if you find anything that seems out of the ordinary.

@comment $NetBSD: PLIST,v 1.32 2020/03/23 17:12:10 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_EXTSDIR}/RMagick2.${RUBY_DLEXT}
${GEM_EXTSDIR}/gem.build_complete
${GEM_LIBDIR}/.codeclimate.yml
${GEM_LIBDIR}/.editorconfig
${GEM_LIBDIR}/.github/workflows/ci.yml
${GEM_LIBDIR}/.gitignore
${GEM_LIBDIR}/.rspec
${GEM_LIBDIR}/.rubocop.yml
${GEM_LIBDIR}/.rubocop_todo.yml
${GEM_LIBDIR}/.yardopts
${GEM_LIBDIR}/CHANGELOG.md
${GEM_LIBDIR}/CODE_OF_CONDUCT.md
${GEM_LIBDIR}/CONTRIBUTING.md
${GEM_LIBDIR}/Gemfile
${GEM_LIBDIR}/LICENSE
${GEM_LIBDIR}/README.md
${GEM_LIBDIR}/Rakefile
${GEM_LIBDIR}/before_install_linux.sh
${GEM_LIBDIR}/before_install_osx.sh
${GEM_LIBDIR}/deprecated/RMagick.rb
${GEM_LIBDIR}/ext/RMagick/extconf.rb
${GEM_LIBDIR}/ext/RMagick/rmagick.c
${GEM_LIBDIR}/ext/RMagick/rmagick.h
${GEM_LIBDIR}/ext/RMagick/rmdraw.c
${GEM_LIBDIR}/ext/RMagick/rmenum.c
${GEM_LIBDIR}/ext/RMagick/rmfill.c
${GEM_LIBDIR}/ext/RMagick/rmilist.c
${GEM_LIBDIR}/ext/RMagick/rmimage.c
${GEM_LIBDIR}/ext/RMagick/rminfo.c
${GEM_LIBDIR}/ext/RMagick/rmkinfo.c
${GEM_LIBDIR}/ext/RMagick/rmmain.c
${GEM_LIBDIR}/ext/RMagick/rmmontage.c
${GEM_LIBDIR}/ext/RMagick/rmpixel.c
${GEM_LIBDIR}/ext/RMagick/rmstruct.c
${GEM_LIBDIR}/ext/RMagick/rmutil.c
${GEM_LIBDIR}/lib/RMagick2.${RUBY_DLEXT}
${GEM_LIBDIR}/lib/rmagick.rb
${GEM_LIBDIR}/lib/rmagick/version.rb
${GEM_LIBDIR}/lib/rmagick_internal.rb
${GEM_LIBDIR}/lib/rvg/clippath.rb
${GEM_LIBDIR}/lib/rvg/container.rb
${GEM_LIBDIR}/lib/rvg/deep_equal.rb
${GEM_LIBDIR}/lib/rvg/describable.rb
${GEM_LIBDIR}/lib/rvg/embellishable.rb
${GEM_LIBDIR}/lib/rvg/misc.rb
${GEM_LIBDIR}/lib/rvg/paint.rb
${GEM_LIBDIR}/lib/rvg/pathdata.rb
${GEM_LIBDIR}/lib/rvg/rvg.rb
${GEM_LIBDIR}/lib/rvg/stretchable.rb
${GEM_LIBDIR}/lib/rvg/stylable.rb
${GEM_LIBDIR}/lib/rvg/text.rb
${GEM_LIBDIR}/lib/rvg/transformable.rb
${GEM_LIBDIR}/lib/rvg/units.rb
${GEM_LIBDIR}/rmagick.gemspec
${GEM_HOME}/specifications/${GEM_NAME}.gemspec