The NetBSD Project

CVS log for pkgsrc/graphics/py-imaging/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / graphics / py-imaging

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgviews


Revision 1.12 / (download) - annotate - [select for diffs], Thu Feb 14 11:39:46 2002 UTC (22 years, 2 months ago) by drochner
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.11: +3 -3 lines
Diff to previous 1.11 (colored)

update to 1.1.2
Changes:
+ Adapted to Python 2.1.  Among other things, all uses of the
  "regex" module has been repleased with "re".
+ Fixed attribute error when reading large PNG files (this bug
  was introduced in maintenance code released after the 1.1.1
  release)
+ Ignore non-string objects in sys.path
+ Fixed Image.transform(EXTENT) for negative xoffsets
+ Fixed loading of image plugins if PIL is installed as a package.
  (The plugin loader now always looks in the directory where the
  Image.py module itself is found, even if that directory isn't on
  the standard search path)
+ The Png plugin has been added to the list of preloaded standard
  formats
+ Fixed bitmap/text drawing in fill mode.
+ Fixed "getextrema" to work also for multiband images.
+ Added transparency support for L and P images to the PNG codec.
+ Improved support for read-only images.  The "load" method now
  sets the "readonly" attribute for memory-mapped images.  Operations
  that modifies an image in place (such as "paste" and drawing operations)
  creates an in-memory copy of the image, if necessary.  (before this
  change, any attempt to modify a memory-mapped image resulted in a
  core dump...)
+ Added special cases for lists everywhere PIL expects a sequence.
  This should speed up things like "putdata" and drawing operations.
+ The Image.offset method is deprecated.  Use the ImageChops.offset
  function instead.
+ Changed ImageChops operators to copy palette and info dictionary
  from the first image argument.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>