The NetBSD Project

CVS log for pkgsrc/graphics/py-contourpy/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / graphics / py-contourpy

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun Apr 20 20:08:57 2025 UTC (35 hours, 42 minutes ago) by wiz
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2 lines
py-contourpy: update to 1.3.2.

v1.3.2 (2025-04-15)
-------------------

ContourPy 1.3.2 is a minor release to support changes in type annotations in Bokeh >= 3.7 and add
support for PyPy 3.11.

This release supports CPython 3.10 to 3.13, and PyPy 3.10 to 3.11.

Compatibility:

- Fix type annotations for Bokeh >= 3.7 (:pr:`471`)

Build, testing and CI improvements:

- Test on CPython 3.14 (:pr:`470`)
- Test and build wheels for PyPy 3.11 (:pr:`464`)
- Test PyPy 3.10 on all 3 major OSes (:pr:`465`)
- Use ubuntu-24.04-arm runners (:pr:`459`)

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun Nov 17 19:51:50 2024 UTC (5 months ago) by gutteridge
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -1 lines
py-contourpy: reflect correct minimum py-pybind11 dependency

Separate from what upstream documents in their issue #451, some older
versions of py-pybind11 accepted previously here would result in a
build failure like so:

../src/wrap.cpp:21:54: error: macro "PYBIND11_MODULE" passed 3 arguments, but takes just 2
 PYBIND11_MODULE(_contourpy, m, py::mod_gil_not_used()) {
                                                      ^
../src/wrap.cpp:21:1: error: 'PYBIND11_MODULE' does not name a type
 PYBIND11_MODULE(_contourpy, m, py::mod_gil_not_used()) {
 ^~~~~~~~~~~~~~~

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sun Nov 17 09:31:14 2024 UTC (5 months ago) by wiz
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
py-contourpy: update to 1.3.1.

ContourPy 1.3.1 is a compatibility release to support changes in bokeh, meson-python and pybind11.

This release supports Python 3.10 to 3.13.

Compatibility:

    Drop support for Python 3.9 (#435)
    Update to bokeh 3.6.0 (#444)
    Update minimum pybind11 to 2.13.2 (#451)
    Read meson-python version in recommended way (#452)

Code improvements:

    Use itertools.pairwise instead of zip where possible (#437)
    Typing changes from ruff UP035 and UP038 (#438)

Build, testing and CI improvements:

    Tidy up python 3.13 CI (#449)
    Build Python 3.13t wheels on Windows (#450)

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon Oct 14 06:45:45 2024 UTC (6 months, 1 week ago) by wiz
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +1 -3 lines
*: clean-up after python38 removal

Revision 1.11: download - view: text, markup, annotated - select for diffs
Fri Sep 13 08:27:47 2024 UTC (7 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +3 -3 lines
py-contourpy: update to 1.3.0.

ContourPy 1.3.0 adds new ContourGenerator functions multi_lines
and multi_filled to calculate contour lines and filled contours
over a sequence of levels in a single function call. There are also
new functions to render, convert and dechunk the returns from
multi_lines and multi_filled.

This release adds support for Python 3.13, including free-threaded.
The latter should be considered experimental.

The use of np.nan as the lower_level or upper_level of
ContourGenerator.filled() is no longer permitted.

Enhancements:

    multi_lines and multi_filled:
        ContourGenerator.multi_lines and multi_filled (#338, #340, #342, #343)
        Renderer.multi_lines and multi_filled (#341)
        convert_multi_lines and convert_multi_filled (#348)
        dechunk_multi_lines and dechunk_multi_filled (#345)

    Prevent use of np.nanas lower or upper level in filled (#339)

Compatibility:

    Support CPython 3.13 including free-threaded (#382, #384, #388, #408, #410, #411, #412, #423)
    Support PyPy 3.10 (#404)

Code improvements:

    Support improved typing in NumPy 2.1.0 (#422)

Documentation improvements:

    Simpler sphinx cross-references (#361)
    Add more doc cross-references to explain returned data formats (#366)
    Remove download numbers for conda packages (#428)
    Documentation for multi_lines and multi_filled (#390, #431)
    Document possibility of duplicate contour points (#432)

Build, testing and CI improvements:

    Add pytest option to log image differences to CSV file (#335)
    Label flaky test (#385)
    MSVC linking and std::mutex compiler flag (#391, #395, #414, #419, #427)
    Add minimal test script (#399)
    Bump minimum supported NumPy to 1.23 (#403)
    Build and publish nightly wheels (#413, #425)
    Bump default python version in CI to 3.12 (#430)

Revision 1.10: download - view: text, markup, annotated - select for diffs
Wed Jul 3 04:29:55 2024 UTC (9 months, 2 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +4 -1 lines
py-contourpy: disable -Werror to fix build on -current

Upstream bug report filed.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Sun Apr 7 11:38:36 2024 UTC (12 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
py-contourpy: update to 1.2.1.

ContourPy 1.2.1 is a compatibility release to support NumPy 2.

This release supports Python 3.9 to 3.12.

Thanks to new contributor @motoro and core maintainer @ianthomas23.

Compatibility:

    Support NumPy 2 (#331, #371, #372)

Code improvements:

    Fix a few f-strings (#332)

Documentation improvements:

    Clarify use of quotes in pip install (#349)

Build, testing and CI improvements:

    Improved linting (#322, #323, #333, #337)
    Update cppcheck to 2.11 (#324)
    Support running tests on unicore hosts (#327)
    Improved tests against nightly wheels (#329, #373)
    Update to chromium 118 for Bokeh renderer tests (#325)
    Add CI run using earliest supported numpy (#347)

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Nov 6 13:47:24 2023 UTC (17 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
py-contourpy: update to 1.2.0.

v1.2.0 (2023-11-03)
-------------------

ContourPy 1.2.0 is a significant release with a number of new
features. There is a new format for contour lines called
``LineType.ChunkCombinedNan`` that is designed to work directly
with Bokeh and HoloViews. There are also new functions for manipulating
contour lines and filled contours (``convert_filled``, ``convert_lines``,
``dechunk_filled`` and ``dechunk_lines``).

Calling ``ContourGenerator.filled()`` with two identical levels
now raises a ``ValueError`` whereas previously it gave different
results depending on algorithm ``name``.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sat Nov 4 16:21:55 2023 UTC (17 months, 2 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +5 -4 lines
py-contourpy: update to 1.1.1.

v1.1.1 (2023-09-16)
-------------------

This release adds support for CPython 3.12 and reinstates the release of
Windows 32-bit wheels following NumPy's intention to continue doing so.
There is a new keyword argument ``webdriver`` to the ``BokehRenderer`` save
functions to reuse the same Selenium WebDriver instance across multiple calls.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat Oct 28 19:57:09 2023 UTC (17 months, 3 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
python/wheel.mk: simplify a lot, and switch to 'installer' for installation

This follows the recommended bootstrap method (flit_core, build, installer).

However, installer installs different files than pip, so update PLISTs
for all packages using wheel.mk and bump their PKGREVISIONs.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Aug 1 23:20:44 2023 UTC (20 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
*: remove more references to Python 3.7

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat Jul 1 08:37:36 2023 UTC (21 months, 3 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
*: restrict py-numpy users to 3.9+ in preparation for update

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu Jun 29 10:25:42 2023 UTC (21 months, 3 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +6 -4 lines
py-contourpy: update to 1.1.0.

v1.1.0 (2023-06-13)
-------------------

This release features a change in the build system from ``distutils``, which
is scheduled for removal in Python 3.12, to `meson`_ and `meson-python`_.
It includes the building of wheels for ppc64le and s390x (on x86_64 only) and
removes building of all 32-bit wheels and macOS universal2 wheels.

This release supports Python 3.8 to 3.11.

Thanks to new contributor :user:`eli-schwartz`.

Build system improvements:

* New meson build system (:pr:`183`, :pr:`226`, :pr:`232`, :pr:`249`, :pr:`250`)
* Drop building universal2 wheels (:pr:`225`)
* Add build_config to store and show build configuration info (:pr:`227`)
* Build ppc64le and s390x wheels (:pr:`246`)

Code improvements:

* Rearrange functions alphabetically (:pr:`219`)
* Remove unused mpl2005 and mpl2014 code (:pr:`234`, :pr:`237`)
* Improve mpl2014 chunk count error handling (:pr:`238`)

Documentation improvements:

* Improve API docs (:pr:`220`, :pr:`221`, :pr:`222`)
* Update benchmarks (:pr:`233`)
* Add meson-specific build docs (:pr:`245`)
* Add simpler README for PyPI (:pr:`247`)

CI improvements:

* Replace flake8 with ruff (:pr:`211`)
* Building and testing on cirrus CI (:pr:`213`)
* Run mypy in CI (:pr:`230`)
* Set up code coverage in CI (:pr:`235`, :pr:`236`, :pr:`183`)
* New internal API, codebase and debug renderer tests (:pr:`239`, :pr:`241`, :pr:`244`)
* Use correct version of chromium for Bokeh image tests (:pr:`243`)
* Add tests for musllinux (on x86_64), ppc64le and s390x (:pr:`246`)

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Apr 26 09:12:20 2023 UTC (23 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -3 lines
py-contourpy: updated to 1.0.7

v1.0.7 (2023-01-13)
-------------------

This release adds type annotations and moves project metadata to pyproject.toml (PEP 621).
Documentation now uses the Sphinx Furo theme, supporting dark and light modes. There are no
functional changes.

Type annotations:

* Add type annotations
* Complete mypy configuration

Documentation improvements:

* Support dark mode
* Use sphinx copy button
* Add conda monthly download badges to README
* Furo sphinx theme

Code improvements:

* Improved if statement
* Test nonfinite z and decreasing zlevel for filled
* Add abstract base class Renderer
* Replace mpl scatter call with plot instead
* Use absolute imports
* Minor improvement to get_boundary_start_point

Build system and CI improvements:

* Switch from setup.cfg to pyproject.toml
* Add git pre-commit
* Test improvements
* CI improvements

v1.0.6 (2022-10-30)
-------------------

This release features major improvements to the robustness of the threaded algorithm on both
CPython and PyPy.

Thanks to new contributors :user:`mgorny` and :user:`Zac-HD`.

Threaded algorithm improvements:

* Correctly acquire and release GIL in multithreaded code
* Update benchmarks in line with recent changes

CI improvements:

* Add PyPy 3.9 to CI
* Use numpy debug build in debug CI run

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Oct 13 16:01:42 2022 UTC (2 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
py-contourpy: added version 1.0.5

ContourPy is a Python library for calculating contours of 2D quadrilateral
grids. It is written in C++11 and wrapped using pybind11.

It contains the 2005 and 2014 algorithms used in Matplotlib as well as a newer
algorithm that includes more features and is available in both serial and
multithreaded versions. It provides an easy way for Python libraries to use
contouring algorithms without having to include Matplotlib as a dependency.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>