[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / pngcheck

File: [cvs.NetBSD.org] / pkgsrc / graphics / pngcheck / Makefile (download)

Revision 1.1.1.1 (vendor branch), Fri Dec 8 18:00:20 2006 UTC (17 years, 4 months ago) by wiz
Branch: TNF
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-20061208
Changes since 1.1: +0 -0 lines

Initial import of pngcheck-2.2.0:

pngcheck verifies the integrity of PNG, JNG, and MNG files (by
checking the internal 32-bit CRCs [checksums] and decompressing
the image data); it can optionally dump almost all of the chunk-level
information in the image in human-readable form. For example, it
can be used to print the basic statistics about an image (dimensions,
bit depth, etc.); to list the color and transparency info in its
palette (assuming it has one); or to extract the embedded text
annotations. This is a command-line program with batch capabilities.

# $NetBSD: Makefile,v 1.1.1.1 2006/12/08 18:00:20 wiz Exp $
#

DISTNAME=	pngcheck-2.2.0
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=png-mng/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.libpng.org/pub/png/apps/pngcheck.html
COMMENT=	Verify the integrity of PNG, JNG, and MNG files

do-build:
	cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} -DUSE_ZLIB \
		-o pngcheck pngcheck.c -lz

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/pngcheck ${PREFIX}/bin
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/pngcheck
	${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/pngcheck

.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"