The NetBSD Project

CVS log for pkgsrc/graphics/plotutils/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / graphics / plotutils

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.53 / (download) - annotate - [select for diffs], Sat Jan 18 23:32:17 2020 UTC (3 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, HEAD
Changes since 1.52: +2 -2 lines
Diff to previous 1.52 (colored)

all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.

Revision 1.52 / (download) - annotate - [select for diffs], Thu Oct 9 14:06:37 2014 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.51: +1 -3 lines
Diff to previous 1.51 (colored)

Remove pkgviews: don't set PKG_INSTALLATION_TYPES in Makefiles.

Revision 1.51 / (download) - annotate - [select for diffs], Thu Jul 24 13:20:10 2014 UTC (8 years, 6 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.50: +2 -2 lines
Diff to previous 1.50 (colored)

lex (libfl) is a runtime dependency.

Revision 1.50 / (download) - annotate - [select for diffs], Wed May 7 10:34:30 2014 UTC (8 years, 8 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.49: +2 -1 lines
Diff to previous 1.49 (colored)

Needs libiconv.

Revision 1.49 / (download) - annotate - [select for diffs], Sat Feb 16 11:17:56 2013 UTC (9 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.48: +2 -2 lines
Diff to previous 1.48 (colored)

Recursive bump for png-1.6.

Revision 1.48 / (download) - annotate - [select for diffs], Sat Oct 6 14:11:14 2012 UTC (10 years, 3 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.47: +1 -2 lines
Diff to previous 1.47 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.47 / (download) - annotate - [select for diffs], Tue Feb 8 13:08:06 2011 UTC (11 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.46: +15 -20 lines
Diff to previous 1.46 (colored)

Switch to options.mk and remove plotutils-nox11

Revision 1.46 / (download) - annotate - [select for diffs], Thu Jan 13 13:36:05 2011 UTC (12 years ago) by wiz
Branch: MAIN
Changes since 1.45: +2 -2 lines
Diff to previous 1.45 (colored)

png shlib name changed for png>=1.5.0, so bump PKGREVISIONs.

Revision 1.45 / (download) - annotate - [select for diffs], Sun Jun 13 22:44:41 2010 UTC (12 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.44: +2 -1 lines
Diff to previous 1.44 (colored)

Bump PKGREVISION for libpng shlib name change.
Also add some patches to remove use of deprecated symbols and fix other
problems when looking for or compiling against libpng-1.4.x.

Revision 1.44 / (download) - annotate - [select for diffs], Sun May 2 13:28:43 2010 UTC (12 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.43: +7 -6 lines
Diff to previous 1.43 (colored)

Update to 2.6:

Version 2.6 released, 9/2009.  [Includes libplot 4.4, interface age=2.]

ode:	 File ode/specfun.c now heavily rewritten to remove all non-GNU
	 copyrights.  For details, see the file ./COMPAT.
libplot: Several bugfixes to the SVG and PS drivers.  (Thanks to Diomidis
	 Spinellis, James Anderson, and others, for pointing out that
	 several apps that import SVG or PS were choking on libplot's
	 output.  Some still choke on its SVG output, but that's no longer
	 libplot's fault; see ./COMPAT.)
libplot: The SVG driver now no longer assumes that the application that
	 imports or displays SVG can do _any_ justification of text strings
	 (not even horizontal justification, e.g., position a string in a
	 right-justified way, with its right edge at a given point).  Many
	 SVG viewers still get this wrong.
libplot: Fig plotters now slightly increase the width of drawn lines,
	 in .fig output, to agree with the interpretation of `line width'
	 in recent releases of xfig.  (Thanks to Wolfgang Glunz and
	 Bart De Schutter for pointing out the need for this.)  This
	 affects executables built with libplot, such as `graph -Tfig'.
graph,plot,tek2plot,plotfont,pic2plot,hersheydemo: The output of the
         `--help' option now cautions that if a `-T' or `--output-format'
         command-line option is not included, the output will by default
         be in the `metafile' format, which is probably not what the user
         expects or wants (by default, it is in binary).
hersheydemo: New executable, generating a single demo page that serves
	 as an advertisement for the Hershey vector fonts.  (It replaces
         the file doc/h-demo.c.)  Invoke it by doing, e.g.,
	 `hersheydemo -Tsvg > demo.svg' , or `hersheydemo -Tps | lpr' .
         It supports the usual libplot options such as --bg-color,
	 --pen-color, and --page-size.  Also --bitmap-size, if a bitmap
	 output format is requested; but note that the Hershey fonts, not
	 being anti-aliased, do not look their best in low-resolution
	 (i.e., small-size) bitmap output.

Version 2.5.1 released, 7/2008.  [Includes libplot 4.3, interface age=2.]

package: license for the package (and for libplot) upgraded to GNU GPL v3.
libplot: SVG output format slightly tweaked, to ensure compatability with
	 SVG 1.1 syntax, as tested for by validator.w3.org.
	 Note: a few SVG editing tools, such as inkscape, currently fail
	 to agree with libplot's SVG semantics, in positioning text.
	 That appears to be their fault (they do not comply with the
	 handling of reflected text, as specified in the SVG 1.1 standard).
libplot: Fixed a bug in bounding box computatations when triangular
	 line-joins are used.
executables: Changed nearly all warning and error messages to complete
         sentences, to smooth the upcoming transition to gettext.

Version 2.5 released, 12/2005.  [Includes libplot 4.2, interface age=2.]

package: bug reporting address has changed to bug-plotutils@gnu.org.
libplot: support for rotated and sheared (i.e., "anamorphically
	 transformed") X Window System fonts has been completely rewritten.
	 Core X fonts are still used, but it is no longer assumed that the
	 X display has the ability to rasterize rotated and sheared glyphs.
	 (Recent releases of XFree86 are broken in this regard.)  Instead,
	 unrotated glyphs are retrieved from the server, and rotated or
	 transformed within libplot.  See new module libplot/x_afftext.c.
graph: plotting of rotated y-axis labels by the `-Y' option, when `-T X' is
         specified (so that output is to an X Window System display) should
         now work, even when recent broken releases of XFree86 are used.
         This is due to the above change to libplot.
libplot: URW versions of the standard 35 Adobe fonts (Helvetica,
	 Times-Roman etc.) are now checked for under their own names on any
	 X Window System display, as well as under the Adobe names.  This
	 fixes a problem with recent SuSE GNU/Linux distributions, of
	 `graph -T X' being unable to use even the default Helvetica font.
libplot: SVG output is now conformant SVG 1.1, and should not be rejected
	 by the Firefox browser.
libplot: vertical positioning of text strings by the SVG driver is
	 improved; libplot now does vertical positioning itself, since
	 many SVG renderers, e.g. Firefox 1.5, can't do it properly.
libplot: the ROTATION parameter, which is the angle in degrees at which the
	 viewport in the output (device) frame should be rotated, can now
	 take values other than 0, 90, 180, and 270.
graph,plot,tek2plot,plotfont,pic2plot: the --rotation option no longer
         requires that the specified angle be 0, 90, 180, or 270 degrees.
         Some quite postmodern effects can now be obtained.
libplot: modifiers such as "xsize=6in", "yoffset=8cm" appended to the
	 PAGESIZE parameter by the user, to do fine positioning of the
	 viewport on the output page, are no longer sometimes ignored.
graph,plot,tek2plot,plotfont,pic2plot: modifiers such as "xsize=6in",
         "yoffset=8cm" appended to the argument of the --page-size option,
         by the user, to do fine positioning of the viewport on the output
         page, are no longer sometimes ignored.
libplotter,pic2plot: problems with compilation by recent C++ compilers now
	 fixed: unsigned char* is cast to char* as needed, deprecated C++
	 headers have had their names modernized, etc.  Support for `bool'
	 in the C++ compiler is now assumed (this could be trivially backed
	 out of, if needed).
installation: entire package can now be compiled by a C++ compiler if
	 desired; request this by doing e.g. `CC=g++ ./configure'.
installation: support for pre-ANSI C compilers, such the SunOS 4.1.3 one,
	 now largely dropped.  Non-working `const' is still checked for,
	 but compiler support for prototypes and void is now assumed.
	 Removal of preprocessor macros that supported pre-ANSI C, from
	 many source files, considerably improved maintainability.
installation: updated GNU autotools now used (autoconf-2.59, libtool-1.5.6,
	 and the older automake-1.4-p6 for safety's sake).  Also, recent
	 flex/bison have been used to prepare the scanner and parser supplied
	 with the ode source (flex-2.5.31 and bison-1.875d).
graph: new short `-Q' option, which is equivalent to the long option
	 `--toggle-rotate-y-axis-label'.
graph,plot,tek2plot,plotfont,pic2plot: `--display-type' long option, the
	 name of which confused some users, has been changed to
	 `--output-format'.  The old option is still supported but is now
	 deprecated.  The short option `-T' continues to work.
libplot: problems with PS output triggering an error in some versions of
	 ghostscript (and hence ghostview, gv), due to changes in the way
	 ghostscript handles FontBBox, now fixed.  Thanks, Brian Gough (and
	 also Alex Cherepanov, who found the fix to idraw's PS prologue).
libplot: most external symbols not meant to be publicly accessible now have
	 names beginning with the prefix "_pl_", to reduce the possibility
	 of namespace collisions.  This will be completed in a later release.
executables: output of "--help" has been altered to agree with current GNU
	 coding standards.
package: copyright and license notices added to nearly all source files.

Revision 1.43 / (download) - annotate - [select for diffs], Mon Nov 10 17:21:36 2008 UTC (14 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

Bump PKGREVISION for libXaw API depends bump due to libXaw8 removal.

Revision 1.42 / (download) - annotate - [select for diffs], Thu Jun 12 02:14:32 2008 UTC (14 years, 7 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.41: +2 -1 lines
Diff to previous 1.41 (colored)

Add DESTDIR support.

Revision 1.41 / (download) - annotate - [select for diffs], Wed Oct 10 14:20:39 2007 UTC (15 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.40: +2 -1 lines
Diff to previous 1.40 (colored)

Needs lex and yacc, as reported in PR 37097.

Revision 1.40 / (download) - annotate - [select for diffs], Mon Jan 22 22:09:15 2007 UTC (16 years ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.39: +6 -2 lines
Diff to previous 1.39 (colored)

Modular Xorg support. Based on patch from drochner@

Revision 1.39 / (download) - annotate - [select for diffs], Mon Apr 17 13:45:58 2006 UTC (16 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

Bump BUILDLINK_ABI_DEPENDS.png and PKGREVISION for png-1.2.9nb2 update.

Revision 1.38 / (download) - annotate - [select for diffs], Fri Mar 31 23:56:28 2006 UTC (16 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.37: +2 -3 lines
Diff to previous 1.37 (colored)

List the info pages directly in the PLIST and ensure that we honor
PKGINFODIR.

Revision 1.37 / (download) - annotate - [select for diffs], Fri Mar 31 17:28:11 2006 UTC (16 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.36: +2 -4 lines
Diff to previous 1.36 (colored)

Drop LTCONFIG_OVERRIDE... USE_LIBTOOL takes care of replacing libtool
already.

Revision 1.36 / (download) - annotate - [select for diffs], Sun Feb 5 23:09:37 2006 UTC (16 years, 11 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.35: +2 -2 lines
Diff to previous 1.35 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.35 / (download) - annotate - [select for diffs], Wed Jun 1 18:02:57 2005 UTC (17 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

Massive cleanup of buildlink3.mk and builtin.mk files in pkgsrc.
Several changes are involved since they are all interrelated.  These
changes affect about 1000 files.

The first major change is rewriting bsd.builtin.mk as well as all of
the builtin.mk files to follow the new example in bsd.builtin.mk.
The loop to include all of the builtin.mk files needed by the package
is moved from bsd.builtin.mk and into bsd.buildlink3.mk.  bsd.builtin.mk
is now included by each of the individual builtin.mk files and provides
some common logic for all of the builtin.mk files.  Currently, this
includes the computation for whether the native or pkgsrc version of
the package is preferred.  This causes USE_BUILTIN.* to be correctly
set when one builtin.mk file includes another.

The second major change is teach the builtin.mk files to consider
files under ${LOCALBASE} to be from pkgsrc-controlled packages.  Most
of the builtin.mk files test for the presence of built-in software by
checking for the existence of certain files, e.g. <pthread.h>, and we
now assume that if that file is under ${LOCALBASE}, then it must be
from pkgsrc.  This modification is a nod toward LOCALBASE=/usr.  The
exceptions to this new check are the X11 distribution packages, which
are handled specially as noted below.

The third major change is providing builtin.mk and version.mk files
for each of the X11 distribution packages in pkgsrc.  The builtin.mk
file can detect whether the native X11 distribution is the same as
the one provided by pkgsrc, and the version.mk file computes the
version of the X11 distribution package, whether it's built-in or not.

The fourth major change is that the buildlink3.mk files for X11 packages
that install parts which are part of X11 distribution packages, e.g.
Xpm, Xcursor, etc., now use imake to query the X11 distribution for
whether the software is already provided by the X11 distribution.
This is more accurate than grepping for a symbol name in the imake
config files.  Using imake required sprinkling various builtin-imake.mk
helper files into pkgsrc directories.  These files are used as input
to imake since imake can't use stdin for that purpose.

The fifth major change is in how packages note that they use X11.
Instead of setting USE_X11, package Makefiles should now include
x11.buildlink3.mk instead.  This causes the X11 package buildlink3
and builtin logic to be executed at the correct place for buildlink3.mk
and builtin.mk files that previously set USE_X11, and fixes packages
that relied on buildlink3.mk files to implicitly note that X11 is
needed.  Package buildlink3.mk should also include x11.buildlink3.mk
when linking against the package libraries requires also linking
against the X11 libraries.  Where it was obvious, redundant inclusions
of x11.buildlink3.mk have been removed.

Revision 1.34 / (download) - annotate - [select for diffs], Mon Apr 11 21:46:08 2005 UTC (17 years, 9 months ago) by tv
Branch: MAIN
Changes since 1.33: +1 -2 lines
Diff to previous 1.33 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.33 / (download) - annotate - [select for diffs], Sat Nov 13 22:04:53 2004 UTC (18 years, 2 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.32: +1 -2 lines
Diff to previous 1.32 (colored)

Replace USE_GCC_SHLIB with "USE_LANGUAGE=c c++" (the latter implies the
former) for applications that are known to require C++.

Revision 1.32 / (download) - annotate - [select for diffs], Sun Oct 3 00:14:56 2004 UTC (18 years, 4 months ago) by tv
Branch: MAIN
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.31 / (download) - annotate - [select for diffs], Tue Jun 15 08:06:52 2004 UTC (18 years, 7 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.30: +2 -1 lines
Diff to previous 1.30 (colored)

plotutils uses a c and c++ compiler.

XXX these packages need to be made to use a common Makefile fragment.

Revision 1.30 / (download) - annotate - [select for diffs], Mon May 31 16:47:48 2004 UTC (18 years, 8 months ago) by minskim
Branch: MAIN
Changes since 1.29: +3 -1 lines
Diff to previous 1.29 (colored)

Enable pkgviews installation.  Patches provided by Joachim Kuebart on
tech-pkg@.

Revision 1.29 / (download) - annotate - [select for diffs], Sat Feb 21 14:46:50 2004 UTC (18 years, 11 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.28: +3 -3 lines
Diff to previous 1.28 (colored)

bl3ify

Revision 1.28 / (download) - annotate - [select for diffs], Sat Aug 9 10:53:29 2003 UTC (19 years, 5 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.27: +1 -2 lines
Diff to previous 1.27 (colored)

USE_NEW_TEXINFO is unnecessary now.

Revision 1.27 / (download) - annotate - [select for diffs], Thu Jul 17 21:42:16 2003 UTC (19 years, 6 months ago) by grant
Branch: MAIN
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

s/netbsd.org/NetBSD.org/

Revision 1.26 / (download) - annotate - [select for diffs], Thu Jul 3 18:47:58 2003 UTC (19 years, 7 months ago) by seb
Branch: MAIN
Changes since 1.25: +5 -3 lines
Diff to previous 1.25 (colored)

Convert to USE_NEW_TEXINFO.

While here fix CONFLICTS.

Revision 1.25 / (download) - annotate - [select for diffs], Sat Jun 7 17:39:24 2003 UTC (19 years, 7 months ago) by jschauma
Branch: MAIN
Changes since 1.24: +9 -18 lines
Diff to previous 1.24 (colored)

Split plotutils and gnuplot into '<pkgname>' and '<pkgname>-nox11' each
(alternatively, we could have renamed one to '<pkgname>-x11', but for the
element of least surprise, the default remains x11 enabled).
This will work much better than the previous attempt to build two packages
from one Makefile, which wasn't all thought out wrt to dependencies, buildlinks etc.
Bump PKGREVISION on plotutils and gnuplot for this.

Revision 1.24 / (download) - annotate - [select for diffs], Fri Jun 6 14:39:06 2003 UTC (19 years, 7 months ago) by jschauma
Branch: MAIN
Changes since 1.23: +5 -1 lines
Diff to previous 1.23 (colored)

If X11 is present, set the pkgname to plotutils-x11 and conflict with
plain plotutils (and the other way around).  ok'd by agc.

Revision 1.23 / (download) - annotate - [select for diffs], Wed Jun 4 21:22:44 2003 UTC (19 years, 7 months ago) by jschauma
Branch: MAIN
Changes since 1.22: +3 -1 lines
Diff to previous 1.22 (colored)

We need bsd.prefs.mk -- sheesh, I should go home.

Revision 1.22 / (download) - annotate - [select for diffs], Wed Jun 4 21:19:42 2003 UTC (19 years, 7 months ago) by jschauma
Branch: MAIN
Changes since 1.21: +7 -1 lines
Diff to previous 1.21 (colored)

thiss package works with and without X11, but if X11 is present, we need the
necessary compile and ld flags

Revision 1.21 / (download) - annotate - [select for diffs], Wed Jun 4 18:21:50 2003 UTC (19 years, 8 months ago) by jschauma
Branch: MAIN
Changes since 1.20: +1 -2 lines
Diff to previous 1.20 (colored)

These don't really need X after all -- they can be useful on headless
machines without X, too, so remove USE_X11.

Revision 1.20 / (download) - annotate - [select for diffs], Thu May 29 23:14:09 2003 UTC (19 years, 8 months ago) by grant
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

s/USE_CXX/USE_GCC_SHLIB/ - there are more shared libraries than just
libstdc++ in gcc3.

when defined, USE_GCC_SHLIB ensures that the correct rpath is passed
to the linker, and a full dependency on the compiler package is
registered.

packages which define USE_GCC_SHLIB should not include
mk/gcc.buildlink2.mk (or gcc{,3}/buildlink2.mk) as it is handled
automatically.

Revision 1.19 / (download) - annotate - [select for diffs], Sat Jan 25 12:04:26 2003 UTC (20 years ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.18: +5 -5 lines
Diff to previous 1.18 (colored)

Use buildlink2.

Revision 1.18 / (download) - annotate - [select for diffs], Wed Mar 13 17:37:15 2002 UTC (20 years, 10 months ago) by fredb
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.17: +3 -2 lines
Diff to previous 1.17 (colored)

Give all packages which depend on "png" a version bump, and update
all dependencies on packages depending on "png" which contain shared
libraries, all for the (imminent) update to the "png" package.
[List courtesy of John Darrow, courtesy of "bulk-build".]

Revision 1.17 / (download) - annotate - [select for diffs], Mon Feb 18 15:14:21 2002 UTC (20 years, 11 months ago) by seb
Branch: MAIN
Changes since 1.16: +2 -3 lines
Diff to previous 1.16 (colored)

Introduce new framework for handling info files generation and installation.

Summary of changes:
- removal of USE_GTEXINFO
- addition of mk/texinfo.mk
- inclusion of this file in package Makefiles requiring it
- `install-info' substituted by `${INSTALL_INFO}' in PLISTs
- tuning of mk/bsd.pkg.mk:
    removal of USE_GTEXINFO
    INSTALL_INFO added to PLIST_SUBST
    `${INSTALL_INFO}' replace `install-info' in target rules
    print-PLIST target now generate `${INSTALL_INFO}' instead of `install-info'
- a couple of new patch files added for a handful of packages
- setting of the TEXINFO_OVERRIDE "switch" in packages Makefiles requiring it
- devel/cssc marked requiring texinfo 4.0
- a couple of packages Makefiles were tuned with respect of INFO_FILES and
  makeinfo command usage

See -newly added by this commit- section 10.24 of Packages.txt for
further information.

Revision 1.16 / (download) - annotate - [select for diffs], Mon Jun 11 06:34:38 2001 UTC (21 years, 7 months ago) by jlam
Branch: MAIN
Changes since 1.15: +1 -2 lines
Diff to previous 1.15 (colored)

CPPFLAGS is now passed to MAKE_ENV and CONFIGURE_ENV by bsd.pkg.mk, so
adapt by moving CPPFLAGS settings to top-level, and removing explicit
inclusion of CPPFLAGS into MAKE_ENV and CONFIGURE_ENV.

Revision 1.15 / (download) - annotate - [select for diffs], Tue May 22 09:32:22 2001 UTC (21 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Update dependency on png to >=1.0.11 because of the shlib major bump.
Noted by Frederick Bruckman.

Revision 1.14 / (download) - annotate - [select for diffs], Sun Mar 4 09:06:13 2001 UTC (21 years, 11 months ago) by tron
Branch: MAIN
CVS Tags: netbsd-1-5-PATCH001
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Because the minor number of the PNG library was increased packages compiled
using the newest PNG library won't work on system with an older one. To
prevent such problems with precompiled binary packages require at least
"png-1.0.9nb1" in all dependences.

Revision 1.13 / (download) - annotate - [select for diffs], Fri Feb 16 15:22:30 2001 UTC (21 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.12: +2 -1 lines
Diff to previous 1.12 (colored)

Update to new COMMENT style: COMMENT var in Makefile instead of pkg/COMMENT.

Revision 1.12 / (download) - annotate - [select for diffs], Fri Aug 25 23:47:13 2000 UTC (22 years, 5 months ago) by dmcmahill
Branch: MAIN
CVS Tags: netbsd-1-5-RELEASE, netbsd-1-4-PATCH003
Changes since 1.11: +4 -4 lines
Diff to previous 1.11 (colored)

make sure configure actually finds png

Revision 1.11 / (download) - annotate - [select for diffs], Thu Aug 24 00:08:39 2000 UTC (22 years, 5 months ago) by dmcmahill
Branch: MAIN
Changes since 1.10: +3 -1 lines
Diff to previous 1.10 (colored)

add depends on png so we always get that functionality

Revision 1.10 / (download) - annotate - [select for diffs], Thu Aug 24 00:03:47 2000 UTC (22 years, 5 months ago) by dmcmahill
Branch: MAIN
Changes since 1.9: +3 -3 lines
Diff to previous 1.9 (colored)

Update to plotutils-2.4.1.

Many bug fixes since the last release.  For a complete list of changes refer
to the NEWS file.

Notable additions include:
libplot: SVG driver added, which outputs the new XML-based SVG (scalable
         vector graphics) format.
documentation: man page for plotfont added.
libplot: completely new metafile export driver, written from scratch.
libplot: ReGIS driver added, which outputs ReGIS (DEC's remote graphics
         instruction set, understood by DEC's VT340 and earlier terminals,
         and also emulators like DEC's decterm).  No support yet for filling
         paths that extend beyond the boundaries of a ReGIS display, due to
         a need for clipping code.
graph,plot,tek2plot,plotfont,pic2plot: `-T png' now allowed if libplot
         contains a PNG driver.
libplot: PNG driver added, which outputs PNG (portable network graphics)
         format.  Included only if libpng (version number >= 0.95) and libz
         are found at package installation time.  `configure' now supports
         a `--without-libpng' option to disable PNG support.

Revision 1.9 / (download) - annotate - [select for diffs], Mon Aug 14 20:06:18 2000 UTC (22 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.8: +13 -12 lines
Diff to previous 1.8 (colored)

USE_PKGLIBTOOL -> USE_LIBTOOL. LTCONFIG_OVERRIDE saves a patch.

Revision 1.8 / (download) - annotate - [select for diffs], Tue Jul 18 23:07:46 2000 UTC (22 years, 6 months ago) by itohy
Branch: MAIN
Changes since 1.7: +3 -3 lines
Diff to previous 1.7 (colored)

Rename PKGNAME of plotutils to "plotutils-2.3nb1" as suggested.

Revision 1.7 / (download) - annotate - [select for diffs], Tue Jul 18 07:41:24 2000 UTC (22 years, 6 months ago) by itohy
Branch: MAIN
Changes since 1.6: +9 -5 lines
Diff to previous 1.6 (colored)

Enable C++ support, required by pstoedit.
This includes "libplotter" library and "pic2plot" utility.

Change PKGNAME to plotutils-2.3.0 to distinguish this
from non C++ version.          ^^

Revision 1.6 / (download) - annotate - [select for diffs], Thu Jun 1 11:23:31 2000 UTC (22 years, 8 months ago) by rh
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

s/USE_LIBTOOL/USE_PKGLIBTOOL/
Add a new USE_LIBTOOL definition that uses the libtool package instead of
pkglibtool which is now considered outdated.
USE_PKGLIBTOOL is available for backwards compatibility with old packages
but is deprecated for new packages.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Oct 10 14:33:07 1999 UTC (23 years, 3 months ago) by dmcmahill
Branch: MAIN
CVS Tags: netbsd-1-4-PATCH002, comdex-fall-1999
Changes since 1.4: +3 -3 lines
Diff to previous 1.4 (colored)

Update to plotutils-2.3.  Changes include:
- PNM driver added, which outputs PBM/PGM/PPM format.
- CGM support added, By default, a CGM Plotter produces
  binary-encoded version-3 CGM format, which conforms to the WebCGM
  profile.
- pseudo-GIF driver added, using miGIF run-length encoding routines
- text string format now supports "\fP" macro for switching to
  previous font (cf. troff; "\fR", "\fI", "\fB" supported too).
- libplotter: new C++ library.  Provides base Plotter class, subclasses for
  the different sorts of Plotter.
- new "dotdotdashed" line style added
- new thread save C/C++ API added (old API still supported)
- pic2plot: new utility, which can translate the pic language to any supported
  graphics format, including X11.
- new function pentype() added to the API.
- many bug fixes.  See the file 'NEWS' in the source distribution for a
  complete list (a couple of pages).

Revision 1.4 / (download) - annotate - [select for diffs], Wed Apr 14 21:39:03 1999 UTC (23 years, 9 months ago) by tron
Branch: MAIN
CVS Tags: netbsd-1-4-RELEASE, netbsd-1-4-PATCH001
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Remove unnecessary slash from master site list.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Feb 19 04:29:45 1999 UTC (23 years, 11 months ago) by tv
Branch: MAIN
Changes since 1.2: +3 -3 lines
Diff to previous 1.2 (colored)

Update to 2.1.6, and actually make use of pkglibtool.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Jan 30 23:18:50 1999 UTC (24 years ago) by agc
Branch: MAIN
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Replace all occurrences of USE_X11 with USE_X11BASE. This means "install this
package into ${X11BASE}".
Replace all occurrences of BUILD_USES_X11 with USE_X11. This means "use X11
headers and libraries to build this package".

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sat Nov 7 15:23:49 1998 UTC (24 years, 2 months ago) by frueauf
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of plotutils-2.1.5, Programs and library for plotting
scientific data. Provided in pr 6407 by Dan McMahill.

Revision 1.1 / (download) - annotate - [select for diffs], Sat Nov 7 15:23:49 1998 UTC (24 years, 2 months ago) by frueauf
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>