File:  [cvs.NetBSD.org] / pkgsrc / graphics / pfstools / Makefile
Revision 1.68: download - view: text, annotated - select for diffs
Mon Oct 12 21:52:00 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile,v 1.68 2020/10/12 21:52:00 bacon Exp $

DISTNAME=	pfstools-2.1.0
PKGREVISION=	11
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=pfstools/}
EXTRACT_SUFX=	.tgz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://pfstools.sourceforge.net/
COMMENT=	Tools for manipulating HDR images and video frames
LICENSE=	gnu-lgpl-v2.1

DEPENDS+=	dcraw-[0-9]*:../../graphics/dcraw

USE_CMAKE=		yes
USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_TOOLS+=		bash perl pkg-config
PKGCONFIG_OVERRIDE+=	src/pfs/pfs.pc.in
CMAKE_ARGS+=		-DBASH_EXECUTABLE=${TOOLS_BASH}
CMAKE_ARGS+=		-DPKGMANDIR=${PKGMANDIR}
CMAKE_ARGS+=		-DWITH_MATLAB=OFF
CMAKE_ARGS+=		-DWITH_OpenCV=OFF
CXXFLAGS+=		-std=c++14  # OpenEXR

SUBST_CLASSES+=		paths
SUBST_STAGE.paths=	pre-configure
SUBST_MESSAGE.paths=	Fixing paths in CMake modules.
SUBST_FILES.paths=	cmake/Find*.cmake
SUBST_SED.paths=	-e 's,/usr/local,${PREFIX},g'

SUBST_CLASSES+=		perl
SUBST_STAGE.perl=	pre-configure
SUBST_MESSAGE.perl=	Imprinting Perl path.
SUBST_FILES.perl=	src/camera/pfsinhdrgen.in
SUBST_SED.perl=		-e 's,@PERL_PATH@,${PERL5},g'

.include "options.mk"

.include "../../graphics/libexif/buildlink3.mk"
.include "../../graphics/netpbm/buildlink3.mk"
.include "../../graphics/openexr/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../math/fftwf/buildlink3.mk"
.include "../../math/gsl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>