File:  [cvs.NetBSD.org] / pkgsrc / graphics / openexr / Makefile
Revision 1.66: download - view: text, annotated - select for diffs
Sun Nov 17 09:20:49 2024 UTC (2 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
openexr: update to 3.3.2.

## Version 3.3.2 (November 11, 2024)

Patch release that fixes several bugs and build issues:

* A recent change to CMake had the unintended consequence of
  installing headers and libraries from `libdeflate` when doing an
  internal build. This is now fixed.
* Fix custom namespaces
* Add thread control to `exrmetrics` tool
* Reintroduce single cache for successive scanline reads
* Allow empty filename when providing a custom stream
* Handle non-seekable stream in python module's `InputFile` object

This release fixes:

* OSS-fuzz [372524117](https://issues.oss-fuzz.com/issues/372524117)
Null-dereference WRITE in Imf_3_4::ScanLineProcess::run_fill

# $NetBSD: Makefile,v 1.66 2024/11/17 09:20:49 wiz Exp $

DISTNAME=	openexr-3.3.2
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_GITHUB:=openexr/}
GITHUB_PROJECT=	openexr
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	adam@NetBSD.org
HOMEPAGE=	https://www.openexr.com/
COMMENT=	High dynamic-range (HDR) image file format library and tools
LICENSE=	modified-bsd

USE_LANGUAGES=	c c++

USE_CXX_FEATURES+=	c++17 filesystem

USE_TOOLS+=	pkg-config

PKGCONFIG_OVERRIDE=	cmake/OpenEXR.pc.in

PTHREAD_OPTS=	require

# https://github.com/AcademySoftwareFoundation/openexr/issues/1594
CMAKE_CONFIGURE_ARGS+=	-DBUILD_TESTING=OFF

CHECK_PORTABILITY_SKIP+=	Contrib/DtexToExr/bootstrap
CHECK_PORTABILITY_SKIP+=	share/util/reformat.sh

.include "../../devel/cmake/build.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../devel/libdeflate/buildlink3.mk"
.include "../../math/imath/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>