File:  [cvs.NetBSD.org] / pkgsrc / graphics / openexr / Makefile
Revision 1.61: download - view: text, annotated - select for diffs
Fri Apr 5 10:45:55 2024 UTC (10 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2, HEAD
openexr: update to 3.2.4.

## Version 3.2.4 (March 26, 2024)

Patch release that fixes handling of dwa compression in OpenEXRCore library.

Other miscellaneous changes:

- Add CMake `find_dependency` for `libdeflate`, to fix a vcpkg build error
- Remove the unused CMake option ``OPENEXR_INSTALL_EXAMPLES``
- Fix some other compiler warnings.

### Merged Pull Requests

* Fix typo causing prefix len to be wrong
* CMake packaging fix.
* Improve workflow filters
* 🐛 Remove the OPENEXR_INSTALL_EXAMPLES CMake option
* Initialize _ySampling to 0
* Use size_t as iterator instead of int

# $NetBSD: Makefile,v 1.61 2024/04/05 10:45:55 wiz Exp $

DISTNAME=	openexr-3.2.4
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_GITHUB:=openexr/}
GITHUB_PROJECT=	openexr
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	adam@NetBSD.org
HOMEPAGE=	https://www.openexr.com/
COMMENT=	High dynamic-range (HDR) image file format library and tools
LICENSE=	modified-bsd

USE_LANGUAGES=	c c++

USE_CXX_FEATURES+=	c++14

USE_TOOLS+=	pkg-config

PKGCONFIG_OVERRIDE=	cmake/OpenEXR.pc.in

PTHREAD_OPTS=	require

# https://github.com/AcademySoftwareFoundation/openexr/issues/1594
CMAKE_ARGS+=	-DBUILD_TESTING=OFF

CHECK_PORTABILITY_SKIP+=	Contrib/DtexToExr/bootstrap
CHECK_PORTABILITY_SKIP+=	share/util/reformat.sh

.include "../../devel/cmake/build.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../devel/libdeflate/buildlink3.mk"
.include "../../math/imath/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>