[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / netpbm

Annotation of pkgsrc/graphics/netpbm/Makefile, Revision 1.156

1.156   ! tnn         1: # $NetBSD: Makefile,v 1.155 2007/09/08 21:57:58 jlam Exp $
1.1       agc         2:
1.143     adam        3: DISTNAME=      netpbm-10.34
1.150     wiz         4: PKGREVISION=   1
1.1       agc         5: CATEGORIES=    graphics
1.47      tron        6: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=netpbm/}
1.36      tron        7: EXTRACT_SUFX=  .tgz
1.8       hubertf     8:
1.98      adam        9: MAINTAINER=    adam@NetBSD.org
1.49      dent       10: HOMEPAGE=      http://netpbm.sourceforge.net/
1.76      martti     11: COMMENT=       Toolkit for conversion of images between different formats
1.17      mycroft    12:
1.152     gdt        13: MAKE_JOBS_SAFE=        no
                     14:
1.84      jlam       15: PKG_INSTALLATION_TYPES=        overwrite pkgviews
                     16:
1.118     jlam       17: USE_TOOLS+=    bash:run gmake lex perl
1.155     jlam       18: USE_FEATURES=  snprintf
1.115     minskim    19:
1.67      tron       20: INSTALL_TARGET=        install-dev install-run
1.127     rillig     21: MAKE_ENV+=     INSTALL=${INSTALL:Q} STRIPFLAG=${_STRIPFLAG_INSTALL:Q} \
1.133     adam       22:                pkgdir=${STAGEDIR:Q} MACHINE=${MACHINE:Q}
1.144     obache     23: MAKE_FILE=     GNUmakefile
1.67      tron       24: PLIST_SRC=     ${WRKDIR}/PLIST_STAGE
1.131     adam       25: REPLACE_PERL+= editor/ppmfade editor/ppmshadow editor/pnmquant \
1.124     pooka      26:                generator/ppmrainbow manweb editor/pnmflip editor/ppmquant
1.67      tron       27: STAGEDIR=      ${WRKDIR}/staging
1.39      tron       28:
1.127     rillig     29: LIBS.SunOS+=   -lsocket -lnsl
1.146     rillig     30: MAKE_ENV+=     NETWORKLD=${LIBS:Q}
1.149     rillig     31: MAKE_FLAGS+=   PKGMANDIR=${PKGMANDIR}
1.91      grant      32:
1.151     rillig     33: WRAPPER_REORDER_CMDS+= reorder:l:rle:netpbm
                     34:
1.112     jlam       35: # Several of the netpbm shell scripts use bashisms, so force using
                     36: # bash for all of the shell scripts.
                     37: #
1.134     ghen       38: REPLACE_INTERPRETER+=  bash
1.135     ghen       39: REPLACE.bash.old=      .*/bin/sh
                     40: REPLACE.bash.new=      ${TOOLS_PATH.bash}
                     41: REPLACE_FILES.bash=    converter/other/anytopnm
                     42: REPLACE_FILES.bash+=   converter/other/pnmtoplainpnm
                     43: REPLACE_FILES.bash+=   converter/ppm/hpcdtoppm/hpcdtoppm
                     44: REPLACE_FILES.bash+=   converter/ppm/hpcdtoppm/pcdovtoppm
                     45: REPLACE_FILES.bash+=   editor/pamstretch-gen
                     46: REPLACE_FILES.bash+=   editor/pnmindex.sh
                     47: REPLACE_FILES.bash+=   editor/pnmmargin
                     48: REPLACE_FILES.bash+=   editor/ppmquantall
                     49: REPLACE_FILES.bash+=   other/ppmtomap
1.112     jlam       50:
1.117     minskim    51: .include "../../mk/bsd.prefs.mk"
                     52:
                     53: # Fiasco fails to compile on Darwin-8.x.
                     54: .if !empty(MACHINE_PLATFORM:MDarwin-8.*-*)
                     55: MAKE_ENV+=     BUILD_FIASCO=N
                     56: .endif
                     57:
1.142     minskim    58: .if ${OPSYS} == "Darwin"
                     59: MAKE_ENV+=     NETPBMLIBTYPE="dylib" NETPBMLIBSUFFIX="dylib"
1.153     tnn        60: .elif ${OPSYS} == "HPUX" && ${OBJECT_FMT} == "SOM"
                     61: MAKE_ENV+=     NETPBMLIBTYPE="unixshared" NETPBMLIBSUFFIX="sl"
1.142     minskim    62: .else
                     63: MAKE_ENV+=     NETPBMLIBTYPE="unixshared" NETPBMLIBSUFFIX="so"
                     64: .endif
                     65:
1.156   ! tnn        66: .if !empty(PKGSRC_COMPILER:Mido)
1.145     schwarz    67: CPPFLAGS+=     -DSGI_IDO_CC
                     68: .endif
                     69:
1.123     jlam       70: .include "../../graphics/jasper/buildlink3.mk"
                     71: .include "../../graphics/png/buildlink3.mk"
                     72: .include "../../graphics/tiff/buildlink3.mk"
1.143     adam       73: .include "../../textproc/libxml2/buildlink3.mk"
1.121     grant      74:
1.66      wiz        75: pre-configure:
1.60      wiz        76:        ${CP} ${WRKSRC}/Makefile.config.in ${WRKSRC}/Makefile.config
1.38      tron       77:
1.67      tron       78: pre-install:
1.71      tron       79:        ${RM} -fr ${STAGEDIR}
1.67      tron       80:
1.38      tron       81: post-install:
1.88      tron       82:        cd ${STAGEDIR} &&                                       \
                     83:        ${MV} link/* lib &&                                     \
                     84:        ${RM} -rf link man/web &&                               \
1.149     rillig     85:        (rmdir man || ${TRUE}) &&                               \
1.88      tron       86:        ${MKDIR} share/doc/netpbm &&                            \
                     87:        ${CP} ${WRKSRC}/doc/* share/doc/netpbm &&               \
1.148     reed       88:        ${MKDIR} ${PKGMANDIR}/man1 &&                           \
1.147     rillig     89:        ${MV} share/doc/netpbm/*.1      ${PKGMANDIR}/man1 &&    \
1.88      tron       90:        ${MV} misc share/netpbm &&                              \
                     91:        ${CHOWN} -R ${BINOWN}:${BINGRP} . &&                    \
                     92:        ${FIND} * \! -type d -print | ${SORT} >${PLIST_SRC} &&  \
                     93:        ${FIND} * -type d -print |                              \
                     94:        while read DIR; do                                      \
1.138     adam       95:                ${TEST} -d "${PREFIX}/$${DIR}" ||               \
                     96:                        ${ECHO} "@dirrm $${DIR}";               \
1.88      tron       97:        done >>${PLIST_SRC} &&                                  \
1.82      jmmv       98:        ${PAX} -rwpppm . ${PREFIX}
1.70      tron       99:        ${RM} -fr ${STAGEDIR}
1.137     tron      100:        ${FIND} ${PREFIX}/share/doc/netpbm -type f -print |     \
1.138     adam      101:                ${XARGS} ${CHMOD} ${NONBINMODE}
1.1       agc       102:
1.13      agc       103: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>