File:  [cvs.NetBSD.org] / pkgsrc / graphics / mypaint / Makefile
Revision 1.50: download - view: text, annotated - select for diffs
Mon Oct 12 21:52:00 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile,v 1.50 2020/10/12 21:52:00 bacon Exp $

DISTNAME=	mypaint-2.0.0
PKGREVISION=	6
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_GITHUB:=mypaint/}
EXTRACT_SUFX=	.tar.xz
GITHUB_PROJECT=	mypaint
GITHUB_RELEASE=	v${PKGVERSION_NOREV}

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	http://mypaint.org/
COMMENT=	Fast and easy open-source graphics application for digital painters
LICENSE=	gnu-gpl-v2

DEPENDS+=	${PYPKGPREFIX}-gobject3-[0-9]*:../../devel/py-gobject3
TOOL_DEPENDS+=	swig3-[0-9]*:../../devel/swig3

EGG_NAME=	MyPaint-${PKGVERSION_NOREV}a0

USE_LANGUAGES=	c c++

USE_TOOLS+=	bash:run msgfmt pkg-config

pre-configure:
	${LN} -sf ${PREFIX}/bin/swig3.0 ${BUILDLINK_DIR}/bin/swig

.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
BUILDLINK_API_DEPENDS.libmypaint+=	libmypaint>=1.5.0
.include "../../graphics/libmypaint/buildlink3.mk"
BUILDLINK_API_DEPENDS.mypaint-brushes+=	mypaint-brushes>=2.0
.include "../../graphics/mypaint-brushes/buildlink3.mk"
.include "../../textproc/json-c/buildlink3.mk"
.include "../../graphics/lcms2/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../devel/py-gobject3-common/buildlink3.mk"
.include "../../math/py-numpy/buildlink3.mk"
.include "../../lang/python/pyversion.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>