[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / libraw

File: [cvs.NetBSD.org] / pkgsrc / graphics / libraw / Makefile (download)

Revision 1.16, Sat Oct 22 13:44:12 2011 UTC (12 years, 6 months ago) by gls
Branch: MAIN
Changes since 1.15: +2 -2 lines

Upgrade graphics/libraw to 0.14.2

Upstream changes:

LibRaw 0.14.2 (19-10-2011)

        Fixed bug in Canon 1D and 1Ds files decoding.
        New decoder information bit DECODER_HASRAWCURVE

LibRaw 0.14.1 (11-10-2011)

        Imported dcraw 9.11/1.445:
            Support for new cameras added: Fujifilm
	     F600EXR, Nikon P7100, Olympus E-PL3 and
	     E-PM1, Panasonic DMC-FZ150, Sony NEX-5N,
	      A65 and A77.
            Updated color data for: Olympus E-P3,
	     Panasonic G3 and GF3, PhaseOne H25, P40
	     and P65, Sony NEX-C3, NEX-5, NEX-3, A35 and A55.
            Support for dark frame extraction on Sony cameras.
        DCB demosaicing: reserving 6 pixels instead of 3 to suppress colored
	 image frame.

LibRaw 0.14.0 (21-09-2011)

        Multiple rendering (LibRaw::dcraw_process() calls) allowed without
 	 re-opening RAW file thrfough the sequence of open()/unpack() calls.
        You should be able to change any processing parameters (except
	 shot_select parameter) between dcraw_process() calls.
            New sample in samples/multirender_test.cpp: renders data 4 times:
	     in half and full modes with different white balance settings.
            Unprocessed RAW data is stored in separate data buffer: (2 bytes
	     per pixel for all Bayer-pattern images, 8 bytes per pixel for
	     Foveon, sRAW, and other full-color raw formats), so now LibRaw
	     uses 25% more memory for full processing of most common Bayer
	     images; while for just unpack memory is reduced 4 times.
	    New call LibRaw::raw2image() fills imgdata.image array with
	     fresh copy of data. There is no need to call raw2image()
	     separately if you use dcraw_process() or dcraw_document_mode_processing()
	     calls.
	    New call LibRaw::get_decoder_info() to determine raw data storage
	     layout. See samples/unprocessed_raw.cpp for an example of how to
	     use it.
    	    New call LibRaw::free_image(), deallocates imgdata.image buffer.
	     Use this call if current postprocessing results are not needed,
	     but it is to early to call recycle() because dcraw_process()
	     may be called later.
    	    New C-API calls libraw_raw2image() - C API for LibRaw::raw2image()
	     libraw_free_image() - C API for LibRaw::free_image()
	     libraw_get_decoder_info() - C API for LibRaw::get_decoder_info()

If your code uses usual open()/unpack()/dcraw_process() call sequence, then
 NOTHING CHANGED: your program should produce same results. For interactive
 programs you may skip open()/unpack() calls after adjusting processing parameters,
 so user should see image refreshed much faster.

If your code uses raw data (open+unpack calls), you need to call
 LibRaw::raw2image(), and imgdata.image will contain same bitmap as in LibRaw 0.13.x

If you code uses access to masked borders data, you need to rewrite it. See
 samples/unprocessed_raw.cpp as a sample.

Other changes:

    No separate imgdata.masked_pixels buffers, Bayer raw formats are read to
     buffer with borders. So, no ugly add_masked_border_to_bitmap() call.
    No filtering_mode parameter. Raw tone curve is applied at unpack() stage;
     zero pixels removed on postprocesing stage.
    unprocessed_raw and 4colors samples are adjusted to use new RAW data
     storage layout.
    OpenMP speedup of postprocessing steps (up to 50% for half mode and
     4-core machine)
    Most of LibRaw_datastream function bodies are moved to separate source file
    LibRaw_windows_datastream is merged to main source tree
    Imported dcraw 9.10 (1.444), support for new cameras added: ARRIRAW format,
     Canon SX30 IS, Leica D-LUX 5 and V-LUX2, Olympus E-P3, Panasonic G3 and GF3,
     Sony NEX-C3 and SLT-A35
    Support for RedOne digital movie cameras (R3D format). To enable this
     support you need to:
        install libjasper JPEG2000 support library
        compile LibRaw with -DUSE_JASPER compiler switch
         (./configure will do it for you)
        If you use own LibRaw_datastream implementation, you should implement
         make_jas_stream() call for your datastream. See bottom of
         src/libraw_cxx.cpp for implementations in datafile and mem-buffer LibRaw
         streams.

Bugfix: green matching is turned off if output image is shrinked due to wavelet
 filtering or aberration correction.
Removed imgdata.sizes.bottom_margin and right_margin data fields use
 imgdata.sizes.raw_width - width - left_margin to get right one, the same
 with bottom_margin.
Minor ./configure cleanup
Qmake files and Visual Studio Project files are updated.
New version check macroses.
Documentation changed to reflect 0.14 changes.
Removed LibRaw::rotate_fuji_raw() call and corresponding C-API call.
The LibRaw::adjust_sizes_info_only() call may be called repeated and mixed
 with dcraw_process() calls.
Postprocessing speedup and optimization, especially if cropping set.
Cropping works for FujiCCD raws. For the technical reasons, the position of
 top-left corner of crop area will be rounded to the nearest multiple of 4
 (the corner is shifted top-left).
New sample samples/postprocessing_benchmark.cpp This sample measures
 postprocessing speed. All demosaic methods, averaged white balance,
 median filtering, wavelet filtration, highlight recovery, and cropping
 are supported.

all client code should be recompiled due to internals change.

# $NetBSD: Makefile,v 1.16 2011/10/22 13:44:12 gls Exp $
#

DISTNAME=		LibRaw-0.14.2
PKGNAME=		${DISTNAME:tl}
CATEGORIES=		graphics
MASTER_SITES=	http://www.libraw.org/data/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.libraw.org/
COMMENT=	Raw decoding/processing library
LICENSE=	gnu-lgpl-v2.1 OR cddl-1.0

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES=	c c++
GNU_CONFIGURE=	yes
USE_TOOLS+=		pkg-config gmake
USE_LIBTOOL=	yes
MAKE_JOBS_SAFE=	no

CONFIGURE_ARGS+=	--disable-examples
CONFIGURE_ARGS+=	--disable-demosaic-pack-gpl2
CONFIGURE_ARGS+=	--disable-demosaic-pack-gpl3

PKGCONFIG_OVERRIDE+=	libraw.pc.in
PKGCONFIG_OVERRIDE+=	libraw_r.pc.in

.include "../../graphics/lcms/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"