[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / iGMT

File: [cvs.NetBSD.org] / pkgsrc / graphics / iGMT / Makefile (download)

Revision 1.28, Sat Mar 4 21:29:49 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.27: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.28 2006/03/04 21:29:49 jlam Exp $

DISTNAME=		igmt_v1.2
PKGNAME=		iGMT-1.2
PKGREVISION=		4
CATEGORIES=		graphics
MASTER_SITES=		http://op.gfz-potsdam.de/igmt/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://op.gfz-potsdam.de/igmt/
COMMENT=		Interactive Mapping of Geoscientific Datasets

DEPENDS+=		GMT>=3.3.6:../../graphics/GMT
DEPENDS+=		tcl>=8.0:../../lang/tcl
DEPENDS+=		tk>=8.0:../../x11/tk
DEPENDS+=		gv-[0-9]*:../../print/gv
DEPENDS+=		ImageMagick>=5.3.9nb1:../../graphics/ImageMagick

WRKSRC=			${WRKDIR}/igmt_1.2
NO_BUILD=		yes

USE_TOOLS+=		gs:run
GMT_PREFIX_DEFAULT=	${LOCALBASE}
EVAL_PREFIX+=		GMT_PREFIX=GMT
EVAL_PREFIX+=		TK_PREFIX=tk
INSTALLATION_DIRS=	bin

.include "../../mk/x11.buildlink3.mk"

do-configure:
	for i in ${WRKSRC}/igmt ${WRKSRC}/igmt_configure.tcl; do	\
		${SED} -e 's:@PREFIX@:'${PREFIX}':g'			\
		       -e 's:@GMT_PREFIX@:'${GMT_PREFIX}':g'		\
		       -e 's:@TK_PREFIX@:'${TK_PREFIX}':g'		\
		$$i > $$i.tmp && ${MV} -f $$i.tmp $$i;			\
	done

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/igmt ${PREFIX}/bin
	${INSTALL_DATA_DIR} ${PREFIX}/share/igmt
	cd ${WRKSRC} && ${INSTALL_DATA} manual.ps README.TXT NOTES.TXT 	\
		COPYING COPYRIGHT ${PREFIX}/share/igmt/
	${INSTALL_DATA_DIR} ${PREFIX}/share/igmt/colormaps
	${INSTALL_DATA} ${WRKSRC}/colormaps/* ${PREFIX}/share/igmt/colormaps/
	cd ${WRKSRC} && ${INSTALL_SCRIPT} igmt*.tcl *.awk 		\
		igmt_helper* *.batch ${PREFIX}/share/igmt/
	cd ${WRKSRC} && ${INSTALL_DATA} 01_02-98.cmt			\
		gps.vel hotspots.dat nuvel.yx igmt_def.gif		\
		allslabs_rum.gmt volcanoes.dat wcity.dat		\
		wcity_major.dat	igmt_gmtdefaults_3.0			\
		igmt_gmtdefaults_3.1 igmt_gmtdefaults_3.2		\
		igmt_gmtdefaults_3.3 ${PREFIX}/share/igmt/
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/igmt
	cd ${WRKSRC} && ${INSTALL_DATA} example*.ps.gz			\
		${WRKSRC}/example*.dat ${PREFIX}/share/examples/igmt/

.include "../../mk/bsd.pkg.mk"