[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / hugin

File: [cvs.NetBSD.org] / pkgsrc / graphics / hugin / Makefile (download)

Revision 1.56, Sun Oct 18 15:56:56 2015 UTC (8 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.55: +19 -25 lines

Changes 2015.0.0:
Hugin 2015.0 has a number of new features. Most of the changes are under the hood to improve stability, allow easier maintenance and easier addition of new features.
The makefile based stitching engine has been replaced with direct calls to the underlying programs. This should reduce the overhead of calling the same program too often and so speed up the whole process. Hopefully this also allows the usage of more unusual characters in the filename. Instead of pto2mk and make we now have hugin_executor which can also be used for running the assistant from the command line.
Hugin now has it's own blender, verdandi, based on a watershed algorithm, which has been included in 'nona'. verdandi can be chosen as the blender by choosing "builtin" in the stitcher tab, and can also be set in the Preferences. verdandi can also be called as a command line tool.
The lensfun library has been removed as it did not fulfill our expectations. It has been replaced with our own camera and lens database which uses a data mining approach and operates automatically without user intervention. Geometric distortion and vignetting data have to be loaded manually.
The fast preview window has a new tool to add or remove control points to selected areas in the output projection.
Automatic exposure stack detection is now applied when loading images, and an option has been added to unlink image position when adding stacks.
The fine-tune and auto-estimate functions in the control point tab have been made projection aware. It should now work also with images with different fov or different projections. The fine-tune feature has had a significant speed up when Hugin is compiled with the libfftw3 library (optional).
PTBatcherGUI has more choice for the end of the process: depending on the operating system the PTBatcherGUI can be closed, the computer can be shut down or send to the hibernate mode.
PTBatcherGUI now shows the thumbnails when searching for images in directories.
Many of the underlying tools in hugin are now able to use available cpu cores.

# $NetBSD: Makefile,v 1.56 2015/10/18 15:56:56 adam Exp $

DISTNAME=	hugin-2015.0.0
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=hugin/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://hugin.sourceforge.net/
COMMENT=	Panorama photo stitcher
LICENSE=	gnu-gpl-v2

DEPENDS+=	enblend-enfuse>=4.0:../../graphics/enblend-enfuse
DEPENDS+=	p5-Image-ExifTool>=8.15:../../graphics/p5-Image-ExifTool

USE_CMAKE=		yes
USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_TOOLS+=		msgfmt pkg-config

CMAKE_ARGS+=		-DBUILD_HSI=OFF

SUBST_CLASSES+=		apple
SUBST_MESSAGE.apple=	Avoiding Mac OS X application bundles
SUBST_STAGE.apple=	pre-configure
SUBST_FILES.apple=	src/hugin1/hugin/CMakeLists.txt
SUBST_FILES.apple+=	src/hugin1/ptbatcher/CMakeLists.txt
SUBST_FILES.apple+=	src/hugin1/icpfind/CMakeLists.txt
SUBST_FILES.apple+=	src/hugin1/stitch_project/CMakeLists.txt
SUBST_SED.apple=	-e 's,(APPLE),(ELPPA),g'

.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../devel/swig2/buildlink3.mk"
.include "../../devel/tclap/buildlink3.mk"
.include "../../graphics/exiv2/buildlink3.mk"
.include "../../graphics/glew/buildlink3.mk"
.include "../../graphics/glut/buildlink3.mk"
.include "../../graphics/gnome-icon-theme/buildlink3.mk"
.include "../../graphics/lensfun/buildlink3.mk"
.include "../../graphics/libpano13/buildlink3.mk"
.include "../../graphics/openexr/buildlink3.mk"
.include "../../graphics/vigra/buildlink3.mk"
#.include "../../lang/python/extension.mk"
.include "../../math/fftw/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/wxGTK30/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"