[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / gnuplot

File: [cvs.NetBSD.org] / pkgsrc / graphics / gnuplot / Makefile (download)

Revision 1.21, Sat Jun 7 17:39:25 2003 UTC (20 years, 10 months ago) by jschauma
Branch: MAIN
Changes since 1.20: +15 -23 lines

Split plotutils and gnuplot into '<pkgname>' and '<pkgname>-nox11' each
(alternatively, we could have renamed one to '<pkgname>-x11', but for the
element of least surprise, the default remains x11 enabled).
This will work much better than the previous attempt to build two packages
from one Makefile, which wasn't all thought out wrt to dependencies, buildlinks etc.
Bump PKGREVISION on plotutils and gnuplot for this.

# $NetBSD: Makefile,v 1.21 2003/06/07 17:39:25 jschauma Exp $
#

DISTNAME=		gnuplot-3.7.3
SVR4_PKGNAME=		gplot
PKGREVISION=		1
CATEGORIES=		graphics x11
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=gnuplot/} \
			ftp://ftp.ucc.ie/pub/gnuplot/ \
			ftp://ftp.cc.monash.edu.au/pub/gnuplot/

MAINTAINER=		root@garbled.net
HOMEPAGE=		http://sourceforge.net/projects/gnuplot/
COMMENT=		gnuplot is a nice plotting utility

CONFLICTS+=             ${DISTNAME:C/-[0-9].*//}

GNU_CONFIGURE=		YES
USE_BUILDLINK2=		YES
# because of missing rl_complete_with_tilde_expansion and rl_terminal_name
USE_GNU_READLINE=	YES
USE_X11=		YES

CONFIGURE_ARGS+=	--with-pdf
CONFIGURE_ARGS+=	--with-plot=${LOCALBASE}
CONFIGURE_ARGS+=	--with-readline=${BUILDLINK_PREFIX.readline}

.include "../../devel/readline/buildlink2.mk"
.include "../../graphics/plotutils/buildlink2.mk"
.include "../../graphics/png/buildlink2.mk"
.include "../../print/pdflib/buildlink2.mk"
.include "../../mk/texinfo.mk"
.include "../../mk/bsd.pkg.mk"