[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / gd

File: [cvs.NetBSD.org] / pkgsrc / graphics / gd / Makefile (download)

Revision 1.86, Thu Jan 6 18:01:21 2011 UTC (13 years, 3 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.85: +2 -2 lines

add a patch from upstream to fix a bug which made that fontconfig
support could not be switched off once enabled
(could make a difference for gnuplot but I couldn't find a testcase yet)

# $NetBSD: Makefile,v 1.86 2011/01/06 18:01:21 drochner Exp $

DISTNAME=	gd-2.0.35
PKGREVISION=	7
CATEGORIES=	graphics
MASTER_SITES=	http://www.libgd.org/releases/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	adam@NetBSD.org
HOMEPAGE=	http://www.libgd.org/
COMMENT=	Graphics library for the dynamic creation of images

PKG_DESTDIR_SUPPORT=	user-destdir

.include "options.mk"

# fails in test not finding libgd.a
MAKE_JOBS_SAFE=		no

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_LIBTOOL=		yes
USE_TOOLS+=		perl:run
GNU_CONFIGURE=		yes
REPLACE_PERL+=		bdftogd
PTHREAD_AUTO_VARS=	yes

# Make sure configure doesn't find an old (possibly non-Pkgsrc)
# libpng12-config executable.  If it does, it will override the Pkgsrc
# version, but fail to configure, and fail to build in PNG support.
CONFIGURE_ENV+=		ac_cv_path_LIBPNG12_CONFIG=""

.include "../../devel/zlib/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"

.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"