[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / feh

File: [cvs.NetBSD.org] / pkgsrc / graphics / feh / Makefile (download)

Revision 1.80, Thu Apr 20 13:41:39 2017 UTC (6 years, 11 months ago) by szptvlfn
Branch: MAIN
Changes since 1.79: +2 -2 lines

Update to 2.18.3

http://git.finalrewind.org/feh/plain/ChangeLog:
Tue, 04 Apr 2017 21:22:16 +0200  Daniel Friesel <derf+feh@finalrewind.org>

* Release v2.18.3
    * Fix double-free/OOB-write in E17 IPC. This only affects the
      background setting options and requires a malicious X11 app to run
      alongside feh and pretend to be an E17 window manager.
      (patch by Tobias Stoeckmann)
    * Fix image-specific format specifiers not being updated correctly in
      thumbnail mode window titles
    * Fix memory leak when closing images opened from thumbnail mode
    * Fix a possible out of bounds read caused by an unterminated string when
      using --output to save images in long paths. (patch by Tobias Stoeckmann)
    * Fix out of bounds read/write when handling empty or broken caption files.
      (patch by Tobias Stoeckmann)
    * Fix memory leak when saving a filelist or image whose target filename
      already exists. (patch by Tobias Stoeckmann)

# $NetBSD: Makefile,v 1.80 2017/04/20 13:41:39 szptvlfn Exp $

DISTNAME=	feh-2.18.3
CATEGORIES=	graphics
MASTER_SITES=	https://feh.finalrewind.org/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://feh.finalrewind.org/
COMMENT=	Imlib2 based image viewer
LICENSE=	mit

USE_LANGUAGES=	c99

USE_TOOLS+=	gmake

LDFLAGS.SunOS+=		-lnsl -lsocket

BUILDLINK_DEPMETHOD.libXt?=	build

.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/imlib2/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"