[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / evas

File: [cvs.NetBSD.org] / pkgsrc / graphics / evas / Makefile.common (download)

Revision 1.18, Fri May 1 00:08:22 2020 UTC (3 years, 11 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.17: +3 -3 lines

Update to evas 1.7.10 including plugins:
   * Correctly detect if a loader support asynchronous preloading.
   * Fix memory leak in evas textgrid
   * Evas: Fix evas_common_convert_yuv_42* functions to actually return the converted data.
   * Evas textblock: Fixed issue when parsing formats with quotes.
   * Evas textblock: Make the ellipsis format the same as the surrounding.
   * evas/wayland_egl: Skip makecurrent if re->win is NULL.
   * Evas textblock: Added proper size adjustments for "high" shaped texts.
   * Evas bidi: Fixed a bug causing BiDi not to work in some cases.
   * Evas textblock: fixed an issue with markup_get and markup_to_utf8 behaving differently (markup_get was misbehaving).
   * evas/wayland_egl: Do not create a new surface if we already have one.
   * Fixed the textblock format to be drawn according to the glyph's horizontal advance width.
   * Evas textblock: Fixed order of tags inserted with markup_app/prepend.
   * Evas textblock: Fixed wrapping of lines ending with whites.

# $NetBSD: Makefile.common,v 1.18 2020/05/01 00:08:22 joerg Exp $

# used by graphics/evas-buffer/Makefile
# used by graphics/evas-edb/Makefile
# used by graphics/evas-eet/Makefile
# used by graphics/evas-gif/Makefile
# used by graphics/evas-jpeg/Makefile
# used by graphics/evas-pmaps/Makefile
# used by graphics/evas-png/Makefile
# used by graphics/evas-sdl/Makefile
# used by graphics/evas-sdl-16/Makefile
# used by graphics/evas-software-x11/Makefile
# used by graphics/evas-tiff/Makefile
# used by graphics/evas-xpm/Makefile

EVAS_VERSION=	1.7.10
DISTNAME=	evas-${EVAS_VERSION}
CATEGORIES=	graphics
MASTER_SITES=	https://download.enlightenment.org/att/releases/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	joerg@NetBSD.org
HOMEPAGE=	https://enlightenment.org/
LICENSE=	2-clause-bsd

DISTINFO_FILE=	${.CURDIR}/../../graphics/evas/distinfo
PATCHDIR=	${.CURDIR}/../../graphics/evas/patches

GNU_CONFIGURE=	yes
USE_LIBTOOL=	yes
USE_TOOLS+=	gmake pkg-config

.for mod in software-ddraw software-16-ddraw direct3d software-16-wince \
	software-xlib software-16-x11 software-xcb directfb sdl \
	sdl-primitive fb buffer software-qtopia gl-xlib quartz gl-glew \
	xrender-x11 xrender-xcb glitz-x11 wayland-shm wayland-egl
.  if defined(EVAS_ENGINES) && !empty(EVAS_ENGINES:M${mod})
CONFIGURE_ARGS+=	--enable-${mod}
.  else
CONFIGURE_ARGS+=	--disable-${mod}
.  endif
.endfor

.for mod in gif png jpeg eet edb tiff xpm svg pmaps
.  if defined(EVAS_IMAGE_LOADERS) && !empty(EVAS_IMAGE_LOADERS:M${mod})
CONFIGURE_ARGS+=	--enable-image-loader-${mod}
.  else
CONFIGURE_ARGS+=	--disable-image-loader-${mod}
.  endif
.endfor

CONFIGURE_ENV+=	ACLOCAL=: AUTOCONF=: AUTOMAKE=:

.include "../../mk/bsd.prefs.mk"

.if !empty(MACHINE_PLATFORM:M*-powerpc)
CONFIGURE_ARGS+=	--enable-cpu-altivec
.endif

# currently it is like it is
MODULE_ARCH=		${LOWER_OPSYS}-${MACHINE_ARCH}-${EVAS_VERSION}
PLIST_SUBST=		MODULE_ARCH=${MODULE_ARCH}
PRINT_PLIST_AWK+=	{ gsub(/${MODULE_ARCH}/, "$${MODULE_ARCH}") }

MAKE_FLAGS+=	MODULE_ARCH=${MODULE_ARCH}