[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / enblend-enfuse

File: [cvs.NetBSD.org] / pkgsrc / graphics / enblend-enfuse / Makefile (download)

Revision 1.22, Fri Oct 25 08:13:04 2013 UTC (10 years, 5 months ago) by adam
Branch: MAIN
Changes since 1.21: +2 -3 lines

Changes 4.1.2:
** Bug Fixes
- [Enblend and Enfuse] Fix a bug in the highlight-recovery that caused
  Enfuse to bail out with the uncaught exception
    "Minimizer1D::set_bracket: minimum not bracketed".
  This addresses LaunchPad Bug 1214004.
- [Enfuse] Clean up seemingly random, bright-colored pixels that
  sometimes show up when fusing images with high contrast and "large"
  color profiles.

# $NetBSD: Makefile,v 1.22 2013/10/25 08:13:04 adam Exp $

DISTNAME=	enblend-enfuse-4.1.2
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=enblend/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://enblend.sourceforge.net/
COMMENT=	Combines overlapping images without seams, with good exposure
LICENSE=	gnu-gpl-v2

USE_LANGUAGES=		c c++
USE_LIBTOOL=		yes
USE_TOOLS+=		gmake perl:build pkg-config
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--with-boost-filesystem

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "Darwin"
CONFIGURE_ARGS+=	--enable-openmp
CONFIGURE_ARGS+=	--with-apple-opengl-framework
.else
CONFIGURE_ARGS+=	--with-x
.include "../../graphics/glut/buildlink3.mk"
.endif

LIBS+=			-lboost_system

.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/boost-libs/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/glew/buildlink3.mk"
.include "../../graphics/lcms2/buildlink3.mk"
.include "../../graphics/openexr/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../graphics/vigra/buildlink3.mk"
.include "../../math/gsl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"