CVS log for pkgsrc/graphics/cal3d/Makefile.common
Up to [cvs.NetBSD.org] / pkgsrc / graphics / cal3d
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
Revision 1.17: download - view: text, markup, annotated - select for diffs
Wed Aug 2 19:21:53 2023 UTC (16 months, 1 week ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base,
pkgsrc-2024Q3,
pkgsrc-2024Q2-base,
pkgsrc-2024Q2,
pkgsrc-2024Q1-base,
pkgsrc-2024Q1,
pkgsrc-2023Q4-base,
pkgsrc-2023Q4,
pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
HEAD
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +5 -2
lines
*: Mark packages that were originally identified as requiring
C++03 due to failing to build with a C++14 default compiler
with FORCE_CXX_STD instead of USE_LANGUAGES.
Revision 1.16: download - view: text, markup, annotated - select for diffs
Sat Jan 30 08:57:02 2021 UTC (3 years, 10 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +3 -4
lines
(graphics/cal3d) Updated 0.9.1 to 0.11.0, build fix
o-----------------------------------------------------------------------------o
| Version 0.11.0 ( 29 june 2006)
o-----------------------------------------------------------------------------o
- Make the list of the root bones a vector. So the root bones can be acceded
in C wrapper.
- Add some missing function to access to private variables.
- Add cal3d_converter to the default distribution with manual page and file format
description (tools subdirectory is therefore removed)
- The destructor of CalModel is now virtual.
- Made CalModel noncopyable to prevent shallow pointer copying bugs.
- Use a RefCounted base class and RefPtr smart pointers to hold RefCounted objects.
- Make CalModel destructor nonvirtual
- Improve bounding boxes calculation performance.
- Update the C wrapper.
- Add some function to rotate around axis during the loading.
- When a cycle animation is played, ensure that the last post equals the first pose.
- Extended callback mechanism to pass user data directly instead of making
the callback query for it. This means the callback executable does not have
to link with cal3d.lib and makes many things simpler in CS context.
Also worked around a bug (feature?) in the mixer which thinks that
m_AnimDuration is always 0 for AnimActions. Now the callback uses the
internal time counter of the animation, which is probably more consistent
anyway.
- VC6 and automake fixes. Removed old variables from src/cal3d/Makefile.am.
- 64bit compatibility fixes.
- Patch for reading correctly raw texture on a Big endian cpu (for Mac).
- Fixed bug in updating current anim time when time factor is set to negative.
- Correction in max exporters.
- Update the glew (The OpenGL Extension Wrangler Library).
- Made the refcounted classes derive from RefCounted, and manage
their lifetimes with RefPtr smart pointers.
- Put TinyXML into the cal3d namespace so it doesn't conflict with other
libraries linking with their own TinyXML.
- Fixed bug in updating current anim time when time factor is set to negative,
which resuilted in anim times like -32 instead of between 0 and 2 seconds,
for example. This threw the bone extrapolations way off and made the model
look like garbage until the anim time got back in the right zone. (Keith Fulton)
- GNU/Linux compilation / packaging fixes (-DCAL_16BIT_INDICES is included if
relevant in the .pc)
- Upgraded the guide
o-----------------------------------------------------------------------------o
| Version 0.10.0 ( 12 january 2005)
o-----------------------------------------------------------------------------o
- CalModel::setAbstractMixer and CalAbstractMixer to enable third
party mixers.
- Symbolic names for coreMaterial, coreMesh, coreAnimations loaded
by coremodel.{h,cpp}
- Add functions to control force of the spring system
- CalHardwareModel : a object to store and to compute information
needed to do hardware vertex skinning.
- Add a time factor to allow reverse time of sync animation.
- Most of the math functions are now inline.
- Add an option to stop a action animation at the end.
- Add functions to rescale a core model,
but this can be done only before creating the CalModel.
- Fix in the XML loader
- Add a function to compute the global bounding box of the model.
- Rename calculateBoundingBox to calculateBoundingBoxes.
- Add reference counting. Core* objects can be
now shared between several coremodel correctly.
- Modify the XML file format to be XML valid
- Added animation callbacks.
- Added Maya exporter.
- create/destroy functions removed.
- Add a "stride" argument to getVertices(), getNormals() ...
Revision 1.15: download - view: text, markup, annotated - select for diffs
Fri Mar 20 11:57:46 2020 UTC (4 years, 8 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2
lines
*: Convert broken sourceforge HOMEPAGEs back to http
Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Jan 18 23:32:10 2020 UTC (4 years, 10 months ago) by rillig
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2
lines
all: migrate several HOMEPAGEs to https
pkglint --only "https instead of http" -r -F
With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.
This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Nov 2 22:37:54 2019 UTC (5 years, 1 month ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +3 -3
lines
graphics: align variable assignments
pkglint -Wall -F --only aligned --only indent -r
No manual corrections.
Revision 1.12: download - view: text, markup, annotated - select for diffs
Wed Jul 18 00:06:18 2018 UTC (6 years, 4 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2
lines
Mark packages that require C++03 (or the GNU variants) if they fail with
C++14 default language.
Revision 1.11: download - view: text, markup, annotated - select for diffs
Sat Jan 26 22:01:07 2013 UTC (11 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2,
pkgsrc-2014Q1-base,
pkgsrc-2014Q1,
pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +3 -1
lines
Add some used-by lines.
Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Jan 19 09:16:24 2008 UTC (16 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2012Q4-base,
pkgsrc-2012Q4,
pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1,
pkgsrc-2011Q4-base,
pkgsrc-2011Q4,
pkgsrc-2011Q3-base,
pkgsrc-2011Q3,
pkgsrc-2011Q2-base,
pkgsrc-2011Q2,
pkgsrc-2011Q1-base,
pkgsrc-2011Q1,
pkgsrc-2010Q4-base,
pkgsrc-2010Q4,
pkgsrc-2010Q3-base,
pkgsrc-2010Q3,
pkgsrc-2010Q2-base,
pkgsrc-2010Q2,
pkgsrc-2010Q1-base,
pkgsrc-2010Q1,
pkgsrc-2009Q4-base,
pkgsrc-2009Q4,
pkgsrc-2009Q3-base,
pkgsrc-2009Q3,
pkgsrc-2009Q2-base,
pkgsrc-2009Q2,
pkgsrc-2009Q1-base,
pkgsrc-2009Q1,
pkgsrc-2008Q4-base,
pkgsrc-2008Q4,
pkgsrc-2008Q3-base,
pkgsrc-2008Q3,
pkgsrc-2008Q2-base,
pkgsrc-2008Q2,
pkgsrc-2008Q1-base,
pkgsrc-2008Q1,
cwrapper,
cube-native-xorg-base,
cube-native-xorg
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2
lines
Reset maintainer on his request.
Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu Feb 22 19:26:33 2007 UTC (17 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2007Q4-base,
pkgsrc-2007Q4,
pkgsrc-2007Q3-base,
pkgsrc-2007Q3,
pkgsrc-2007Q2-base,
pkgsrc-2007Q2,
pkgsrc-2007Q1-base,
pkgsrc-2007Q1
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2
lines
Whitespace cleanup, courtesy of pkglint.
Patch provided by Sergey Svishchev in private mail.
Revision 1.8: download - view: text, markup, annotated - select for diffs
Sat Jul 22 04:46:16 2006 UTC (18 years, 4 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2006Q4-base,
pkgsrc-2006Q4,
pkgsrc-2006Q3-base,
pkgsrc-2006Q3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2
lines
Added "c" to USE_LANGUAGES for packages that use GNU configure scripts,
since they always need a C compiler, even when the source code is
completely in C++.
For some other packages, stated in the comment that a C compiler is
really not needed.
Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon May 22 18:21:10 2006 UTC (18 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2006Q2-base,
pkgsrc-2006Q2
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -1
lines
USE_LANGUAGES=c++
Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Jun 1 20:08:00 2005 UTC (19 years, 6 months ago) by jlam
Branches: MAIN
CVS tags: pkgsrc-2006Q1-base,
pkgsrc-2006Q1,
pkgsrc-2005Q4-base,
pkgsrc-2005Q4,
pkgsrc-2005Q3-base,
pkgsrc-2005Q3,
pkgsrc-2005Q2-base,
pkgsrc-2005Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -5
lines
Remove mk/autoconf.mk and mk/automake.mk and replace their usage with
USE_TOOLS and any of "autoconf", "autoconf213", "automake" or
"automake14". Also, we don't need to call the auto* tools via
${ACLOCAL}, ${AUTOCONF}, etc., since the tools framework takes care
to symlink the correct tool to the correct name, so we can just use
aclocal, autoconf, etc.
Revision 1.5: download - view: text, markup, annotated - select for diffs
Mon Apr 11 21:46:00 2005 UTC (19 years, 8 months ago) by tv
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +1 -2
lines
Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.
Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat Sep 4 23:40:43 2004 UTC (20 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2005Q1-base,
pkgsrc-2005Q1,
pkgsrc-2004Q4-base,
pkgsrc-2004Q4,
pkgsrc-2004Q3-base,
pkgsrc-2004Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2
lines
AUTOMAKE_REQD should only be set to 1.4 in the few cases where needed,
otherwise the default is better (and the variable doesn't need to be set).
Remove a few cases where it was set unnecessarily.
Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Feb 14 17:21:40 2004 UTC (20 years, 9 months ago) by jlam
Branches: MAIN
CVS tags: pkgsrc-2004Q2-base,
pkgsrc-2004Q2,
pkgsrc-2004Q1-base,
pkgsrc-2004Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +1 -2
lines
LIBTOOL_OVERRIDE and SHLIBTOOL_OVERRIDE are now lists of shell globs
relative to ${WRKSRC}. Remove redundant LIBTOOL_OVERRIDE settings that
are automatically handled by the default setting in bsd.pkg.mk.
Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Feb 11 01:32:06 2004 UTC (20 years, 10 months ago) by garbled
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +1 -1
lines
Now that PR 24378 has been fixed, take the hack out of Makefile.common so
these packages build the way they were intended to.
Revision 1.1.1.1 (vendor branch): download - view: text, markup, annotated - select for diffs
Tue Feb 10 09:14:34 2004 UTC (20 years, 10 months ago) by garbled
Branches: TNF
CVS tags: pkgsrc-base
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +0 -0
lines
Add new package for cal3d-0.9.1, a 3D skeletal animation library.
Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Feb 10 09:14:34 2004 UTC (20 years, 10 months ago) by garbled
Branches: MAIN
Initial revision
CVSweb <webmaster@jp.NetBSD.org>