[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / cairo

File: [cvs.NetBSD.org] / pkgsrc / graphics / cairo / Makefile (download)

Revision 1.80, Sun Feb 21 13:02:46 2010 UTC (14 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.79: +2 -3 lines

Update to 1.8.10:

Release 1.8.10 (2010-02-19 Carl Worth <cworth@cworth.org>)
==========================================================
The cairo community is pleased to announce the 1.8.10 release of the
cairo graphics library. This is the fifth update to cairo's stable 1.8
series. This release consists of about a dozen hand-picked fixes
compared to 1.8.8 (which was released about 8 months ago).

We recommend that everyone using cairo upgrade to 1.8.10.

-Carl

General Bug fixes
=================
* Fix path construction for the case of cairo_curve_to immediately
  after cairo_new_sub_path followed at some point by
  cairo_close_path. (Previously, the final point for the close_path
  was computed incorrectly.)

* Fix for cairo_push_group or cairo_pop_group with a non-empty current
  path. (Previously the path may have been erroneously translated when
  either of these functions was called.)

* Fix to correctly report an error if
  cairo_surface_set_fallback_resolution is called with a value of 0
  (in either axis). Previously, an assertion would occur later rather
  than an error being properly reported when the original, invalid
  value was passed.

	Bug 23067: Using clear drawing operator crashes printing
	http://bugs.freedesktop.org/show_bug.cgi?id=23067

* Fix to handle a cairo_arc of radius 0 as equivalent to a
  cairo_line_to to the center coordinate, (previously cairo would do
  nothing for a cairo_arc call with a radius of 0).

Backend-specific bug fixes
==========================
cairo-xlib
----------
* Fix to correctly copy from a Window source. Previously, cairo was
  failing to include the contents of any sub-windows when copying from
  a Window source.

	Bug 12996: Xlib source surface fast-paths do not use
	IncludeInferiors, while slow paths do

	https://bugs.freedesktop.org/show_bug.cgi?id=12996

cairo-ft
--------
* Fix conversion of freetype index to UCS4 value, (which would
  previously miss the first character and cause the space glyph to map
  to 0x00A0 instead of 0x0020).

cairo-pdf
---------
* Fix Type 1 subsetting to avoid generating corrupt data.

	Launchpad Ubuntu/cups bug 419143: Printing from evince (and
	perhaps other GTK apps) to PostScript printers is broken

	https://bugs.launchpad.net/ubuntu/+source/cups/+bug/419143

* Fix Type 1 subsetting to correctly identify binary eexec data.

* Fix Type 1 subsetting to include fixed-content portion in the
  embedded font, (since some fonts may contain additional PostScript
  code after the cleartomark).

* Fix Type 1 subsetting to append "cleartomark" operator for binary
  fonts that don't include it.

Build fixes
===========
* Fix to compile on OpenBSD, (which has a libpng.pc file but none of
  libpng10.pc, libpng12.pc, or libpng13.pc which cairo was looking for
  previously).

# $NetBSD: Makefile,v 1.80 2010/02/21 13:02:46 wiz Exp $

DISTNAME=	cairo-1.8.10
CATEGORIES=	graphics
MASTER_SITES=	http://cairographics.org/releases/

MAINTAINER=	recht@NetBSD.org
HOMEPAGE=	http://cairographics.org/
COMMENT=	Vector graphics library with cross-device output support
LICENSE=	gnu-lgpl-v2.1 AND mpl-1.1

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES+=		c99
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		pkg-config
PKGCONFIG_OVERRIDE+=	src/cairo.pc.in src/cairo-features.pc.in
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--disable-xcb
CONFIGURE_ARGS+=	--enable-glitz
CONFIGURE_ARGS+=	--enable-pdf
CONFIGURE_ARGS+=	--enable-ps

PLIST_VARS+=		carbon
.if exists(/System/Library/Frameworks/Carbon.framework)
CONFIGURE_ARGS+=	--enable-quartz
CONFIGURE_ARGS+=	--enable-quartz-font
CONFIGURE_ARGS+=	--enable-quartz-image
PLIST.carbon=		yes
.endif

.include "options.mk"

# For snprintf() and ctime_r()
CPPFLAGS.SunOS+=		-D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS

TEST_TARGET=			check

.include "../../devel/zlib/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
BUILDLINK_API_DEPENDS.freetype2+=	freetype2>=2.1.9
.include "../../graphics/freetype2/buildlink3.mk"
BUILDLINK_API_DEPENDS.glitz+=	glitz>=0.5.1
.include "../../graphics/glitz/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
# include?
#.include "../../print/libspectre/buildlink3.mk"
BUILDLINK_API_DEPENDS.pixman+=	pixman>=0.12.0
.include "../../x11/pixman/buildlink3.mk"

.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"