[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / cairo

File: [cvs.NetBSD.org] / pkgsrc / graphics / cairo / Makefile (download)

Revision 1.32, Sun Apr 2 19:59:13 2006 UTC (18 years ago) by wiz
Branch: MAIN
Changes since 1.31: +3 -3 lines

Update to 1.0.4:

Release 1.0.4 (2006-03-15 Behdad Esfahbod)
==============================================================
This is a bug fix release.  Many fixes in this release are
backported from the head branch and do not have bug numbers.
For the bugs in bugzilla that are fixed in this release, see:

	https://bugs.freedesktop.org/buglist.cgi?bug_id=4674,4823,5528,5734,6176,6196,6197

This includes the bug causing Pango crashes with some corrupt
fonts.  For a list of all changes, see ChangeLog.

# $NetBSD: Makefile,v 1.32 2006/04/02 19:59:13 wiz Exp $

DISTNAME=	cairo-1.0.4
CATEGORIES=	graphics
MASTER_SITES=	http://cairographics.org/releases/

MAINTAINER=	recht@NetBSD.org
HOMEPAGE=	http://cairographics.org/
COMMENT=	Vector graphics library with cross-device output support

USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		pkg-config
PKGCONFIG_OVERRIDE+=	cairo.pc.in
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--disable-atsui
CONFIGURE_ARGS+=	--disable-xcb
CONFIGURE_ARGS+=	--enable-glitz
CONFIGURE_ARGS+=	--enable-pdf
CONFIGURE_ARGS+=	--enable-ps
CONFIGURE_ARGS+=	--with-html-dir=${PREFIX}/share/doc

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "Darwin" && exists(/System/Library/Frameworks/Quartz.framework)
CONFIGURE_ARGS+=	--enable-quartz
PLIST_SUBST+=		QUARTZ=
.else
PLIST_SUBST+=		QUARTZ="@comment "
.endif

BUILDLINK_DEPENDS.freetype2+=	freetype2>=2.1.5
BUILDLINK_DEPENDS.Xft2+=	Xft2>=2.1.2
BUILDLINK_DEPENDS.Xrender+=	Xrender>=0.8
BUILDLINK_DEPENDS.glitz+=	glitz>=0.4.4
BUILDLINK_DEPENDS.libpixman+=	libpixman>=0.1.5

.include "../../mk/compiler.mk"

.if !empty(PKGSRC_COMPILER:Mmipspro*)
CFLAGS+=			-c99
.endif

.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../fonts/Xft2/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/glitz/buildlink3.mk"
.include "../../graphics/libpixman/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../x11/Xrender/buildlink3.mk"
.include "../../mk/x11.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"