[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / cairo

File: [cvs.NetBSD.org] / pkgsrc / graphics / cairo / Attic / Makefile.common (download)

Revision 1.13, Sat Jan 6 11:30:56 2018 UTC (6 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.12: +2 -3 lines

cairo: updated to 1.14.12

Release 1.14.12:
Another bugfix release rolling up backported fixes for the past half year.

Features
--------
None

API Changes
-----------
None

Dependency Changes
------------------
None

Performance Optimizations
-------------------------
None

Bug Fixes
---------
* Fix assertion hit with PDFs using Type 4 fonts rendered with user
  fonts, due to error when destroying glyph page.
* Fix build error with util/font-view
* Fix handling of truetype fonts with excessively long font names
* Fix falling back to system font with PDFs using certain embedded
  fonts, due to truncated font names.
* Fix sigabrt printing documents with fonts lacking the mandatory .nodef
  glyph.
* Fix undefined-behavior with integer math.
* Fix various warnings and typos

# $NetBSD: Makefile.common,v 1.13 2018/01/06 11:30:56 adam Exp $
#
# used by graphics/cairo/Makefile
# used by graphics/cairo-gobject/Makefile

DISTNAME=	cairo-1.14.12
CATEGORIES=	graphics
MASTER_SITES=	http://cairographics.org/releases/
EXTRACT_SUFX=	.tar.xz

MAINTAINER?=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://cairographics.org/
COMMENT=	Vector graphics library with cross-device output support
LICENSE=	gnu-lgpl-v2.1 AND mpl-1.1

DISTINFO_FILE=	${.CURDIR}/../../graphics/cairo/distinfo
PATCHDIR=	${.CURDIR}/../../graphics/cairo/patches

USE_LANGUAGES=		c99
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		pkg-config
GNU_CONFIGURE=		yes
# does not build against NetBSD-5's MesaLib, and is according
# to upstream, only used by "toy applications"
CONFIGURE_ARGS+=	--disable-gl
CONFIGURE_ARGS+=	--enable-fc
CONFIGURE_ARGS+=	--enable-pdf
CONFIGURE_ARGS+=	--enable-ps
CONFIGURE_ARGS+=	--enable-tee

PKGCONFIG_OVERRIDE+=	src/cairo.pc.in
PKGCONFIG_OVERRIDE+=	src/cairo-features.pc.in

# For snprintf() and ctime_r()
CPPFLAGS.SunOS+=		-D__EXTENSIONS__ -D_POSIX_PTHREAD_SEMANTICS

# PR#43928
.include "../../mk/compiler.mk"
.if ${MACHINE_PLATFORM:MDragonFly-*-x86_64} && ${CC_VERSION:Mgcc-4.1.*}
CONFIGURE_ENV+=		ac_cv_type___uint128_t=no
.endif