[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / box2d

File: [cvs.NetBSD.org] / pkgsrc / graphics / box2d / PLIST (download)

Revision 1.1, Sat Feb 6 06:41:33 2021 UTC (3 years, 1 month ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, HEAD

graphics/box2d: import box2d-2.4.1

Box2D is a 2D physics engine for games.

Features:
Collision
    Continuous collision detection
    Contact callbacks: begin, end, pre-solve, post-solve
    Convex polygons and circles
    Multiple shapes per body
    One-shot contact manifolds
    Dynamic tree broadphase
    Efficient pair management
    Fast broadphase AABB queries
    Collision groups and categories

Physics
    Continuous physics with time of impact solver
    Persistent body-joint-contact graph
    Island solution and sleep management
    Contact, friction, and restitution
    Stable stacking with a linear-time solver
    Revolute, prismatic, distance, pulley, gear, mouse joint,
      and other joint types
    Joint limits, motors, and friction
    Momentum decoupled position correction
    Fairly accurate reaction forces/impulses

System
    Small block and stack allocators
    Centralized tuning parameters
    Highly portable C++ with no use of STL containers

@comment $NetBSD: PLIST,v 1.1 2021/02/06 06:41:33 ryoon Exp $
include/box2d/b2_api.h
include/box2d/b2_block_allocator.h
include/box2d/b2_body.h
include/box2d/b2_broad_phase.h
include/box2d/b2_chain_shape.h
include/box2d/b2_circle_shape.h
include/box2d/b2_collision.h
include/box2d/b2_common.h
include/box2d/b2_contact.h
include/box2d/b2_contact_manager.h
include/box2d/b2_distance.h
include/box2d/b2_distance_joint.h
include/box2d/b2_draw.h
include/box2d/b2_dynamic_tree.h
include/box2d/b2_edge_shape.h
include/box2d/b2_fixture.h
include/box2d/b2_friction_joint.h
include/box2d/b2_gear_joint.h
include/box2d/b2_growable_stack.h
include/box2d/b2_joint.h
include/box2d/b2_math.h
include/box2d/b2_motor_joint.h
include/box2d/b2_mouse_joint.h
include/box2d/b2_polygon_shape.h
include/box2d/b2_prismatic_joint.h
include/box2d/b2_pulley_joint.h
include/box2d/b2_revolute_joint.h
include/box2d/b2_rope.h
include/box2d/b2_settings.h
include/box2d/b2_shape.h
include/box2d/b2_stack_allocator.h
include/box2d/b2_time_of_impact.h
include/box2d/b2_time_step.h
include/box2d/b2_timer.h
include/box2d/b2_types.h
include/box2d/b2_weld_joint.h
include/box2d/b2_wheel_joint.h
include/box2d/b2_world.h
include/box2d/b2_world_callbacks.h
include/box2d/box2d.h
lib/cmake/box2d/box2dConfig-noconfig.cmake
lib/cmake/box2d/box2dConfig.cmake
lib/cmake/box2d/box2dConfigVersion.cmake
lib/libbox2d.so
lib/libbox2d.so.2
lib/libbox2d.so.${PKGVERSION}