[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / box2d

File: [cvs.NetBSD.org] / pkgsrc / graphics / box2d / Makefile (download)

Revision 1.1, Sat Feb 6 06:41:33 2021 UTC (3 years, 1 month ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1

graphics/box2d: import box2d-2.4.1

Box2D is a 2D physics engine for games.

Features:
Collision
    Continuous collision detection
    Contact callbacks: begin, end, pre-solve, post-solve
    Convex polygons and circles
    Multiple shapes per body
    One-shot contact manifolds
    Dynamic tree broadphase
    Efficient pair management
    Fast broadphase AABB queries
    Collision groups and categories

Physics
    Continuous physics with time of impact solver
    Persistent body-joint-contact graph
    Island solution and sleep management
    Contact, friction, and restitution
    Stable stacking with a linear-time solver
    Revolute, prismatic, distance, pulley, gear, mouse joint,
      and other joint types
    Joint limits, motors, and friction
    Momentum decoupled position correction
    Fairly accurate reaction forces/impulses

System
    Small block and stack allocators
    Centralized tuning parameters
    Highly portable C++ with no use of STL containers

# $NetBSD: Makefile,v 1.1 2021/02/06 06:41:33 ryoon Exp $

GITHUB_PROJECT=	box2d
GITHUB_TAG=	v${PKGVERSION_NOREV}
DISTNAME=	box2d-2.4.1
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_GITHUB:=erincatto/}

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	https://github.com/erincatto/box2d/
COMMENT=	2D physics engine for games
LICENSE=	mit

USE_CMAKE=	yes
USE_LANGUAGES=	c c++

CMAKE_ARGS+=	-DBOX2D_BUILD_TESTBED=OFF
CMAKE_ARGS+=	-DBUILD_SHARED_LIBS=ON

.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXcursor/buildlink3.mk"
.include "../../x11/libXi/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXrandr/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"