[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / blender

File: [cvs.NetBSD.org] / pkgsrc / graphics / blender / Makefile (download)

Revision 1.12, Sun Jul 14 22:50:33 2002 UTC (21 years, 9 months ago) by rh
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews
Changes since 1.11: +3 -3 lines

Add i386 platform.  Bump PKGREVISION.  This closes PR pkg/17598 by
Julio Merino <jmmv@hispabsd.org>

# $NetBSD: Makefile,v 1.12 2002/07/14 22:50:33 rh Exp $

PKGNAME=	blender-2.11
PKGREVISION=	5
CATEGORIES=	graphics
MASTER_SITES=	ftp://www.blender.nl/pub/

MAINTAINER=	manu@netbsd.org
HOMEPAGE=	http://www.blender.nl
COMMENT=	GUI based raytracer

RESTRICTED=	"Only the original, unmodified package may be freely distributed"
NO_BIN_ON_FTP=	${RESTRICTED}
NO_BIN_ON_CDROM=${RESTRICTED}

NO_BUILD=	yes
CHECK_SHLIBS=	NO

# To be updated as other platforms PLIST will be built
ONLY_FOR_PLATFORM= *-*-i386 *-*-powerpc

.if (${MACHINE_ARCH} == "alpha")
.if !exists(/emul/linux/lib/ld.so.1)
IGNORE=		"${PKGNAME} requires Linux libraries - see compat_linux(8)"
.endif
DISTNAME=	blender2.11-linux-glibc2.1.3-alpha
#
.elif (${MACHINE_ARCH} == "i386")
DEPENDS+=	suse_linux>=6.4:../../emulators/${SUSE_DIR_PREFIX}_linux
DISTNAME=	blender2.11-linux-glibc2.1.2-i386-static
PLIST_ARCH=	linux-i386
#
.elif (${MACHINE_ARCH} == "sparc")
.if !exists(/emul/sunos/usr/lib/ld.so)
IGNORE=		"${PKGNAME} requires SunOS libraries - see compat_sunos(8)"
.endif
DISTNAME=	blender2.11-solaris-2.6-sparc
EXTRACT_SUFX=	.tar.Z
#
.elif (${MACHINE_ARCH} == "powerpc")
.if !exists(/emul/linux/lib/ld.so.1)
IGNORE=		"${PKGNAME} requires Linux libraries - see compat_linux(8)"
.endif
DEPENDS+=	linuxppc_lib>=2000.4.2:../../emulators/linuxppc_lib
DISTNAME=	blender2.11-linux-glibc2.1.3-powerpc-static
PLIST_ARCH=	linux-powerpc
#
.else
DISTNAME=	# dummy, don't break pkg system
IGNORE=		"Your platform is not supported and the package is buggy!"
.endif

PLIST_SRC=	${PKGDIR}/PLIST.${PLIST_ARCH}

do-install:
	${INSTALL_DATA_DIR} ${PREFIX}/lib/blender
	${CP} -Rp ${WRKSRC}/* ${PREFIX}/lib/blender/
	${LN} -sf ../lib/blender/blender ${PREFIX}/bin/blender

.include "../../emulators/suse_linux/Makefile.application"