[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / blender

Annotation of pkgsrc/graphics/blender/Makefile, Revision 1.5

1.5     ! agc         1: # $NetBSD: Makefile,v 1.4 2001/04/08 16:28:02 manu Exp $
1.1       manu        2: #
                      3:
1.4       manu        4: PKGNAME=       blender-2.11.nb2
1.1       manu        5: CATEGORIES=    graphics
                      6: MASTER_SITES=  ftp://www.blender.nl/pub/
                      7:
                      8: MAINTAINER=    manu@netbsd.org
                      9: HOMEPAGE=      http://www.blender.nl
1.2       wiz        10: COMMENT=       GUI based raytracer
1.1       manu       11:
                     12: RESTRICTED=    "Only the original, unmodified package may be freely distributed"
                     13: NO_BIN_ON_FTP= ${RESTRICTED}
                     14: NO_BIN_ON_CDROM=${RESTRICTED}
                     15:
                     16: NO_BUILD=      yes
                     17:
                     18: # To be updated as other platforms PLIST will be built
                     19: ONLY_FOR_PLATFORM= *-*-powerpc
                     20:
                     21: .if (${MACHINE_ARCH} == "alpha")
                     22: .if !exists(/emul/linux/lib/ld.so.1)
1.2       wiz        23: IGNORE=                "${PKGNAME} requires Linux libraries - see compat_linux(8)"
1.1       manu       24: .endif
1.5     ! agc        25: DISTNAME=      blender2.11-linux-glibc2.1.3-alpha
1.1       manu       26: #
                     27: .elif (${MACHINE_ARCH} == "i386")
1.2       wiz        28: DEPENDS+=      suse_linux>=6.4:../../emulators/suse_linux
1.1       manu       29: DISTNAME=      blender2.11-linux-glibc2.1.2-i386-static
1.3       manu       30: PLIST_ARCH=    linux-i386
1.1       manu       31: #
                     32: .elif (${MACHINE_ARCH} == "sparc")
                     33: .if !exists(/emul/sunos/usr/lib/ld.so)
1.2       wiz        34: IGNORE=                "${PKGNAME} requires SunOS libraries - see compat_sunos(8)"
1.1       manu       35: .endif
1.2       wiz        36: DISTNAME=      blender2.11-solaris-2.6-sparc
1.1       manu       37: EXTRACT_SUFX=  .tar.Z
                     38: #
                     39: .elif (${MACHINE_ARCH} == "powerpc")
                     40: .if !exists(/emul/linux/lib/ld.so.1)
1.2       wiz        41: IGNORE=                "${PKGNAME} requires Linux libraries - see compat_linux(8)"
1.1       manu       42: .endif
1.2       wiz        43: DEPENDS+=      linuxppc_lib>=2000.q4.2:../../emulators/linuxppc_lib
1.1       manu       44: DISTNAME=      blender2.11-linux-glibc2.1.3-powerpc-static
                     45: PLIST_ARCH=    linux-powerpc
                     46: #
                     47: .else
1.2       wiz        48: IGNORE=                "Your platform is not supported and the package is buggy!"
1.1       manu       49: .endif
                     50:
                     51: PLIST_SRC=     ${PKGDIR}/PLIST.${PLIST_ARCH}
                     52:
                     53: do-install:
1.2       wiz        54:        ${INSTALL_DATA_DIR} ${PREFIX}/lib/blender
1.1       manu       55:        ${CP} -Rp ${WRKSRC}/* ${PREFIX}/lib/blender/
1.3       manu       56:        ${LN} -sf ../lib/blender/blender ${PREFIX}/bin/blender
1.1       manu       57:
                     58: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>