[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / blender

Annotation of pkgsrc/graphics/blender/Makefile, Revision 1.11

1.11    ! tron        1: # $NetBSD: Makefile,v 1.10 2001/11/29 01:12:34 hubertf Exp $
1.1       manu        2:
1.10      hubertf     3: PKGNAME=       blender-2.11
                      4: PKGREVISION=   4
1.1       manu        5: CATEGORIES=    graphics
                      6: MASTER_SITES=  ftp://www.blender.nl/pub/
                      7:
                      8: MAINTAINER=    manu@netbsd.org
                      9: HOMEPAGE=      http://www.blender.nl
1.2       wiz        10: COMMENT=       GUI based raytracer
1.1       manu       11:
                     12: RESTRICTED=    "Only the original, unmodified package may be freely distributed"
                     13: NO_BIN_ON_FTP= ${RESTRICTED}
                     14: NO_BIN_ON_CDROM=${RESTRICTED}
                     15:
                     16: NO_BUILD=      yes
1.7       manu       17: CHECK_SHLIBS=  NO
1.1       manu       18:
                     19: # To be updated as other platforms PLIST will be built
                     20: ONLY_FOR_PLATFORM= *-*-powerpc
                     21:
                     22: .if (${MACHINE_ARCH} == "alpha")
                     23: .if !exists(/emul/linux/lib/ld.so.1)
1.2       wiz        24: IGNORE=                "${PKGNAME} requires Linux libraries - see compat_linux(8)"
1.1       manu       25: .endif
1.5       agc        26: DISTNAME=      blender2.11-linux-glibc2.1.3-alpha
1.1       manu       27: #
                     28: .elif (${MACHINE_ARCH} == "i386")
1.11    ! tron       29: DEPENDS+=      suse_linux>=6.4:../../emulators/${SUSE_DIR_PREFIX}_linux
1.1       manu       30: DISTNAME=      blender2.11-linux-glibc2.1.2-i386-static
1.3       manu       31: PLIST_ARCH=    linux-i386
1.1       manu       32: #
                     33: .elif (${MACHINE_ARCH} == "sparc")
                     34: .if !exists(/emul/sunos/usr/lib/ld.so)
1.2       wiz        35: IGNORE=                "${PKGNAME} requires SunOS libraries - see compat_sunos(8)"
1.1       manu       36: .endif
1.2       wiz        37: DISTNAME=      blender2.11-solaris-2.6-sparc
1.1       manu       38: EXTRACT_SUFX=  .tar.Z
                     39: #
                     40: .elif (${MACHINE_ARCH} == "powerpc")
                     41: .if !exists(/emul/linux/lib/ld.so.1)
1.2       wiz        42: IGNORE=                "${PKGNAME} requires Linux libraries - see compat_linux(8)"
1.1       manu       43: .endif
1.6       wiz        44: DEPENDS+=      linuxppc_lib>=2000.4.2:../../emulators/linuxppc_lib
1.1       manu       45: DISTNAME=      blender2.11-linux-glibc2.1.3-powerpc-static
                     46: PLIST_ARCH=    linux-powerpc
                     47: #
                     48: .else
1.8       pooka      49: DISTNAME=      # dummy, don't break pkg system
1.2       wiz        50: IGNORE=                "Your platform is not supported and the package is buggy!"
1.1       manu       51: .endif
                     52:
                     53: PLIST_SRC=     ${PKGDIR}/PLIST.${PLIST_ARCH}
                     54:
                     55: do-install:
1.2       wiz        56:        ${INSTALL_DATA_DIR} ${PREFIX}/lib/blender
1.1       manu       57:        ${CP} -Rp ${WRKSRC}/* ${PREFIX}/lib/blender/
1.3       manu       58:        ${LN} -sf ../lib/blender/blender ${PREFIX}/bin/blender
1.1       manu       59:
1.11    ! tron       60: .include "../../emulators/suse_linux/Makefile.application"

CVSweb <webmaster@jp.NetBSD.org>