[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / aqsis

Annotation of pkgsrc/graphics/aqsis/Makefile, Revision 1.51

1.51    ! tron        1: # $NetBSD: Makefile,v 1.50 2013/06/03 10:05:07 wiz Exp $
1.1       agc         2: #
                      3:
1.37      dholland    4: DISTNAME=              aqsis-1.8.1
1.51    ! tron        5: PKGREVISION=           13
1.1       agc         6: CATEGORIES=            graphics
                      7: MASTER_SITES=          ${MASTER_SITE_SOURCEFORGE:=aqsis/}
                      8:
1.24      jlam        9: MAINTAINER=            pkgsrc-users@NetBSD.org
1.35      zafer      10: HOMEPAGE=              http://www.aqsis.org/
1.1       agc        11: COMMENT=               Renderman clone
1.37      dholland   12: LICENSE=               gnu-gpl-v2 AND gnu-lgpl-v2.1 AND modified-bsd
1.1       agc        13:
1.37      dholland   14: USE_CMAKE=             yes
                     15: USE_LANGUAGES=         c c++
                     16: USE_TOOLS+=            pkg-config flex bison
                     17:
                     18: #
                     19: # Insists on being built in a separate directory.
                     20: #
                     21:
                     22: CONFIGURE_DIRS=                build
                     23: CMAKE_ARG_PATH=                ..
                     24:
                     25: pre-configure:
                     26:        mkdir ${WRKSRC}/build
                     27:
                     28: #
                     29: # Something in cmake issues -ldl regardless of whether it's appropriate.
                     30: # Kludge around it.
                     31: #
1.1       agc        32:
1.37      dholland   33: # This does not work; it sets CMAKE_DL_LIBS which the cmake documentation
                     34: # says is where -ldl comes from, but this does not apparently prevent
                     35: # cmake from issuing -ldl.
                     36: #CMAKE_ARGS+=          -D CMAKE_DL_LIBS:STRING='${DL_LIBS}'
                     37:
                     38: .include "../../mk/bsd.prefs.mk"
                     39: .if ${OPSYS} == "NetBSD"
                     40: BUILDLINK_TRANSFORM+=  rm:-ldl
                     41: .endif
                     42:
                     43: #
                     44: # Forcibly reprogram cmake's rpath substitution.
                     45: #
                     46:
                     47: BLDIR=         ${WRKDIR}/.buildlink/lib
                     48:
                     49: SUBST_CLASSES+=                rpath
                     50: SUBST_STAGE.rpath=     post-configure
                     51: SUBST_FILES.rpath+=    build/libs/math/cmake_install.cmake
                     52: SUBST_FILES.rpath+=    build/libs/util/cmake_install.cmake
                     53: SUBST_FILES.rpath+=    build/libs/riutil/cmake_install.cmake
                     54: SUBST_FILES.rpath+=    build/libs/slcomp/cmake_install.cmake
                     55: SUBST_FILES.rpath+=    build/libs/tex/cmake_install.cmake
                     56: SUBST_FILES.rpath+=    build/libs/shadervm/cmake_install.cmake
                     57: SUBST_FILES.rpath+=    build/libs/slxargs/cmake_install.cmake
                     58: SUBST_FILES.rpath+=    build/libs/ri2rib/cmake_install.cmake
                     59: SUBST_FILES.rpath+=    build/libs/core/cmake_install.cmake
                     60: SUBST_FILES.rpath+=    build/tools/aqsl/cmake_install.cmake
                     61: SUBST_FILES.rpath+=    build/tools/aqsltell/cmake_install.cmake
                     62: SUBST_FILES.rpath+=    build/tools/aqsis/cmake_install.cmake
                     63: SUBST_FILES.rpath+=    build/tools/miqser/cmake_install.cmake
                     64: SUBST_FILES.rpath+=    build/tools/teqser/cmake_install.cmake
                     65: SUBST_FILES.rpath+=    build/tools/displays/exr/cmake_install.cmake
                     66: SUBST_FILES.rpath+=    build/tools/displays/file/cmake_install.cmake
                     67: SUBST_FILES.rpath+=    build/tools/displays/piqsl/cmake_install.cmake
                     68: SUBST_FILES.rpath+=    build/tools/displays/sdcBMP/cmake_install.cmake
                     69: SUBST_FILES.rpath+=    build/tools/displays/xpm/cmake_install.cmake
                     70: SUBST_FILES.rpath+=    build/tools/procedurals/hairgen/cmake_install.cmake
                     71: SUBST_SED.rpath=       -e '/OLD_RPATH/s,"::*","${PREFIX}/lib",'
                     72: SUBST_SED.rpath+=      -e '/OLD_RPATH/s,${BLDIR},${PREFIX}/lib,'
                     73: SUBST_SED.rpath+=      -e '/OLD_RPATH/s,:",",'
                     74: SUBST_SED.rpath+=      -e '/NEW_RPATH/s,"${PREFIX}/.*","${PREFIX}/lib",'
                     75: SUBST_MESSAGE.rpath=   Fixing broken rpath mangling.
                     76:
                     77: #
                     78: # Scripts.
                     79: #
                     80:
                     81: REPLACE_PYTHON+=       examples/features/occlusion/occlmap.py
                     82:
                     83: # This script wants to run something called 'hython', which is
                     84: # apparently a Python embedding inside something called Houdini,
                     85: # which appears to be payware. So let's let it slide.
                     86: CHECK_INTERPRETER_SKIP+=       share/aqsis/plugins/houdini/slx2otl.py
                     87:
                     88: # These are all ostensibly bash scripts but I see no bashisms in any of them.
                     89: REPLACE_SH+=   examples/features/archives/render.sh
                     90: REPLACE_SH+=   examples/features/bake/render.sh
                     91: REPLACE_SH+=   examples/features/curves/render.sh
                     92: REPLACE_SH+=   examples/features/layeredshaders/render.sh
                     93: REPLACE_SH+=   examples/features/levelofdetail/render.sh
                     94: REPLACE_SH+=   examples/features/motionblur/render_camera.sh
                     95: REPLACE_SH+=   examples/features/motionblur/render_deformation.sh
                     96: REPLACE_SH+=   examples/features/multipass/render.sh
                     97: REPLACE_SH+=   examples/features/objectinstance/render.sh
                     98: REPLACE_SH+=   examples/features/occlusion/render.sh
                     99: REPLACE_SH+=   examples/features/pointcloud/render.sh
                    100: REPLACE_SH+=   examples/features/shadows/render_autoshadow.sh
                    101: REPLACE_SH+=   examples/features/shadows/render_softshadow.sh
                    102: REPLACE_SH+=   examples/features/solidmodeling/render.sh
                    103: REPLACE_SH+=   examples/features/subdivision/render.sh
                    104: REPLACE_SH+=   examples/features/textures/render.sh
                    105: REPLACE_SH+=   examples/procedurals/menger/render.sh
                    106: REPLACE_SH+=   examples/scenes/fisheye/render.sh
                    107: REPLACE_SH+=   examples/scenes/microbe/render.sh
                    108: REPLACE_SH+=   examples/scenes/vase/render.sh
                    109: REPLACE_SH+=   tools/neqsus/houdini/post.sh
                    110: REPLACE_SH+=   distribution/linux/aqsis.sh
                    111: REPLACE_SH+=   distribution/linux/aqsl.sh
                    112: REPLACE_SH+=   distribution/linux/aqsltell.sh
                    113:
                    114: #
                    115: # Handle the config file.
                    116: #
                    117: # XXX the post-install rule will result in an overwritten config file
                    118: # if using a non-DESTDIR build. However, I can't get it to install the
                    119: # thing anywhere else; the setting cmake documents that ought to move
                    120: # it does not work.
                    121: #
                    122:
                    123: PKG_SYSCONFSUBDIR=     aqsis
                    124: CONF_FILES+=           share/examples/aqsis/aqsisrc ${PKG_SYSCONFDIR}/aqsisrc
                    125: INSTALLATION_DIRS+=    share/examples/aqsis
                    126:
                    127: post-install:
                    128:        mv ${DESTDIR}${PREFIX}/etc/aqsis/aqsisrc \
                    129:                ${DESTDIR}${PREFIX}/share/examples/aqsis/aqsisrc
                    130:        rmdir ${DESTDIR}${PREFIX}/etc/aqsis || ${TRUE}
                    131:        rmdir ${DESTDIR}${PREFIX}/etc || ${TRUE}
                    132:
                    133: #
                    134: # Depends. The package says:
                    135: #
                    136: # CMake (v2.6.3+)
                    137: # Boost (v1.34.1+)
                    138: # libtiff.lib (v3.7.1+)
                    139: # flex (v2.5.4) (2.5.31 causes problems, see FAQ 2.2)
                    140: # bison (v1.35+)
                    141: # Qt (v4.6+) - optional, for framebuffer rendering and other GUI components
                    142: # libzlib (v1.1.4+)
                    143: # libjpeg (v6b+)
                    144: # libilmbase (v1.6+)
                    145: # OpenEXR - if you want to read and write OpenEXR HDR image files
                    146: #
                    147: # and in practice it also needs png.
                    148: #
                    149: # Qt is optional and, for the time being, doesn't work - will need at
                    150: # least PLIST additions.
                    151: #
                    152: # From what I can tell it may react to py-sphinx and/or doxygen by
                    153: # installing more docs or other material. Not sure how to beat on
                    154: # cmake to make sure this doesn't happen.
                    155: #
                    156:
                    157: .include "options.mk"
1.1       agc       158:
1.37      dholland  159: .include "../../devel/boost-libs/buildlink3.mk"
                    160: .include "../../graphics/png/buildlink3.mk"
1.14      snj       161: .include "../../graphics/tiff/buildlink3.mk"
1.37      dholland  162: .include "../../graphics/ilmbase/buildlink3.mk"
                    163: .include "../../graphics/openexr/buildlink3.mk"
                    164: .include "../../devel/zlib/buildlink3.mk"
                    165: .include "../../mk/jpeg.buildlink3.mk"
1.25      joerg     166: .include "../../mk/dlopen.buildlink3.mk"
1.37      dholland  167: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                    168: .include "../../lang/python/application.mk"
1.1       agc       169: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>