[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / aqsis

Annotation of pkgsrc/graphics/aqsis/Makefile, Revision 1.83

1.83    ! joerg       1: # $NetBSD: Makefile,v 1.82 2020/03/08 16:49:52 wiz Exp $
1.1       agc         2: #
                      3:
1.37      dholland    4: DISTNAME=              aqsis-1.8.1
1.82      wiz         5: PKGREVISION=           40
1.1       agc         6: CATEGORIES=            graphics
                      7: MASTER_SITES=          ${MASTER_SITE_SOURCEFORGE:=aqsis/}
                      8:
1.24      jlam        9: MAINTAINER=            pkgsrc-users@NetBSD.org
1.81      rillig     10: HOMEPAGE=              https://www.aqsis.org/
1.1       agc        11: COMMENT=               Renderman clone
1.37      dholland   12: LICENSE=               gnu-gpl-v2 AND gnu-lgpl-v2.1 AND modified-bsd
1.1       agc        13:
1.37      dholland   14: USE_CMAKE=             yes
                     15: USE_LANGUAGES=         c c++
                     16: USE_TOOLS+=            pkg-config flex bison
                     17:
1.83    ! joerg      18: BROKEN=                        Not valid C++11 code, but dependencies require C++11
        !            19:
1.64      wiedi      20: LDFLAGS.SunOS=         -lsocket -lnsl
1.55      dholland   21:
1.37      dholland   22: #
                     23: # Insists on being built in a separate directory.
                     24: #
                     25:
                     26: CONFIGURE_DIRS=                build
                     27: CMAKE_ARG_PATH=                ..
                     28:
                     29: pre-configure:
                     30:        mkdir ${WRKSRC}/build
                     31:
                     32: #
                     33: # Something in cmake issues -ldl regardless of whether it's appropriate.
                     34: # Kludge around it.
                     35: #
1.1       agc        36:
1.37      dholland   37: # This does not work; it sets CMAKE_DL_LIBS which the cmake documentation
                     38: # says is where -ldl comes from, but this does not apparently prevent
                     39: # cmake from issuing -ldl.
                     40: #CMAKE_ARGS+=          -D CMAKE_DL_LIBS:STRING='${DL_LIBS}'
                     41:
1.65      jperkin    42: BUILDLINK_TRANSFORM.NetBSD+=   rm:-ldl
1.37      dholland   43:
                     44: #
                     45: # Forcibly reprogram cmake's rpath substitution.
                     46: #
                     47:
                     48: BLDIR=         ${WRKDIR}/.buildlink/lib
                     49:
                     50: SUBST_CLASSES+=                rpath
                     51: SUBST_STAGE.rpath=     post-configure
                     52: SUBST_FILES.rpath+=    build/libs/math/cmake_install.cmake
                     53: SUBST_FILES.rpath+=    build/libs/util/cmake_install.cmake
                     54: SUBST_FILES.rpath+=    build/libs/riutil/cmake_install.cmake
                     55: SUBST_FILES.rpath+=    build/libs/slcomp/cmake_install.cmake
                     56: SUBST_FILES.rpath+=    build/libs/tex/cmake_install.cmake
                     57: SUBST_FILES.rpath+=    build/libs/shadervm/cmake_install.cmake
                     58: SUBST_FILES.rpath+=    build/libs/slxargs/cmake_install.cmake
                     59: SUBST_FILES.rpath+=    build/libs/ri2rib/cmake_install.cmake
                     60: SUBST_FILES.rpath+=    build/libs/core/cmake_install.cmake
                     61: SUBST_FILES.rpath+=    build/tools/aqsl/cmake_install.cmake
                     62: SUBST_FILES.rpath+=    build/tools/aqsltell/cmake_install.cmake
                     63: SUBST_FILES.rpath+=    build/tools/aqsis/cmake_install.cmake
                     64: SUBST_FILES.rpath+=    build/tools/miqser/cmake_install.cmake
                     65: SUBST_FILES.rpath+=    build/tools/teqser/cmake_install.cmake
                     66: SUBST_FILES.rpath+=    build/tools/displays/exr/cmake_install.cmake
                     67: SUBST_FILES.rpath+=    build/tools/displays/file/cmake_install.cmake
                     68: SUBST_FILES.rpath+=    build/tools/displays/piqsl/cmake_install.cmake
                     69: SUBST_FILES.rpath+=    build/tools/displays/sdcBMP/cmake_install.cmake
                     70: SUBST_FILES.rpath+=    build/tools/displays/xpm/cmake_install.cmake
                     71: SUBST_FILES.rpath+=    build/tools/procedurals/hairgen/cmake_install.cmake
                     72: SUBST_SED.rpath=       -e '/OLD_RPATH/s,"::*","${PREFIX}/lib",'
                     73: SUBST_SED.rpath+=      -e '/OLD_RPATH/s,${BLDIR},${PREFIX}/lib,'
                     74: SUBST_SED.rpath+=      -e '/OLD_RPATH/s,:",",'
                     75: SUBST_SED.rpath+=      -e '/NEW_RPATH/s,"${PREFIX}/.*","${PREFIX}/lib",'
                     76: SUBST_MESSAGE.rpath=   Fixing broken rpath mangling.
                     77:
                     78: #
                     79: # Scripts.
                     80: #
                     81:
                     82: REPLACE_PYTHON+=       examples/features/occlusion/occlmap.py
                     83:
                     84: # This script wants to run something called 'hython', which is
                     85: # apparently a Python embedding inside something called Houdini,
                     86: # which appears to be payware. So let's let it slide.
                     87: CHECK_INTERPRETER_SKIP+=       share/aqsis/plugins/houdini/slx2otl.py
                     88:
                     89: # These are all ostensibly bash scripts but I see no bashisms in any of them.
                     90: REPLACE_SH+=   examples/features/archives/render.sh
                     91: REPLACE_SH+=   examples/features/bake/render.sh
                     92: REPLACE_SH+=   examples/features/curves/render.sh
                     93: REPLACE_SH+=   examples/features/layeredshaders/render.sh
                     94: REPLACE_SH+=   examples/features/levelofdetail/render.sh
                     95: REPLACE_SH+=   examples/features/motionblur/render_camera.sh
                     96: REPLACE_SH+=   examples/features/motionblur/render_deformation.sh
                     97: REPLACE_SH+=   examples/features/multipass/render.sh
                     98: REPLACE_SH+=   examples/features/objectinstance/render.sh
                     99: REPLACE_SH+=   examples/features/occlusion/render.sh
                    100: REPLACE_SH+=   examples/features/pointcloud/render.sh
                    101: REPLACE_SH+=   examples/features/shadows/render_autoshadow.sh
                    102: REPLACE_SH+=   examples/features/shadows/render_softshadow.sh
                    103: REPLACE_SH+=   examples/features/solidmodeling/render.sh
                    104: REPLACE_SH+=   examples/features/subdivision/render.sh
                    105: REPLACE_SH+=   examples/features/textures/render.sh
                    106: REPLACE_SH+=   examples/procedurals/menger/render.sh
                    107: REPLACE_SH+=   examples/scenes/fisheye/render.sh
                    108: REPLACE_SH+=   examples/scenes/microbe/render.sh
                    109: REPLACE_SH+=   examples/scenes/vase/render.sh
                    110: REPLACE_SH+=   tools/neqsus/houdini/post.sh
                    111: REPLACE_SH+=   distribution/linux/aqsis.sh
                    112: REPLACE_SH+=   distribution/linux/aqsl.sh
                    113: REPLACE_SH+=   distribution/linux/aqsltell.sh
                    114:
                    115: #
                    116: # Handle the config file.
                    117: #
                    118: # XXX the post-install rule will result in an overwritten config file
                    119: # if using a non-DESTDIR build. However, I can't get it to install the
                    120: # thing anywhere else; the setting cmake documents that ought to move
                    121: # it does not work.
                    122: #
                    123:
                    124: PKG_SYSCONFSUBDIR=     aqsis
                    125: CONF_FILES+=           share/examples/aqsis/aqsisrc ${PKG_SYSCONFDIR}/aqsisrc
                    126: INSTALLATION_DIRS+=    share/examples/aqsis
                    127:
                    128: post-install:
                    129:        mv ${DESTDIR}${PREFIX}/etc/aqsis/aqsisrc \
                    130:                ${DESTDIR}${PREFIX}/share/examples/aqsis/aqsisrc
                    131:        rmdir ${DESTDIR}${PREFIX}/etc/aqsis || ${TRUE}
                    132:        rmdir ${DESTDIR}${PREFIX}/etc || ${TRUE}
                    133:
                    134: #
                    135: # Depends. The package says:
                    136: #
                    137: # CMake (v2.6.3+)
                    138: # Boost (v1.34.1+)
                    139: # libtiff.lib (v3.7.1+)
                    140: # flex (v2.5.4) (2.5.31 causes problems, see FAQ 2.2)
                    141: # bison (v1.35+)
                    142: # Qt (v4.6+) - optional, for framebuffer rendering and other GUI components
                    143: # libzlib (v1.1.4+)
                    144: # libjpeg (v6b+)
                    145: # libilmbase (v1.6+)
                    146: # OpenEXR - if you want to read and write OpenEXR HDR image files
                    147: #
                    148: # and in practice it also needs png.
                    149: #
                    150: # Qt is optional and, for the time being, doesn't work - will need at
                    151: # least PLIST additions.
                    152: #
                    153: # From what I can tell it may react to py-sphinx and/or doxygen by
                    154: # installing more docs or other material. Not sure how to beat on
                    155: # cmake to make sure this doesn't happen.
                    156: #
                    157:
                    158: .include "options.mk"
1.1       agc       159:
1.37      dholland  160: .include "../../devel/boost-libs/buildlink3.mk"
                    161: .include "../../graphics/png/buildlink3.mk"
1.14      snj       162: .include "../../graphics/tiff/buildlink3.mk"
1.37      dholland  163: .include "../../graphics/ilmbase/buildlink3.mk"
                    164: .include "../../graphics/openexr/buildlink3.mk"
                    165: .include "../../devel/zlib/buildlink3.mk"
                    166: .include "../../mk/jpeg.buildlink3.mk"
1.25      joerg     167: .include "../../mk/dlopen.buildlink3.mk"
1.37      dholland  168: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                    169: .include "../../lang/python/application.mk"
1.1       agc       170: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>