[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / R-ggplot2

File: [cvs.NetBSD.org] / pkgsrc / graphics / R-ggplot2 / Makefile (download)

Revision 1.5, Sun Jun 6 14:56:14 2021 UTC (2 years, 10 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.4: +13 -2 lines

(graphics/R-ggplot2) Updated 3.2.0 to 3.3.0

# ggplot2 3.3.3
This is a small patch release mainly intended to address changes in R and CRAN.
It further changes the licensing model of ggplot2 to an MIT license.

* Update the ggplot2 licence to an MIT license (#4231, #4232, #4233, and #4281)
* Use vdiffr conditionally so ggplot2 can be tested on systems without vdiffr
* Update tests to work with the new `all.equal()` defaults in R >4.0.3

# ggplot2 3.3.2
This is a small release focusing on fixing regressions introduced in 3.3.1.

* Added an `outside` option to `annotation_logticks()` that places tick marks
  outside of the plot bounds. (#3783, @kbodwin)

* `annotation_raster()` adds support for native rasters. For large rasters,
  native rasters render significantly faster than arrays (@kent37, #3388)

* Facet strips now have dedicated position-dependent theme elements
  (`strip.text.x.top`, `strip.text.x.bottom`, `strip.text.y.left`,
  `strip.text.y.right`) that inherit from `strip.text.x` and `strip.text.y`,
  respectively. As a consequence, some theme stylings now need to be applied to
  the position-dependent elements rather than to the parent elements. This
  change was already introduced in ggplot2 3.3.0 but not listed in the
  changelog. (@thomasp85, #3683)

* Facets now handle layers containing no data (@yutannihilation, #3853).

* A newly added geom `geom_density_2d_filled()` and associated stat
  `stat_density_2d_filled()` can draw filled density contours
  (@clauswilke, #3846).

* A newly added `geom_function()` is now recommended to use in conjunction
  with/instead of `stat_function()`. In addition, `stat_function()` now
  works with transformed y axes, e.g. `scale_y_log10()`, and in plots
  containing no other data or layers (@clauswilke, #3611, #3905, #3983).

* Fixed a bug in `geom_sf()` that caused problems with legend-type
  autodetection (@clauswilke, #3963).

* Support graphics devices that use the `file` argument instead of `fileneame`
  in `ggsave()` (@bwiernik, #3810)

* Default discrete color scales are now configurable through the `options()` of
  `ggplot2.discrete.colour` and `ggplot2.discrete.fill`. When set to a character
  vector of colour codes (or list of character vectors)  with sufficient length,
  these colours are used for the default scale. See `help(scale_colour_discrete)`
  for more details and examples (@cpsievert, #3833).

* Default continuous colour scales (i.e., the `options()`
  `ggplot2.continuous.colour` and `ggplot2.continuous.fill`, which inform the
  `type` argument of `scale_fill_continuous()` and `scale_colour_continuous()`)
  now accept a function, which allows more control over these default
  `continuous_scale()`s (@cpsievert, #3827).

* A bug was fixed in `stat_contour()` when calculating breaks based on
  the `bins` argument (@clauswilke, #3879, #4004).

* Data columns can now contain `Vector` S4 objects, which are widely used in the
  Bioconductor project. (@teunbrand, #3837)

# ggplot2 3.3.1

This is a small release with no code change. It removes all malicious links to a
site that got hijacked from the readme and pkgdown site.

# ggplot2 3.3.0

This is a minor release but does contain a range of substantial new features,
along with the standard bug fixes. The release contains a few visual breaking
changes, along with breaking changes for extension developers due to a shift in
internal representation of the position scales and their axes. No user breaking
changes are included.

This release also adds Dewey Dunnington (@paleolimbot) to the core team.

## Breaking changes
There are no user-facing breaking changes, but a change in some internal
representations that extension developers may have relied on, along with a few
breaking visual changes which may cause visual tests in downstream packages to
fail.

* The `panel_params` field in the `Layout` now contains a list of list of
  `ViewScale` objects, describing the trained coordinate system scales, instead
  of the list object used before. Any extensions that use this field will likely
  break, as will unit tests that checks aspects of this.

* `element_text()` now issues a warning when vectorized arguments are provided,
  as in `colour = c("red", "green", "blue")`. Such use is discouraged and not
  officially supported (@clauswilke, #3492).

* Changed `theme_grey()` setting for legend key so that it creates no border
  (`NA`) rather than drawing a white one. (@annennenne, #3180)

* `geom_ribbon()` now draws separate lines for the upper and lower intervals if
  `colour` is mapped. Similarly, `geom_area()` and `geom_density()` now draw
  the upper lines only in the same case by default. If you want old-style full
  stroking, use `outline.type = "full"` (@yutannihilation, #3503 / @thomasp85, #3708).

## New features

* The evaluation time of aesthetics can now be controlled to a finer degree.
  `after_stat()` supersedes the use of `stat()` and `..var..`-notation, and is
  joined by `after_scale()` to allow for mapping to scaled aesthetic values.
  Remapping of the same aesthetic is now supported with `stage()`, so you can
  map a data variable to a stat aesthetic, and remap the same aesthetic to
  something else after statistical transformation (@thomasp85, #3534)

* All `coord_*()` functions with `xlim` and `ylim` arguments now accept
  vectors with `NA` as a placeholder for the minimum or maximum value
  (e.g., `ylim = c(0, NA)` would zoom the y-axis from 0 to the
  maximum value observed in the data). This mimics the behaviour
  of the `limits` argument in continuous scale functions
  (@paleolimbot, #2907).

* Allowed reversing of discrete scales by re-writing `get_limits()`
  (@AnneLyng, #3115)

* All geoms and stats that had a direction (i.e. where the x and y axes had
  different interpretation), can now freely choose their direction, instead of
  relying on `coord_flip()`. The direction is deduced from the aesthetic
  mapping, but can also be specified directly with the new `orientation`
  argument (@thomasp85, #3506).

* Position guides can now be customized using the new `guide_axis()`, which can
  be passed to position `scale_*()` functions or via `guides()`. The new axis
  guide (`guide_axis()`) comes with arguments `check.overlap` (automatic removal
  of overlapping labels), `angle` (easy rotation of axis labels), and
  `n.dodge` (dodge labels into multiple rows/columns) (@paleolimbot, #3322).

* A new scale type has been added, that allows binning of aesthetics at the
  scale level. It has versions for both position and non-position aesthetics and
  comes with two new guides (`guide_bins` and `guide_coloursteps`)
  (@thomasp85, #3096)

* `scale_x_continuous()` and `scale_y_continuous()` gains an `n.breaks` argument
  guiding the number of automatic generated breaks (@thomasp85, #3102)

* Added `stat_contour_filled()` and `geom_contour_filled()`, which compute
  and draw filled contours of gridded data (@paleolimbot, #3044).
  `geom_contour()` and `stat_contour()` now use the isoband package
  to compute contour lines. The `complete` parameter (which was undocumented
  and has been unused for at least four years) was removed (@paleolimbot, #3044).

* Themes have gained two new parameters, `plot.title.position` and
  `plot.caption.position`, that can be used to customize how plot
  title/subtitle and plot caption are positioned relative to the overall plot
  (@clauswilke, #3252).

## Extensions

* `Geom` now gains a `setup_params()` method in line with the other ggproto
  classes (@thomasp85, #3509)

* The newly added function `register_theme_elements()` now allows developers
  of extension packages to define their own new theme elements and place them
  into the ggplot2 element tree (@clauswilke, #2540).

## Minor improvements and bug fixes

* `coord_trans()` now draws second axes and accepts `xlim`, `ylim`,
  and `expand` arguments to bring it up to feature parity with
  `coord_cartesian()`. The `xtrans` and `ytrans` arguments that were
  deprecated in version 1.0.1 in favour of `x` and `y`
  were removed (@paleolimbot, #2990).

* `coord_trans()` now calculates breaks using the expanded range
  (previously these were calculated using the unexpanded range,
  which resulted in differences between plots made with `coord_trans()`
  and those made with `coord_cartesian()`). The expansion for discrete axes
  in `coord_trans()` was also updated such that it behaves identically
  to that in `coord_cartesian()` (@paleolimbot, #3338).

* `expand_scale()` was deprecated in favour of `expansion()` for setting
  the `expand` argument of `x` and `y` scales (@paleolimbot).

* `geom_abline()`, `geom_hline()`, and `geom_vline()` now issue
  more informative warnings when supplied with set aesthetics
  (i.e., `slope`, `intercept`, `yintercept`, and/or `xintercept`)
  and mapped aesthetics (i.e., `data` and/or `mapping`).

* Fix a bug in `geom_raster()` that squeezed the image when it went outside
  scale limits (#3539, @thomasp85)

* `geom_sf()` now determines the legend type automatically (@microly, #3646).

* `geom_sf()` now removes rows that can't be plotted due to `NA` aesthetics
  (#3546, @thomasp85)

* `geom_sf()` now applies alpha to linestring geometries
  (#3589, @yutannihilation).

* `gg_dep()` was deprecated (@perezp44, #3382).

* Added function `ggplot_add.by()` for lists created with `by()`, allowing such
  lists to be added to ggplot objects (#2734, @Maschette)

* ggplot2 no longer depends on reshape2, which means that it no longer
  (recursively) needs plyr, stringr, or stringi packages.

* Increase the default `nbin` of `guide_colourbar()` to place the ticks more
  precisely (#3508, @yutannihilation).

* `manual_scale()` now matches `values` with the order of `breaks` whenever
  `values` is an unnamed vector. Previously, unnamed `values` would match with
  the limits of the scale and ignore the order of any `breaks` provided. Note
  that this may change the appearance of plots that previously relied on the
  unordered behaviour (#2429, @idno0001).

* `scale_manual_*(limits = ...)` now actually limits the scale (#3262,
  @yutannihilation).

* Fix a bug when `show.legend` is a named logical vector
  (#3461, @yutannihilation).

* Added weight aesthetic option to `stat_density()` and made scaling of
  weights the default (@annennenne, #2902)

* `stat_density2d()` can now take an `adjust` parameter to scale the default
  bandwidth. (#2860, @haleyjeppson)

* `stat_smooth()` uses `REML` by default, if `method = "gam"` and
  `gam`'s method is not specified (@ikosmidis, #2630).

* stacking text when calculating the labels and the y axis with
  `stat_summary()` now works (@ikosmidis, #2709)

* `stat_summary()` and related functions now support rlang-style lambda functions
  (#3568, @dkahle).

* The data mask pronoun, `.data`, is now stripped from default labels.

* Addition of partial themes to plots has been made more predictable;
  stepwise addition of individual partial themes is now equivalent to
  addition of multple theme elements at once (@clauswilke, #3039).

* Facets now don't fail even when some variable in the spec are not available
  in all layers (@yutannihilation, #2963).

# ggplot2 3.2.1

This is a patch release fixing a few regressions introduced in 3.2.0 as well as
fixing some unit tests that broke due to upstream changes.

* `position_stack()` no longer changes the order of the input data. Changes to
  the internal behaviour of `geom_ribbon()` made this reordering problematic
  with ribbons that spanned `y = 0` (#3471)
* Using `qplot()` with a single positional aesthetic will no longer title the
  non-specified scale as `"NULL"` (#3473)
* Fixes unit tests for sf graticule labels caused by chages to sf

# $NetBSD: Makefile,v 1.5 2021/06/06 14:56:14 mef Exp $

R_PKGNAME=	ggplot2
R_PKGVER=	3.3.3
CATEGORIES=	graphics

MAINTAINER=	minskim@NetBSD.org
COMMENT=	Create elegant data visualisations using the grammar of graphics
LICENSE=	gnu-gpl-v2

DEPENDS+=	R-lazyeval>=0.2.2:../../devel/R-lazyeval
DEPENDS+=	R-rlang>=0.3.0:../../devel/R-rlang
DEPENDS+=	R-withr>=2.0.0:../../devel/R-withr
DEPENDS+=	R-scales>=0.5.0:../../graphics/R-scales
DEPENDS+=	R-viridisLite>=0.3.0:../../graphics/R-viridisLite
DEPENDS+=	R-gtable>=0.1.1:../../math/R-gtable
DEPENDS+=	R-plyr>=1.7.1:../../math/R-plyr
DEPENDS+=	R-reshape2>=1.4.3:../../math/R-reshape2
DEPENDS+=	R-tibble>=2.1.3:../../math/R-tibble
DEPENDS+=	R-digest>=0.6.20:../../security/R-digest
DEPENDS+=	R-isoband-[0-9]*:../../graphics/R-isoband

# Packages suggested but not available:
#   'ggplot2movies', 'hexbin', 'Hmisc', 'multcomp', 'profvis',
#   'quantreg', 'svglite', 'vdiffr'

TEST_DEPENDS+=	R-dplyr-[0-9]*:../../math/R-dplyr
TEST_DEPENDS+=	R-mapproj-[0-9]*:../../math/R-mapproj
TEST_DEPENDS+=	R-maps-[0-9]*:../../geography/R-maps
TEST_DEPENDS+=	R-rgeos-[0-9]*:../../geography/R-rgeos
TEST_DEPENDS+=	R-sf-[0-9]*:../../geography/R-sf

USE_LANGUAGES=	# none

.include "../../math/R/Makefile.extension"
.include "../../mk/bsd.pkg.mk"