[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / MesaLib

Annotation of pkgsrc/graphics/MesaLib/Makefile, Revision 1.73

1.73    ! bjs         1: # $NetBSD: Makefile,v 1.72 2008/09/06 13:00:31 wiz Exp $
1.1       rh          2:
1.57      bjs         3: PKGNAME=       MesaLib-${MESA_PKGVERSION}
1.30      adam        4: COMMENT=       Graphics library similar to SGI's OpenGL
1.72      wiz         5: PKGREVISION=   2
1.30      adam        6:
1.57      bjs         7: MESA_HEADERS=  gl.h gl_mangle.h glext.h glx.h glxext.h \
                      8:                glx_mangle.h osmesa.h xmesa.h xmesa_x.h \
                      9:                xmesa_xf86.h
                     10:
1.65      bjs        11: MESA_HEADERS+= internal/dri_interface.h internal/sarea.h
                     12:
1.57      bjs        13: PKG_DESTDIR_SUPPORT=   user-destdir
                     14:
1.65      bjs        15: BUILD_DEFS+=           MESA_HZ
1.57      bjs        16: PLIST_VARS=            dri nodri
                     17:
1.73    ! bjs        18: .include "glx-config.mk"
1.57      bjs        19: .include "../../graphics/Mesa/Makefile.lib"
                     20: .include "options.mk"
1.40      jlam       21:
1.47      drochner   22: .if !empty(MACHINE_PLATFORM:MNetBSD-[12].*)
1.67      dsainty    23: ##
                     24: ## NetBSD 2.x and earlier require pthread stubs
                     25: ##
1.57      bjs        26: .  include "../../devel/pthread-stublib/buildlink3.mk"
1.67      dsainty    27: PTHREAD_STUBLIB= -L${PREFIX}/lib -Wl,-R${PREFIX}/lib -lpthstub
                     28: .elif !empty(MACHINE_PLATFORM:MNetBSD-*)
                     29: ##
                     30: ## NetBSD 3.x and later have pthread stubs in libc
                     31: ##
                     32: PTHREAD_STUBLIB=
1.47      drochner   33: .else
1.67      dsainty    34: ##
                     35: ## Other platforms may or may not have stubs provided by libc, but pulling in
                     36: ## threading support via the pthread.buildlink3.mk definitions will provide
                     37: ## all the necessary interfaces.  This matches the standard configuration for
                     38: ## most platforms as they appear in "${WRKSRC}/configs", and is necessary
                     39: ## for successful linking with libGL under many platforms.
                     40: ##
1.68      dsainty    41: .include "../../mk/pthread.buildlink3.mk"
1.67      dsainty    42: PTHREAD_STUBLIB= ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}
1.47      drochner   43: .endif
1.67      dsainty    44: PKGSRC_MAKE_ENV+=      PTHREAD_STUBLIB=${PTHREAD_STUBLIB:Q}
1.47      drochner   45:
1.55      joerg      46: .if !empty(USE_CROSS_COMPILE:M[yY][eE][sS])
                     47: MAKE_ENV+=     CROSS_COMPILING=yes
                     48: .endif
                     49:
1.57      bjs        50: RM_PATCH_BACKUP_DIRS=  docs src/mesa src/glut/glx \
                     51:                        progs/demos progs/xdemos progs/glsl
1.55      joerg      52: post-extract:
                     53:        ${CP} ${FILESDIR}/gen_matypes.awk ${WRKSRC}/src/mesa/x86
                     54:        ${CP} ${FILESDIR}/gen_matypes.sh ${WRKSRC}/src/mesa/x86
                     55:        ${CHMOD} a+x ${WRKSRC}/src/mesa/x86/gen_matypes.sh
1.57      bjs        56:        for fn in ${RM_PATCH_BACKUP_DIRS}; do \
                     57:                ${RM} -f ${WRKSRC}/$${fn}/*.orig; \
                     58:        done
1.55      joerg      59:
1.65      bjs        60: pre-install:
                     61:        ${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/include/GL/internal
                     62:
1.28      jschauma   63: pre-build:
1.54      seb        64:        cd ${WRKSRC} && ${RM} -fr src/glu src/glut progs
1.28      jschauma   65:
1.1       rh         66: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>