[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / MesaDemos

Annotation of pkgsrc/graphics/MesaDemos/Makefile, Revision 1.51

1.51    ! jperkin     1: # $NetBSD: Makefile,v 1.50 2022/08/11 05:08:38 gutteridge Exp $
1.1       jschauma    2:
1.43      tnn         3: DISTNAME=      mesa-demos-8.4.0
1.37      tnn         4: PKGNAME=       ${DISTNAME:S/mesa-demos/MesaDemos/}
1.50      gutterid    5: PKGREVISION=   6
1.37      tnn         6: CATEGORIES=    graphics
1.45      nia         7: MASTER_SITES=  https://mesa.freedesktop.org/archive/demos/
1.37      tnn         8: EXTRACT_SUFX=  .tar.bz2
                      9:
                     10: MAINTAINER=    pkgsrc-users@NetBSD.org
1.41      wiz        11: HOMEPAGE=      https://cgit.freedesktop.org/mesa/demos/
1.13      adam       12: COMMENT=       OpenGL examples and Demos
1.46      nia        13: LICENSE=       mit
1.2       jschauma   14:
1.37      tnn        15: GNU_CONFIGURE= yes
                     16: USE_LIBTOOL=   yes
                     17: USE_TOOLS+=    pkg-config
                     18: USE_LANGUAGES= c c++
                     19:
1.40      tnn        20: SUBST_CLASSES+=                bitmap
                     21: SUBST_STAGE.bitmap=    pre-configure
                     22: SUBST_MESSAGE.bitmap=  Avoid conflict with x11/bitmap and graphics/glx-utils
                     23: SUBST_FILES.bitmap=    src/glsl/Makefile.in
                     24: SUBST_FILES.bitmap+=   src/xdemos/Makefile.in
                     25: SUBST_SED.bitmap=      -e 's/bitmap$$(EXEEXT)/bitmap_mesademos$$(EXEEXT)/g'
                     26: SUBST_SED.bitmap+=     -e 's/glxgears$$(EXEEXT)/glxgears_mesademos$$(EXEEXT)/g'
                     27: SUBST_SED.bitmap+=     -e 's/glxinfo$$(EXEEXT)/glxinfo_mesademos$$(EXEEXT)/g'
                     28:
1.46      nia        29: # Mesa library features.
1.47      nia        30: PLIST_VARS+=           egl glesv2 osmesa
                     31:
                     32: # Appended in options.mk.
                     33: EGL_PROGS+=            eglkms peglgears
1.46      nia        34:
                     35: .include "../../graphics/MesaLib/buildlink3.mk"
                     36: .if !empty(MESALIB_SUPPORTS_EGL:M[Yy][Ee][Ss])
                     37: PLIST.egl=             yes
1.47      nia        38: .  if !empty(MESALIB_SUPPORTS_GLESv2:M[Yy][Ee][Ss])
                     39: PLIST.glesv2=          yes
                     40: .  else
                     41: CONFIGURE_ARGS+=       --disable-gles2
                     42: .  endif
1.46      nia        43: # eglfbdev.c:43:10: fatal error: linux/kd.h: No such file or directory
                     44: CONFIGURE_ARGS+=       --disable-gles1
1.47      nia        45: CONFIGURE_ARGS+=       --enable-egl
1.46      nia        46: .else
                     47: CONFIGURE_ARGS+=       --disable-egl
                     48: .endif
                     49:
                     50: .if !empty(MESALIB_SUPPORTS_OSMESA:M[Yy][Ee][Ss])
                     51: PLIST.osmesa=          yes
                     52: CONFIGURE_ARGS+=       --enable-osmesa
                     53: .else
                     54: CONFIGURE_ARGS+=       --disable-osmesa
                     55: .endif
                     56:
1.43      tnn        57: .include "options.mk"
1.47      nia        58:
                     59: post-install:
                     60: .if !empty(MESALIB_SUPPORTS_EGL:M[Yy][Ee][Ss])
                     61: .  for prog in ${EGL_PROGS}
                     62:        ${INSTALL_PROGRAM} ${WRKSRC}/src/egl/opengl/${prog} ${DESTDIR}${PREFIX}/bin
                     63: .  endfor
                     64: .endif
                     65:
1.51    ! jperkin    66: .include "../../converters/libiconv/buildlink3.mk"
1.46      nia        67: .include "../../graphics/freeglut/buildlink3.mk"
1.37      tnn        68: .include "../../graphics/freetype2/buildlink3.mk"
                     69: .include "../../graphics/glew/buildlink3.mk"
                     70: .include "../../graphics/glu/buildlink3.mk"
1.1       jschauma   71: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>