[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / Mesa

File: [cvs.NetBSD.org] / pkgsrc / graphics / Mesa / Attic / Makefile.common (download)

Revision 1.47, Sat Mar 4 21:29:45 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.46: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile.common,v 1.47 2006/03/04 21:29:45 jlam Exp $

DISTNAME=	MesaLib-${MESA_VERSION}
DISTFILES=	${DISTNAME}${EXTRACT_SUFX}
DISTFILES+=	${DISTNAME:S/MesaLib/MesaGLUT/}${EXTRACT_SUFX}
DISTFILES+=	${DISTNAME:S/MesaLib/MesaDemos/}${EXTRACT_SUFX}
WRKSRC=		${WRKDIR}/${DISTNAME:S/Lib//}
CATEGORIES=	graphics
MASTER_SITES= 	${MASTER_SITE_SOURCEFORGE:=mesa3d/}
EXTRACT_SUFX=	.tar.bz2

MESA_VERSION=	6.4.2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.mesa3d.org/

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_LIBTOOL=		yes

BUILDING_MESA=		yes
NO_CONFIGURE=		yes
DIST_SUBDIR=		Mesa-${MESA_VERSION}
PATCHDIR?=		${.CURDIR}/../MesaLib/patches
DISTINFO_FILE?=		${.CURDIR}/../MesaLib/distinfo

INSTALLATION_DIRS+=	lib

.include "../../mk/compiler.mk"
.include "../../mk/bsd.prefs.mk"
.include "../../mk/x11.buildlink3.mk"

# Mesa has proper support for Solaris and SunPro, use it.
.if ${OPSYS} == "SunOS"
.  if ${MACHINE_ARCH} == "sparc"
.    if !empty(PKGSRC_COMPILER:Msunpro)
.      if ${SPARC_TARGET_ARCH} == "sparcv7"
BUILD_TARGET=		sunos5
.      elif ${SPARC_TARGET_ARCH} == "sparcv8"
BUILD_TARGET=		sunos5-v8
.      elif ${SPARC_TARGET_ARCH} == "sparcv9"
BUILD_TARGET=		sunos5-v9
.      endif
.    else
BUILD_TARGET=		sunos5-gcc
.    endif
.  else	# i386
.    if !empty(PKGSRC_COMPILER:Msunpro)
BUILD_TARGET=		solaris-x86
.    else
BUILD_TARGET=		solaris-x86-gcc
.    endif
.  endif
.elif ${OPSYS} == "Interix"
BUILD_TARGET=		interix3
.else
BUILD_TARGET=		pkgsrc
.endif

pre-install:
	@if [ -n "${INSTLIBS}" ]; then					\
		${ECHO_MSG} "Installing libraries.";			\
		${INSTALL_LIB_DIR} ${PREFIX}/lib;			\
		for lib in ${INSTLIBS}; do				\
			${LIBTOOL} --mode=install ${INSTALL_LIB}	\
				$${lib} ${PREFIX}/lib;			\
		done;							\
	fi