[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / ImageMagick

File: [cvs.NetBSD.org] / pkgsrc / graphics / ImageMagick / Makefile (download)

Revision 1.118, Wed May 19 14:11:28 2004 UTC (19 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.117: +2 -2 lines

Changes 6.0.1-3:
* DrawSetStrokeDashArray() now respects the number_elements argument
* Since the WMF coder has Wand dependancies we only enable this coder when
  both WMF is available and module support enabled
* Some XCF tiles were not being read properly
* Fixed memory leak in EPT coder
* Fixed memory leak in DestroyImage()
* Close Windows registry when no longer needed
* RelinquishUniqueFileResource() was not freeing file resource properly
* Free the ImageInfo structure allocated by CloneImageInfo() in the
  WriteImages() method
* EPT images cannot support blobs
* Fixed temporary file resource limit leak in RelinquishUniqueFileResource()
* ConvolveImageChannel() incorrectly initialized non-selected channels to 0
* Added Cisco IP phone image format (write only)

# $NetBSD: Makefile,v 1.118 2004/05/19 14:11:28 adam Exp $

.include "Makefile.common"

PKGNAME=	ImageMagick-${DISTVERSION}

MAINTAINER=	adam@NetBSD.org
HOMEPAGE=	http://www.simplesystems.org/ImageMagick/
COMMENT=	Package for display and interactive manipulation of images

BUILDLINK_DEPENDS.jasper+=	jasper>=1.701.0
DEPENDS+=			mpeg2codec-1.2:../../graphics/mpeg2codec

CONFLICTS=	geomview<1.8.1nb2  # used to have a program named 'animate'

PKG_INSTALLATION_TYPES=	overwrite pkgviews

USE_BUILDLINK3=		YES
USE_X11=		YES
GNU_CONFIGURE=		YES
USE_LIBTOOL=		YES
USE_LANGUAGES=		c c++
PKGCONFIG_OVERRIDE=	Magick++/lib/ImageMagick++.pc.in
PKGCONFIG_OVERRIDE+=	magick/ImageMagick.pc.in

GCC_REQD+=		2.95.3

PLIST_SUBST+=		IM_MAJOR_VER=${IM_MAJOR_VER}
PLIST_SUBST+=		IM_MAJOR_LIB_VER=${IM_MAJOR_LIB_VER}

.include "../../mk/bsd.prefs.mk"

.if !empty(MACHINE_PLATFORM:MNetBSD-*-sparc64)
GCC_REQD+=		3.0
.endif

# Avoid compiler bug on "mipsel" (cobalt?)
.if ${MACHINE_ARCH} == "mipsel"
CFLAGS=			-O
.endif

# Some configure_args come from Makefile.common
CONFIGURE_ARGS+=	--without-perl

# Remove the empty directory
post-install:
	-${RMDIR} ${PREFIX}/share/ImageMagick

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../graphics/jasper/buildlink3.mk"
.include "../../graphics/libexif/buildlink3.mk"
.include "../../graphics/libwmf/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"