[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / ImageMagick

File: [cvs.NetBSD.org] / pkgsrc / graphics / ImageMagick / Makefile.common (download)

Revision 1.179, Wed Dec 12 15:10:04 2018 UTC (5 years, 4 months ago) by bsiegert
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.178: +2 -2 lines

Update ImageMagick to 7.0.8.16.

The old distfile is no longer available upstream, and no one uploaded one :(

2018-12-02  7.0.8-16 Cristy  <quetzlzacatenango@image...>
  * Add support for -clahe clip limit with percentages (e.g. -clahe 2x2+128+3%)
  * Check for modulo underflow.
  * Change SVG default DPI to 96 from 90 to meet recommendation of SVG2 & CSS.

# $NetBSD: Makefile.common,v 1.179 2018/12/12 15:10:04 bsiegert Exp $
#
# When updating this package, please upload the distfile
# since they disappear immediately when new releases happen,
# which is quite often.
#
# used by graphics/p5-PerlMagick/Makefile

IM_MAJOR_VER=		7.0.8
IM_MINOR_VER=		16
IM_MAJOR_LIB_VER=	7

.if (${IM_MINOR_VER} != NONE)
DISTSUFFIX=	${IM_MAJOR_VER}-${IM_MINOR_VER}
.else
DISTSUFFIX=	${IM_MAJOR_VER}
.endif

DISTNAME=	ImageMagick-${DISTSUFFIX}
DISTVERSION=	${DISTSUFFIX:S/-/./}

#
# Please always run `upload-distfiles' after every update!
# (upstream usually get rid of old version and only the latest stable versions
# are available in the mirrors)
#
CATEGORIES=	graphics
MASTER_SITES=	ftp://ftp.imagemagick.org/pub/ImageMagick/
MASTER_SITES+=	ftp://ftp.nluug.nl/pub/ImageMagick/
MASTER_SITES+=	https://www.imagemagick.org/download/
EXTRACT_SUFX=	.tar.xz

HOMEPAGE=	https://www.imagemagick.org/
LICENSE=	gnu-gpl-v3

WRKSRC=		${WRKDIR}/ImageMagick-${DISTSUFFIX}

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
# For things for which we do not specify an explicit dependency above, disable
# so that we don't cause implicit "hidden" dependencies.
CONFIGURE_ARGS+=	--without-dps
CONFIGURE_ARGS+=	--without-fpx
CONFIGURE_ARGS+=	--without-gvc
CONFIGURE_ARGS+=	--without-jbig
CONFIGURE_ARGS+=	--without-lqr
CONFIGURE_ARGS+=	--without-modules
CONFIGURE_ARGS+=	--disable-opencl