[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / ImageMagick

File: [cvs.NetBSD.org] / pkgsrc / graphics / ImageMagick / Makefile.common (download)

Revision 1.151, Tue Apr 4 11:14:45 2017 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.150: +2 -2 lines

Updated ImageMagick to 7.0.5.4.

2017-03-24  7.0.5-4 Cristy  <quetzlzacatenango@image...>
  * Release ImageMagick version 7.0.5-4, GIT revision 19754:350fff3:20170324.

2017-03-21  7.0.5-4 Cristy  <quetzlzacatenango@image...>
  * Respect -loop option for animate -window (reference
    https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=31619).

# $NetBSD: Makefile.common,v 1.151 2017/04/04 11:14:45 wiz Exp $
#
# When updating this package, please upload the distfile
# since they disappear immediately when new releases happen,
# which is quite often.
#
# used by graphics/p5-PerlMagick/Makefile

IM_MAJOR_VER=		7.0.5
IM_MINOR_VER=		4
IM_MAJOR_LIB_VER=	7

.if (${IM_MINOR_VER} != NONE)
DISTSUFFIX=	${IM_MAJOR_VER}-${IM_MINOR_VER}
.else
DISTSUFFIX=	${IM_MAJOR_VER}
.endif

DISTNAME=	ImageMagick-${DISTSUFFIX}
DISTVERSION=	${DISTSUFFIX:S/-/./}

#
# Please always run `upload-distfiles' after every update!
# (upstream usually get rid of old version and only the latest stable versions
# are available in the mirrors)
#
CATEGORIES=	graphics
MASTER_SITES=	ftp://ftp.imagemagick.org/pub/ImageMagick/
MASTER_SITES+=	ftp://ftp.nluug.nl/pub/ImageMagick/
MASTER_SITES+=	ftp://ftp.kddlabs.co.jp/graphics/ImageMagick/
MASTER_SITES+=	https://www.imagemagick.org/download/
EXTRACT_SUFX=	.tar.xz

HOMEPAGE=	https://www.imagemagick.org/
LICENSE=	gnu-gpl-v3

WRKSRC=		${WRKDIR}/ImageMagick-${DISTSUFFIX}

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
# For things for which we do not specify an explicit dependency above, disable
# so that we don't cause implicit "hidden" dependencies.
CONFIGURE_ARGS+=	--without-dps
CONFIGURE_ARGS+=	--without-fpx
CONFIGURE_ARGS+=	--without-gvc
CONFIGURE_ARGS+=	--without-jbig
CONFIGURE_ARGS+=	--without-lqr
CONFIGURE_ARGS+=	--without-modules