[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / GraphicsMagick

File: [cvs.NetBSD.org] / pkgsrc / graphics / GraphicsMagick / Makefile (download)

Revision 1.13, Mon Jun 30 12:34:10 2008 UTC (15 years, 9 months ago) by obache
Branch: MAIN
Changes since 1.12: +2 -2 lines

Update GraphicsMagick to 1.2.4.

1.2.4 (June 29, 2008)
====================

Security Fixes:

  * AVI reader: Re-worked to be more robust against crash or DOS.

  * AVS reader: Re-worked to be more robust against crash or DOS.

  * DCM reader: Re-worked to be more robust against crash or DOS.

  * EPT reader: Re-worked to be more robust against crash or DOS.

  * FITS reader: Re-worked to be more robust against crash or DOS.

  * MTV reader: Re-worked to be more robust against crash or DOS.

  * PALM reader: Re-worked to be more robust against crash or DOS.

  * RLA reader: Re-worked to be more robust against crash or DOS.

  * TGA reader: Re-worked to be more robust against crash or DOS.

  * Avoid possible crash in GetImageCharacteristics() when substituting
    text in comment read from file.

Bug fixes:

  * Magick++ Image Quantize was not supporting error measurement properly
    and was waisting time with redundant SyncImage().

  * The --enable-magick-compat configure option was not being respected
    by the Makefiles (SourceForge bug 2005883).

# $NetBSD: Makefile,v 1.13 2008/06/30 12:34:10 obache Exp $
#

DISTNAME=	GraphicsMagick-1.2.4
CATEGORIES=	graphics
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=graphicsmagick/} \
		ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/

MAINTAINER=	obache@NetBSD.org
HOMEPAGE=	http://www.graphicsmagick.org/
COMMENT=	X application for displaying and manipulating images

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES=	c c++
USE_LIBTOOL=	yes
USE_TOOLS+=	gmake pkg-config gs
USE_FEATURES=	vsnprintf		# optional but recommended for security
GNU_CONFIGURE=	yes

PKGCONFIG_OVERRIDE+=	magick/GraphicsMagick.pc.in \
			wand/GraphicsMagickWand.pc.in \
			Magick++/lib/GraphicsMagick++.pc.in

CONFIGURE_ARGS+=	--without-perl

TEST_TARGET=	check

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/lcms/buildlink3.mk"
.include "../../graphics/libexif/buildlink3.mk"
.include "../../graphics/libwmf/buildlink3.mk"
.include "../../graphics/jasper/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/xextproto/buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"