[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / graphics / Coin

File: [cvs.NetBSD.org] / pkgsrc / graphics / Coin / Makefile (download)

Revision 1.36, Tue Jan 3 17:36:22 2023 UTC (4 months, 3 weeks ago) by wiz
Branch: MAIN
Changes since 1.35: +2 -2 lines

*: recursive bump for tiff shlib major bump

# $NetBSD: Makefile,v 1.36 2023/01/03 17:36:22 wiz Exp $

DISTNAME=		Coin-3.1.3
PKGREVISION=		8
CATEGORIES=		graphics
MASTER_SITES=		https://bitbucket.org/Coin3D/coin/downloads/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.coin3d.org/
COMMENT=		Free, portable, Open Inventor API implementation
LICENSE=		modified-bsd
# See https://bitbucket.org/Coin3D/coin/wiki/EndOfLifeLetter

USE_LANGUAGES=		c c++03
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-3ds-import
CONFIGURE_ARGS+=	--disable-debug

.include "../../mk/pthread.buildlink3.mk"

.if defined(PTHREAD_TYPE) && ${PTHREAD_TYPE} != "none"
CONFIGURE_ARGS+=	--with-pthread=yes
CONFIGURE_ARGS+=	--enable-threadsafe
.endif

.include "../../mk/bsd.prefs.mk"

.if !empty(OPSYS:MDarwin)
CONFIGURE_ARGS+=	--without-framework
.endif

.include "../../graphics/simage/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/glu/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"