[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / geography / geos

File: [cvs.NetBSD.org] / pkgsrc / geography / geos / Makefile (download)

Revision 1.4, Fri Nov 10 21:00:23 2006 UTC (17 years, 4 months ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.3: +3 -4 lines

Update to 2.2.3.  (Minor and irrelevant changes omitted.)
Take maintainership.

Changes in 2.2.3

- CAPI: multiple finishGEOS() calls made harmless.

Changes in 2.2.2

- Added LinearRing::clone
- Added GEOSArea(), GEOSLength(), GEOSEnvelope(), and GEOSGeomType() to C API
- Cleanups in C-API
- Support for gcc-4
- Fixed Polygon::equalsExact
- Fixed bug in NULL-factory Geometry constructor
- Cleanups in SWIG wrappers
- New Ruby bindings
- Enumerated SweepLineEvent's DELETE and INSERT labels
  renamed to DELETE_EVENT and INSERT_EVENT.
- Fixed geos-config to use system-specific libs path
- Accept correct WKT format for MultiPoints
- SRID support in (E)WKB reader.

Changes in 2.2.0

- Higher dimensions interface for CoordinateSequence
- Added getCoordinatesRO for Point class
- NEW WKB IO
- NEW Simplified and stabler C API

Changes in 2.1.4

- Severe BUGFIX in BufferSubgraphGT and other functions used
  as StrictWeakOrdering predicates for sort()

Changes in 2.1.3

- XMLTester installed by default
- New Node::isIncidentEdgeInResult() method

Changes in 2.1.2

- Added multipolygon buffering test in source/test/testLeaksBig
- Ported JTS robustness patch for RobustLineIntersector
- Removed useless Coordinate copies in OverlayOp::mergeZ()
- Avoided throws by IsValid on invalid input
- Stricter C++ syntax (math.h=>cmath, ieeefp.h in "C" block, ostringstream
  instead of sprintf)
- Better support for older compilers (Polygonizer::LineStringAdder friendship)
- Removed useless Coordinate copies in CGAlgorithms::isOnLine()
- Added support for polygonize and parametrized buffer tests in XMLTester
- Fixed Z interpolation in LineIntersector
- Made polygon::getBoundary() always OGC-valid (no LinearRings)
- Input checking and promoting in GeometryFactory::createMultiLineString()
- Segfault fix in GeometryEditor::editPolygon()

Changes in 2.1.1

- Fixed uninitialized Coordinate in TopologyException
- Added install of version.h, platform.h and timeval.h
- Z interpolation in overlay operations

Changes in 2.1.0

- Added Polygonizer and LineMerger classes.
- python wrapper examples
- Z support in overlay operations.

# $NetBSD: Makefile,v 1.4 2006/11/10 21:00:23 gdt Exp $
#

DISTNAME=		geos-2.2.3
CATEGORIES=		geography
MASTER_SITES=		http://geos.refractions.net/
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		gdt@NetBSD.org
HOMEPAGE=		http://geos.refractions.net/
COMMENT=		C++ port of the Java Topology Suite (JTS)

USE_PKGLOCALEDIR=	yes
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_LANGUAGES=		c c++

.include "../../mk/bsd.pkg.mk"