[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / geography / gdal-lib

File: [cvs.NetBSD.org] / pkgsrc / geography / gdal-lib / Makefile (download)

Revision 1.30, Fri Aug 27 11:14:23 2010 UTC (13 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.29: +5 -5 lines

Changes 1.7.2:
* configure/libtool/etc regenerated with newer versions.
* Fix definition of CPL atomic function with CPL_INLINE undefined
* Clean out remnants of old generation python support in configure
* Fix build problems on systems with 64bit pointer and 32bit long
* C#: Fixed ambiguous reference to SpatialReference in C# sample apps
* C#: Fix crash on memory release of string from ExportToWkt()
* Java: Handle transparency better in color tables
* Python 2.x/3.0 compatability fixes for scripts
* Python fixes for numpy array io
* stateplane.csv updated for Kentuky and California fixes

# $NetBSD: Makefile,v 1.30 2010/08/27 11:14:23 adam Exp $

DISTNAME=	gdal-1.7.2
PKGNAME=	gdal-lib-1.7.2
CATEGORIES=	geography
MASTER_SITES=	http://download.osgeo.org/gdal/

MAINTAINER=	brook@nmsu.edu
HOMEPAGE=	http://www.gdal.org/
COMMENT=	Translator library for raster geospatial data formats
LICENSE=	mit

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES=		c c++ fortran
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		gmake
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--with-geos
CONFIGURE_ARGS+=	--with-libz=${BUILDLINK_PREFIX.zlib}/include
CONFIGURE_ARGS+=	--with-xerces
CONFIGURE_ARGS+=	--with-xerces-inc=${BUILDLINK_PREFIX.xerces-c}/include
CONFIGURE_ARGS+=	--with-xerces-lib=-L${BUILDLINK_PREFIX.xerces-c}/lib\ -lxerces-c
CONFIGURE_ARGS+=	--without-python

MAKE_FILE=		GNUmakefile

.include "options.mk"

CHECK_PORTABILITY_SKIP+=	mkbindist.sh

INSTALLATION_DIRS=	bin include lib ${PKGMANDIR}/man1 share/gdal

.include "../../devel/zlib/buildlink3.mk"
.include "../../geography/geos/buildlink3.mk"
.include "../../geography/proj/buildlink3.mk"
.include "../../graphics/jasper/buildlink3.mk"
.include "../../graphics/libungif/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../textproc/xerces-c/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"