The NetBSD Project

CVS log for pkgsrc/geography/R-sf/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / geography / R-sf

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Nov 27 23:26:16 2024 UTC (3 months, 2 weeks ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -4 lines
(geography/R-sf) 1.0.13 to 1.0.19

# version 1.0-19

* fix type checks in C++ GDAL area and length computation functions,
  anticipating GDAL 3.10.0; #2466, #2468, #2469 by @rsbivand and
  @rouault

* improve test on empty geometries, which changed in 1.0-18; #2463

* `gdal_utils()` `ogrinfo` has an argument `read_only` which, when
  `TRUE` (or `options` includes `"-ro"`), opens a datasource in
  read-only mode (#2460; `sf` did this before 1.0-17); by default a
  datasource is opened in update (read-write) mode (since sf 1.0-17;
  #2420)

* the `sf` -> `ppp` conversion `as.ppp.sf()` accepts a data.frame of
  marks instead of just 1 column #2450, by @agila5

* add flag for preservation of point order in `st_voronoi` #1371 for
  GEOS >= 3.12

# version 1.0-18

* support `POLYGON FULL` simple feature geometry, representing the
  entire Earth surface, as used by `s2geometry`; see also
  https://r-spatial.org/r/2024/10/11/polygonfull.html for a longer
  introduction; #2441

* `st_sfc()` has an argument `oriented` which, when set to `TRUE`,
  adds an attribute `oriented=TRUE` to an `sfc` object, indicating
  that this object should not be reoriented in conversion to
  `s2_geography` (avoiding using the global option `s2_oriented`);
  `st_as_sfc.bbox()` sets this to `TRUE`; #2441

* fix build failure with GDAL < 3.4.0 #2436

* `st_simplify()` now accepts feature-wise tolerance values when `s2`
  is switched on #2442

# version 1.0-17

* add `st_transform()` method for `bbox` objects; this uses
  OGRCoordinateTransformation::TransformBounds(), densifying first and
  antemeridian proof; #2415

* `st_filter.sf()` correctly scopes `x` and `y` arguments using !!
  operator; #2416

* `[.sfc` and `[<-.sfc` use matrix/array type subsetting for `sfc`
  objects that have a `dim` attribute

* add `st_exterior_ring()` to extract exterior rings (remove holes);
  #2406

* add `text.sf()`, `text.sfc()`, `points.sf()`, `points.sfc()` to
  annotate base plots at geometry centroids; #2399

* `st_sf()` no longer strips `tbl` or `tbl_df` class labels; #2378

* `st_layers()` returns an object of class `c("sf_layers",
  "data.frame")`, with a dedicated `print` method.

* when `dim` is not `XYZM`, `sf_as_sf.data.frame()` interprets a
  length 4 `coords` argument to specify the corners of a rectangular
  polygon; #2357

* `st_interpolate_aw()` gains an `na.rm` argument, for removing
  features with `NA` attributes before interpolating; #830

* `merge.sf()` no longer renames geometry column; #2334

# version 1.0-16

* `st_join()` no longer renames the geometry column; #2327

* `st_sample()` works when unprojected polygon geometry crosses the
  antemeridian; #2331

* clean up and modernization of S3 registration of methods and tests;
  #2285, #2288, #2316, #2341, #2342, by @olivroy

* `[.sfc` works when setting argument `op`; #2320

* `st_sample()` for polygons is sensitive to setting `oriented = TRUE`
  to prevent wrongly correcting ring directions; #2308

* add support for the GDAL `footprint` utility (requiring GDAL >=
  3.8.0) to `gdal_utils`; #2305, by @goergen95

* existing environment variables `PROJ_LIB` and `PROJ_DATA` are
  (again) ignored on `sf` binary CRAN installations (win + macos),
  effectively by overwriting them during the R session and restoring
  them on exit; this does not happen if environment variable
  `R_SF_USE_PROJ_DATA` is set to `true`. #2298

* add `st_line_project()` to find how far a point is when projected on
  a line; #2291

* add `st_line_interpolate()` to obtain a point at a certain distance
  along a line; #2291

# version 1.0-15

* add `st_perimeter()` generic to cover both geographic and projected
  coordinates; #268, #2279, by @JosiahParry

* add `st_sample()` method for `bbox`, with special provisions for
  ellipsoidal coordinates; #2283

* documentation clean-up by @olivroy; #2266, #2285

* `st_convex_hull()` uses `s2::s2_convex_hull()` for geodetic
  coordinates; #2250

* add `directed` argument to `st_line_merge()`; #2264

* `st_union.sfc()` given `x` and `y` works consistently across
  geodetic and projected objects; #2262

* `st_union.sf()` given `x` and `y` unions pairwise if `by_feature = TRUE`; #2259

* `st_read()` work around issue with GPKG driver if `wkt_filter` is set; #2248

* `st_read()` uses GDAL's stream reading when `use_stream = TRUE`;
  #2238 by @paleolimbot

* `st_transform()` responds to in-session changes to `sf_proj_network()`; #2166

* `plot.sf()`: `key.width` is sensitive to pointsize graphics
  parameter `par("ps")`; keys with factor levels suggest a proper size
  if they won't fit.

* `plot.sf()`: `key.pos` can hold a second value in [0, 1] determining
  the relative position of the key in the available space

* `[<-.sf` fixes the `agr` attribute when it is broken; #2211

* if the env. variable `ADD_SF_NAMESPACE` is set to `true`, `sf`
  objects get a new attribute, `.sf_namespace`, which forces loading
  the `sf` namespace when it has not been loaded so far, e.g. for
  proper printing or plotting of an `sf` object; #2212 by Mike Mahoney

* `distinct.sf()` is type-safe for `sf` objects with zero rows; #2204

* `summarise.sf()` raises an error if `.by` is given but no `across()`
  on the geometry; #2207

* `st_write()` matches fields on name first, than on position; this
  matters for formats that have pre-defined names, such as GPX; #2202

# version 1.0-14

* fix `plot.sf()` when using a key for multiple factor variables; #2196, #2195

* fix use of `as.numeric_version` in a test, for upcoming change in r-devel

* code tidy-ing: fix many lintr suggestions, thanks to Michael Chirico
  (#2181 - #2191)

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Jun 5 23:03:07 2023 UTC (21 months, 2 weeks ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -4 lines
(geography/R-sf) Updated 1.0.2 to 1.0.13

# version 1.0-13

* `gdal_utils()` adds `"ogrinfo"` utility (requires GDAL >= 3.7.0); #2160

* `st_as_sf()` catches errors when setting invalid crs values, raised by Jon Skøien

* add `rename_with.sf()` method; #1472

* use GEOS' overlayNG routines for (GEOS) Intersection, Difference,
  Union and SymDifference; #2143

* added `duplicated.sf()`; #2138, #2140, thanks to @bart1

* `select.sf()` allows selecting the same column twice under different names; #1886

* `st_as_sf.ppplist()` is deprecated; #1926

* `st_cast()` handles empty geometries; #1961

* don't repeat longlat messages in `summarise.sf()`; #1519

* fix random sampling on the sphere; #2133

# version 1.0-12

* update NAMESPACE to `useDynLib(sf, .registration=TRUE)`; #2127 thanks to @eddelbuettel

* fix call in `gdal_addo()`; #2124

* fix issues that came up with older GDAL version, use `GDAL_VERSION_NUM` consistently; #2123 #2121 #2119

# version 1.0-11

* `st_make_grid()` also accepts area units for `cellsize`, for square and hexagonal grids; #1505

* add `st_concave_hull()`, for concave hulls, if GEOS >= 3.11.0; #1964

* add `st_triangulate_constrained()`, for constrained Delaunay triangulation, if GEOS >= 3.10.0; #1964

* clean up the retrieval of length or angle units from WKT
  representations;
  https://lists.osgeo.org/pipermail/gdal-dev/2023-March/056994.html

* conversion to GEOS uses the `GEOS_PREC_VALID_OUTPUT` flag, which
  makes sure that the "[o]utput is always valid. Collapsed geometry
  elements (including both polygons and lines) are removed."

# version 1.0-10

* `gdal_utils()` has a `config_options` argument to set further GDAL
  options, just like `st_write()`; #2003

* fix slow writing of logical vectors in `st_write()`; #1409; #1689

* `st_drivers()` has an argument `regex` to filter on driver (long) name; #2090

* drop C++11 as a system requirement

* `c.sfc()` (and, consequently, `dplyr::bind_rows()`) gives an error
  if components have different CRS; #1884

* data imported from `maps` are associated with the Clark 1866 ellipsoid; #2080

* fix importing legacy `SpatialPolygon` objects without comments;
  #2063, #2069, https://github.com/rstudio/leaflet/issues/833

* `st_read()` no longer errors on mixes of `XY` and `XYZ` geometries; #2046 #1592

* in `plot.sf()`, when numeric `breaks` are given a legend key is always plotted; #2065

* `st_crs()$axes` returns a `data.frame` with axes properties (name,
  orientation, conversion factor) when GDAL >= 3.0.0

* clean up unit handling for geometry measures (length, area, distance) and crs;

* `st_crs(x)$ud_unit` returns `NULL` if units are unknown; #2049

* `st_write()` substitutes an `NA` crs with `ENGCRS["Undefined
  Cartesian SRS with unknown unit"]`; #2049, #2054

* `st_can_transform()` checks whether a transformation between two crs
  exists; see https://github.com/dieghernan/tidyterra/issues/64; #2049

* the matrix returned by `st_coordinates()` has no row names, to reduce output size

# version 1.0-9

* adjust for changes how R-devel handles `POSIXlt`; #2028

* add `st_break_antimeridian()`; #1983, #1991 by Roger Bivand

* add `Fibonacci` as a spatial sampling type in `st_sample()`

* use the global `options("sf_use_s2")` to determine whether to use
  s2, rather than a value in a local environment; #1977

* fix utils `mdiminfo` and `mdimtranslate` in `gdal_utils()`

* extend arguments of `gdal_read_mdim()` needed by
  `stars::read_mdim()` if `stars` >= 0.5-7; add `gdal_write_mdim()`

* add `drop_na()` method for `sf` objects; #1975

# version 1.0-8

* `st_drop_geometry.default()` returns `x` unmodified;

* `sf_project()` accepts 3- or 4-column matrices, containing z and t values;

* optimizations for `st_sfc()` by @paleolimbot; #1938, #1925

* `[<-.sfc()` recomputes the bounding box; `st_sfc()` gets parameter `compute_bbox`; #1965

* add new algorithm and drop option to `st_make_valid()` when using GEOS and GEOS >= 3.10.1; #1655

* add `st_minimum_rotated_rectangle()`, available when GEOS >= 3.9.0; #1953

* fix `st_sample()` with `type = "hexagonal"` for corner case (n=1),
  add a `progress` argument for a progress bar; #1945

* add package `pbapply` to Suggests; #1945

* add pdf driver to windows build; #1942

* clarify `pipeline` argument in `st_transform()` when axis order is ambiguous; #1934

* handle argument `xpd` in calls to `plot.sfc_POLYGON()` and `plot.sfc_MULTIPOLYGON()`

* add `pivot_wider()` method, by Henning Teickner; #1915

* add `gdal_addo()` to add or remove overviews from raster images; #1921

* `st_layers()` returns `crs` of each layer in a `crs` list of `crs` objects

* restore `st_graticule()` behaviour to pre-sf 1.0-0;
  https://github.com/tidyverse/ggplot2/issues/4571

* `gdal_metadata()` sets metadata item names properly

* `st_read()` gains an argument `optional` passed on to
  `as.data.frame` to avoid changing column names; #1916

* GPX files are autodetected by `st_read()`; #1917

* unnecessary coordinate names are not returned in `st_sample()`,
  making the output size smaller; #1879

# version 1.0-7

* `st_drop_geometry()` is a generic; #1914

* `st_crs(x)$ud_unit` returns the unit of the coordinate reference system of `x`

* geometric predicates return `sgbp` objects omitting
  self-intersections etc. by passing `remove_self = TRUE` and unique
  symmetric relationship by passing `retain_unique = TRUE` (to `...`
  if needed); this simplifies identifying (and removing) duplicated
  geometries; duplicates are identified by e.g. by `st_equals(x,
  retain_unique = TRUE) |> unlist() |> unique()`; #1893

* fix compile issue against GDAL < 2.5.0 introduced in 1.0-6; #1899

# version 1.0-6

* adapt to new `spatstat.random` package; #1892

* `st_geometry<-()` also allows to rename a geometry column in an `sf` object; #1890

* for `sf` objects, the `st_as_sfc()` method is an alias for `st_geometry()`; #1882

* `st_make_grid()` speeded up; #1579 thanks to Krzysztof Dyba

* remove direct and indirect dependencies on `rgeos` and `rgdal`; #1869

* use `stats::dist` rather than GEOS for symmetric point-point Euclidian distance computation; #1874

# version 1.0-5

* package startup message reports status of `sf_use_s2()`; #1782

* `sf_use_s2()` uses `message()` to report a change; #1782

* `st_sample()` using regular sampling for ellipsoidal coordinates
  "works" as if coordinates were Cartesian; #1837

# version 1.0-4

* new function `st_delete()` deletes a data source, or layer(s) within
  a data source; #1828

* fix memory leak in `WKT1_ESRI` retrieval; #1690

# version 1.0-3

* cope with how GEOS >= 3.10.0 handles illegal geometries (e.g., non-closed rings); #1807

* `crs` objects have a `$srid` method to extract the SRID (as authority "name:code"); #1804

* `st_as_grob()` methods for `sfc_*` objects correctly handle empty
  geometries; #1789 with help from Hiroaki Yutani

* when writing objects with `NA` as CRS to GeoPackage, assign "Unknown
  Cartesian CRS" first - this is in line with using Cartesian geometry
  operations for objects with `NA` as CRS; #1776

* add coerce method from `sgbp` to `sparseMatrix`; #1750

* fix `st_cast()` for `GEOMETRYCOLLECTIONS` containing empty geometries; #1767

* fix `st_is_valid()` for bogus polygons and projected coordinates; #1666, #1760; #1761

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Oct 26 10:45:07 2021 UTC (3 years, 4 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
geography: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Oct 7 14:09:22 2021 UTC (3 years, 5 months ago) by nia
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
geography: Remove SHA1 hashes for distfiles

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Sep 20 06:45:31 2021 UTC (3 years, 5 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -5 lines
(geography/R-sf) Updated 0.9.8 to 1.0.2

# version 1.0-2
* `st_read()` and `st_write()` using GDAL handle binary attributes
  (OFTBinary fields) ; #1721

* a `pivot_longer` method is added for `sf` objects (the `data.frame`
  method works, but raises a warning)

* `rbind.sf` preserves primary geometry column; #1717

* `configure` constrains using `--static` to `Darwin` platform; #1702,
  #1712, #1713

* old-style `crs` objects created with sf < 0.9-0 generate a message,
  and will cause a warning in the future.

* when `st_crs()` is called with a WKT2 as text input, its `input`
  field will be replaced with the CRS name (if it has one).

* GEOS (>= 3.9.0) operations use `GEOSGeom_setPrecision_r` to set
  precision of geometries; #1535

* `st_read()` with specified `query` ignores argument `layers`, and
  warns if it is given; #1444


# version 1.0-1
* fix regression in `st_intersection()`: when using s2 attributes were
  assigned wrongly; #1704

* `crs` (sf) to `CRS` (sp) conversion no longer needs validation by
  `rgdal`; https://github.com/edzer/sp/issues/107

* retrieve ESRI's WKT version of CRS by `st_crs(id)$WKT1_ESRI`; #1690


# version 1.0-0
* add `s2` to Imports:

* add Dewey Dunnington to contributors

* `sf_use_s2()` prints a message when using s2 has been switched to on or off.

* use `s2` spherical geometry as default when coordinates are ellipsoidal. This can
  be switched off (defaulting to planar geometry, using GEOS, as in sf < 1.0-0)
  by setting environment variable `_SF_USE_S2` to `false` before package `sf`
  is loaded, or by `sf_use_s2(FALSE)`; #1649

* `st_nearest_feature()` with missing `y` returns nearest features in
  the remaining set of `x`; https://github.com/r-spatial/s2/issues/111

* `st_write()` gains an argument `config_options` to set GDAL config
  options; #1618

* fix regression in `sf_project(..., keep = TRUE)`; #1635

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sun Jun 6 14:45:22 2021 UTC (3 years, 9 months ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +5 -5 lines
(geography/R-sf) Updated 0.9.5 to 0.9.8

# version 0.9-8

* add `st_as_sf` method for terra's `SpatVector` class; #1567

* `distinct.sf` works by default on all variables, and keeps active geometry
  afctive; #1613

* improve (fix?) polygonize/contour code; #1608

* `sf_proj_network()` reports whether PROJ uses network (CDN) grids, can switch
  it on or off, and can set the CDN url.

* `st_write` returns obj, invisibly; #1597

* fix regression in n-ary `st_intersection()`, #1595, introduced at #1549

* `st_inscribed_circle` computes the maximum inscribed circle for polygons
  (requires GEOS >= 3.9.0)

* allow to `st_cast` COMPOUNDCURVE, MULTISURFACE or CURVEPOLYGON to
  GEOMETRYCOLLECTION (and back); #1573

* Fixed a bug in `st_as_grob()` when plotting a mix of MULTI and non-MULTI
  geometries of the same base type

# version 0.9-7

* n-ary `st_intersection` skips failing geometries, rather than returning an
  error; #1549

* use `s2_centroid` for geographical coordinates if `sf_use_s2()` is `TRUE`.

* `st_as_text` method for `crs` objects can return projjson (if GDAL >= 3.1.0
  and PROJ > 6.2.0)

* `st_transform` no longer warns on conversions like `"+proj=ob_tran
  +o_proj=longlat +o_lat_p=45 +o_lon_p=30"`

* `st_as_wkb` takes `srid` from `wkt` field of `crs` when `input` field doesn't
  contain it; #1490

* `plot.sf` adds `key.pos=0` option to run the logic behind the key without
  plotting it; #1487

* fix bug in `select.sf` when selected variables were renamed; #1483

* `st_as_sf.stars` with `merge = TRUE` now works if crs is `NA`; #1389

* add (dynamically loaded) `as_wkb` methods for `sf`, `sfc` and `sfg`, making
  `st_as_s2()` unnecessary

* `st_as_s2` transforms non-longlat objects to EPSG:4326 first

# version 0.9-6

* `gdal_utils` print (GDAL-style) progress bar if `quiet = FALSE` (except for
  `info` and `mdiminfo`)

* fix `CPL_gdal_warper` for multi bands; https://github.com/r-spatial/stars/issues/320

* `sf_proj_search_paths()` retrieves and sets the proj search path (if GDAL > 3.0.3)

* when loading sf, `sf_use_s2` is set to `FALSE` unless environment variable
  `_SF_USE_S2` equals `true`

* resolve GDAL/PROJ version vulnerabilities in CRS-crs conversion; #1479

* `st_sample` gains an argument, `by_polygon`, to more clevery sample
  `MULTIPOLYGON` geometries; #1480

* `st_sample` accepts non-integer sample sizes, with a (suppressable) warning
  and handles values of sizes that would round to zero; #1480

* `gdal_utils` adds utils `mdiminfo` and `mdimtranslate` (requires GDAL >= 3.1)

* `st_union` gains an argument `is_coverage`, which, when set to `TRUE`, leads
  to much faster unioning in case features form a coverage (polygons don't
  overlap); #1462 by Don Baston

* fix `gdal_utils("translate")` locking input file; #1452

* `st_make_grid` no longer selects cells intersecting with `x`; #1447

* use `s2::s2_dwithin_matrix` in `st_is_within_distance`; #1367

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sat Aug 8 23:12:18 2020 UTC (4 years, 7 months ago) by brook
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
geography/R-sf: import R-sf-0.9.5

Support for simple features, a standardized way to encode spatial
vector data. Binds to 'GDAL' for reading and writing data, to 'GEOS'
for geometrical operations, and to 'PROJ' for projection conversions
and datum transformations. Optionally uses the 's2' package for
spherical geometry operations on geographic coordinates.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>