File:  [cvs.NetBSD.org] / pkgsrc / geography / R-osmdata / Makefile
Revision 1.3: download - view: text, annotated - select for diffs
Fri Nov 29 15:31:15 2024 UTC (3 months, 2 weeks ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
(geography/R-osmdata) Updated 0.1.6 to 0.2.5

0.2.5
===================

## Major changes

- v0.2.4 was removed without notice from CRAN because of #329; this is
  a rapid re-submission

0.2.4
===================

## Minor changes

- Bug fix to stop getbb call to Nominatim returning 405 error (#328)


0.2.3
===================

## Minor changes

- Fix failing test due to changes to 'sp' moving towards deprecation.


0.2.2
===================

## Major changes:
- `osmdata_data_frame` adds columns `osm_center_lat` and
  `osm_center_lon` for `out * center;` queries (#316, #319).

- Add parameters from `opq` to `opq_osm_id`: out, datetime, datetime2,
  adiff, timeout and memsize (#320)

- Fix `available_tags()` function which no longer worked (#322 thanks
  to @boiled-data)

- Implement `out:csv` queries (#321).

## Minor changes

- Fix queries with `!match_case` and only one value (#317).
- Fix queries with multiple features & multiple osm_types (#318).

0.2.1
===================

## Major changes:

- Very soft deprecation of `nodes_only` parameter in `opq` (#308, #312).

## Minor changes

- Couple of minor memory leak bug fixes in `osmdata_data_frame` C++ code.

0.2.0
===================

This release welcomes a new package author @jmaspons. The lists of
changes here gives an overview of the amazing work he has contributed
to this new major version.

## Major changes:

- New `osmdata_data_frame()` function to return non-spatial
  `data.frame` structures directly from overpass; thanks to @jmaspons
  (#285).

- Improved `add_osm_features` so that key-values pairs can be
  submitted as a list, rather than escape-delimited character strings;
  thanks to @elipousson (#277, #278).

- `opq()` can now utilise overpass ability to filter results by area;
  thanks to @jmaspons (#286).

- `opq()` now has additional "out" parameter to control the kinds of
  data returned by overpass; thanks to @jmaspons (#288).

- `opq()` now has additional "osm_types" parameter to provide finer
  control of which kinds of data are returned by overpass; thanks to
  @jmaspons (#295).

- Fix key modifications for non-valid column names and handle
  duplicated column names in `osmdata_*` functions; by @jmaspons
  (#303)

- @elipousson is new package contributor, thanks to the above work.

- @jmaspons is new package author, thanks to #285 (plus most of the
  above, and a whole lot more!)

## Minor changes:

- Downgraded `sp` from "Imports" to "Suggests"; thanks to @jmaspons
  (#302)

- Improved `osm_osm_id()` to accept vectors of ids and types; thanks
  to @jmaspons (#268, #282, #283)

- "get-osmdata.R" file now split into several smaller and more
  manageable files (#306, thanks to @jmaspons)

0.1.10
===================

## Major changes:

- Changed httr dependency for httr2 (#272)

- Removed two authors of code formerly including for stubbing results;
  which is now done via `httptest2` package.

## Minor changes:

- Moved jsonlite from Imports to Suggests (now only used in tests).

0.1.9
===================

## Major changes:

- New function `opq_around` to query features within a specified radius
  *around* a defined location; thanks to @barryrowlingson via #199 and
  @maellecoursonnais via #238
- New vignette on splitting large queries thanks to @Machin6 (via #262)

## Minor changes:

- New dependency on `reproj` package, so that `trim_osmdata()` can be applied
  to re-projected coordinates.

0.1.8
===================

## Minor changes:

- Fix some failing CRAN checks (no change to functionality)


0.1.7
===================

## Minor changes:

- `add_osm_feature` bug fix to revert AND behaviour (#240 thanks to @anthonynorth)

# $NetBSD: Makefile,v 1.3 2024/11/29 15:31:15 mef Exp $

R_PKGNAME=	osmdata
R_PKGVER=	0.2.5
CATEGORIES=	geography

MAINTAINER=	pkgsrc-users@NetBSD.org
COMMENT=	Import 'OpenStreetMap' Data as Simple Features or Spatial Objects
LICENSE=	gnu-gpl-v3

DEPENDS+=	R-Rcpp-[0-9]*:../../devel/R-Rcpp
DEPENDS+=	R-crsmeta-[0-9]*:../../geography/R-crsmeta
DEPENDS+=	R-curl>=4.2:../../www/R-curl
DEPENDS+=	R-httr>=1.4.1:../../www/R-httr
DEPENDS+=	R-httr2-[0-9]*:../../www/R-httr2
DEPENDS+=	R-jsonlite>=1.6:../../textproc/R-jsonlite
DEPENDS+=	R-lubridate>=1.7.4:../../time/R-lubridate
DEPENDS+=	R-magrittr>=1.5:../../devel/R-magrittr
DEPENDS+=	R-proj4-[0-9]*:../../geography/R-proj4
DEPENDS+=	R-reproj-[0-9]*:../../geography/R-reproj
DEPENDS+=	R-rvest>=0.3.5:../../www/R-rvest
DEPENDS+=	R-sp>=1.3.1:../../math/R-sp
DEPENDS+=	R-tibble>=2.1.3:../../math/R-tibble
DEPENDS+=	R-xml2>=1.2.2nb1:../../textproc/R-xml2

# Package suggested but not available: 'httptest2'

TEST_DEPENDS+=	R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+=	R-markdown-[0-9]*:../../textproc/R-markdown
TEST_DEPENDS+=	R-raster-[0-9]*:../../geography/R-raster
TEST_DEPENDS+=	R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown
TEST_DEPENDS+=	R-sf-[0-9]*:../../geography/R-sf
TEST_DEPENDS+=	R-testthat-[0-9]*:../../devel/R-testthat

USE_LANGUAGES=	c c++

.include "../../math/R/Makefile.extension"
.include "../../devel/R-Rcpp/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>