[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / wxhugo

File: [cvs.NetBSD.org] / pkgsrc / games / wxhugo / Attic / Makefile (download)

Revision 1.32, Sat Oct 6 11:54:58 2012 UTC (10 years, 11 months ago) by asau
Branch: MAIN
Changes since 1.31: +1 -3 lines

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.32 2012/10/06 11:54:58 asau Exp $
#

DISTNAME=	hugov31_unix_source
PKGNAME=	wxhugo-3.1.02
PKGREVISION=	19
CATEGORIES=	games
MASTER_SITES=	${MASTER_SITE_IFARCHIVE:=programming/hugo/source/}
DISTFILES=	${DISTNAME}${EXTRACT_SUFX} ${DISTFILE_WX}

MAINTAINER=	dillo@NetBSD.org
HOMEPAGE=	http://www.generalcoffee.com/hugo.html
COMMENT=	Interactive fiction interpreter with sound and graphics support

DISTFILE_WX=	hugov31_wxwin_source${EXTRACT_SUFX}
#EXTRACT_ONLY=	${DISTNAME}${EXTRACT_SUFX}

DIST_SUBDIR=	hugo-3.1.02
USE_LANGUAGES=	c c++
USE_TOOLS+=	gmake
WRKSRC=		${WRKDIR}/hugov3.1.02/hewx

# The gcc-2.95 Preprocessor chokes on DOS line-ends in macro continuations
SUBST_CLASSES+=		dos_eol
SUBST_MESSAGE.dos_eol=	Removing DOS line-ends
SUBST_STAGE.dos_eol=	post-extract
SUBST_FILES.dos_eol=	*.c *.cpp */*.c */*.cpp */*/*.c */*/*.cpp
SUBST_FILTER_CMD.dos_eol=	${TR} -d '\r'

INSTALLATION_DIRS=	bin

.include "../../audio/libmikmod/buildlink3.mk"
.include "../../x11/wxGTK24/buildlink3.mk"

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/hewx ${DESTDIR}${PREFIX}/bin

.include "../../mk/bsd.pkg.mk"