[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / games / wesnoth

File: [cvs.NetBSD.org] / pkgsrc / games / wesnoth / Makefile (download)

Revision 1.22, Wed Dec 7 17:57:38 2005 UTC (18 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.21: +2 -2 lines

Update to 1.0.2:

Version 1.0.2:
 * new utilities: prkill, find-unused-images, mkdos
 * fixed text savegames (as opposed to binary savegames) having wrong
 textdomain information, making the messages be displayed in English when
 loading levels (#4454).
 * backport fix for Create Unit menu not being translated (#4424)
 * graphics:
   * improved lava-tiles and transitions
   * new attack icon for the fireball
   * new paved road
   * new swamp tiles
   * new cave wall tiles
   * new snow villages (human & elven)
   * new underground village
   * new Deep Tentacle images
   * new death animation: Deep Tentacle
 * sounds:
   * New entangle sound
   * New bat movement sound
 * language and i18n:
   * updated translations: Afrikaans, German, Japanese, Polish,
     Portuguese (Brazil), Slovak
 * multiplayer
   * revised multiplayer maps: Blitz, Clash, Charge, CastleHoppingIsle,
     Hamlets, Hornshark Island, Meteor Lake, Sablestone Delta, Sullas Ruins,
     Smallolof
   * fixed gamelist diff bug
 * Fix bug where duplicate key values were being concatenated rather than
   being replaced by the last value.
 * Backport recall fix to allow access to recall list when short on gold.
 * Fix bug with leader starting position.
 * Tighten up checks on leaders and units placed on the map at the start of
   a scenario.
 * Campaigns
   * Fix bug in HTTP FoA where a serpent leader was defined off board instead
     of using the no_leader attribute.
   * Fix bug in TDH UP where units are placed off map and in walls.
   * Fix bug in EI NO where no_leader should have been used instead of a leader
     without a starting position.
   * Fix bug in EI OT where no_leader should have been used instead of a leader
     without a starting position.
   * Fix bug in EI Captured where no_leader should have been used instead of a
     leader without a starting position.
   * Fix bug in EI TD. Sides 3 and 4 had leaders on the recall list. These
     units have speaking roles, but shouldn't be on the map, so they were
     changed to be regular units.
   * Fix bug in SotBE DoD where no_leader should have been used instead of a
     leader without a starting position.
   * Fix bug in SotBE CoA where the mermen side should have their leader
     created in an event rather than defined in the side setup.
   * Add a backup save_id to use if both save_id and description are empty.
   * Increase maximum allowed recursion depth. The previous limit was
     being reached in "The Heist".
 * Replace all calls to sprintf with snprintf to prevent buffer overflow
   attacks from other players in multiplayer games or from downloaded
   campaigns.

# $NetBSD: Makefile,v 1.22 2005/12/07 17:57:38 wiz Exp $

DISTNAME=	wesnoth-1.0.2
CATEGORIES=	games
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=wesnoth/}

MAINTAINER=	wiz@NetBSD.org
HOMEPAGE=	http://www.wesnoth.org/
COMMENT=	Fantasy turn-based strategy game

USE_TOOLS+=		pkg-config
HAS_CONFIGURE=		yes
CONFIGURE_ARGS+=	--prefix=${PREFIX:Q}

UNLIMIT_RESOURCES+=	datasize

BUILDLINK_DEPENDS.SDL+=		SDL>=1.2.7
BUILDLINK_DEPENDS.SDL_mixer+=	SDL_mixer>=1.2.5nb3

.include "../../audio/SDL_mixer/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
# configure script in 0.9.0 requests explicitly to
# use included SDL_ttf library
#.include "../../devel/SDL_ttf/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../net/SDL_net/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"